From: SJ Park <sj@kernel.org>
To: xu.xin16@zte.com.cn
Cc: SJ Park <sj@kernel.org>,
akpm@linux-foundation.org, david@kernel.org, ljs@kernel.org,
ziy@nvidia.com, baolin.wang@linux.alibaba.com, baohua@kernel.org,
lance.yang@linux.dev, usama.arif@linux.dev,
chengming.zhou@linux.dev, qi.zheng@linux.dev, npache@redhat.com,
ryan.roberts@arm.com, dev.jain@arm.com, linux-mm@kvack.org,
linux-kernel@vger.kernel.org, wang.yaxin@zte.com.cn
Subject: Re: [PATCH v3 2/2] mm/mm_slot.h: add comments for mm_slot_lookup/insert
Date: Tue, 14 Jul 2026 17:25:43 -0700 [thread overview]
Message-ID: <20260715002543.106162-1-sj@kernel.org> (raw)
In-Reply-To: <20260714092815120Wv-CFDlLKtsTmda--97Qw@zte.com.cn>
On Tue, 14 Jul 2026 09:28:15 +0800 (CST) <xu.xin16@zte.com.cn> wrote:
> From: xu xin <xu.xin16@zte.com.cn>
>
> mm_slot_lookup() and mm_slot_insert() are the only helpers in
> this header that are implemented as macros rather than static inline
> functions. This may look inconsistent without explanation.
>
> Explain they must be macros because hash_for_each_possible()
> needs the table as an array (for sizeof), not a pointer.
Thank you for adding the explanation!
>
> Signed-off-by: xu xin <xu.xin16@zte.com.cn>
Reviewed-by: SJ Park <sj@kernel.org>
Thanks,
SJ
[...]
next prev parent reply other threads:[~2026-07-15 0:25 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-14 1:24 [PATCH v3 0/2] Two small patches to clean up mm/mm_slot.h xu.xin16
2026-07-14 1:26 ` [PATCH v3 1/2] mm/mm_slot.h: add a helper function mm_slot_remove xu.xin16
2026-07-14 1:28 ` [PATCH v3 2/2] mm/mm_slot.h: add comments for mm_slot_lookup/insert xu.xin16
2026-07-14 1:37 ` Barry Song
2026-07-14 9:35 ` Lorenzo Stoakes (ARM)
2026-07-14 9:44 ` Qi Zheng
2026-07-14 13:26 ` David Hildenbrand (Arm)
2026-07-15 0:25 ` SJ Park [this message]
2026-07-15 1:10 ` Zi Yan
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260715002543.106162-1-sj@kernel.org \
--to=sj@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=baohua@kernel.org \
--cc=baolin.wang@linux.alibaba.com \
--cc=chengming.zhou@linux.dev \
--cc=david@kernel.org \
--cc=dev.jain@arm.com \
--cc=lance.yang@linux.dev \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=ljs@kernel.org \
--cc=npache@redhat.com \
--cc=qi.zheng@linux.dev \
--cc=ryan.roberts@arm.com \
--cc=usama.arif@linux.dev \
--cc=wang.yaxin@zte.com.cn \
--cc=xu.xin16@zte.com.cn \
--cc=ziy@nvidia.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.