From: sashiko-bot@kernel.org
To: Frank.Li@oss.nxp.com
Cc: devicetree@vger.kernel.org, imx@lists.linux.dev, robh@kernel.org,
dri-devel@lists.freedesktop.org, conor+dt@kernel.org,
Frank.Li@kernel.org
Subject: Re: [PATCH v2 7/7] arm64: dts: imx8dxl-evk: add lcdif overlay
Date: Wed, 15 Jul 2026 19:10:30 +0000 [thread overview]
Message-ID: <20260715191030.CA6511F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260715-dxl_lcdif-v2-7-da797562636e@nxp.com>
Thank you for your contribution! Sashiko AI review found 3 potential issue(s) to consider:
- [Medium] The overlay configures the ADC input pads for LCD digital signals but fails to disable the `adc0` controller.
- [Low] The panel device node is named `lcd-panel`, which violates the standard Device Tree bindings for display panels.
- [Low] The overlay disables audio codecs and DAIs but leaves the top-level sound card nodes enabled, causing endless probe deferrals.
--
--- Patch [7]: [PATCH v2 7/7] arm64: dts: imx8dxl-evk: add lcdif overlay ---
(Note: The format of this report is altered to a free-form summary due to
recitation restrictions. No code from the original patch is directly quoted.)
commit d5a124bf1de36e3cda648d2a3efe1d55a60da419
Author: Frank Li <Frank.Li@nxp.com>
arm64: dts: imx8dxl-evk: add lcdif overlay
This commit adds support for the waiken,101wx001 lcd panel by introducing
a new device tree overlay for the imx8dxl-evk.
[Severity: Low]
The device node for the display panel in the new overlay is named lcd-panel.
Does this violate the standard Device Tree bindings for display panels?
According to panel-common.yaml, the generic node name for a display panel
should typically just be panel. Using a non-generic name could result in
dtbs_check warnings when building the device tree.
[Severity: Medium]
The pinctrl_lcdif node configures several ADC input pads to act as digital
LCD signals. However, the overlay does not appear to disable the corresponding
adc0 controller. Will this cause the adc0 controller to probe and expose
non-functional IIO channels to userspace, potentially resulting in
applications reading meaningless garbage instead of valid analog voltages?
[Severity: Low]
The overlay disables several audio codecs and DAIs, such as sai0, sai1, and
the various wm8960 components, but it leaves the top-level sound card nodes
from the base device tree enabled. Could this result in the sound card
drivers attempting to probe and failing indefinitely with probe deferrals,
leaving dangling devices in the deferred list during system initialization?
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260715-dxl_lcdif-v2-0-da797562636e@nxp.com?part=7
prev parent reply other threads:[~2026-07-15 19:10 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-15 18:34 [PATCH v2 0/7] display: lcdif: imx: add display support for imx8dxl and imx8qxp Frank.Li
2026-07-15 18:34 ` [PATCH v2 1/7] dt-bindings: lcdif: add compatible string for i.MX8QXP and i.MX8DXL Frank.Li
2026-07-15 18:34 ` [PATCH v2 2/7] dt-bindings: display: simple: Add waiken,101wx001 Frank.Li
2026-07-15 18:34 ` [PATCH v2 3/7] drm/panel: simple: Add waiken WKS101WX001-WCT support Frank.Li
2026-07-15 18:34 ` [PATCH v2 4/7] arm64: dts: imx8-ss-dma: Add lcdif support for i.MX8QXP and i.MX8DXL Frank.Li
2026-07-15 18:48 ` sashiko-bot
2026-07-15 18:34 ` [PATCH v2 5/7] arm64: dts: imx8dxl-evk: Add onboard GPIO mux controller Frank.Li
2026-07-15 18:53 ` sashiko-bot
2026-07-15 19:04 ` Frank Li
2026-07-15 18:34 ` [PATCH v2 6/7] arm64: dts: imx8dxl-evk: Move ACM MCLK pin to ACM pinctrl Frank.Li
2026-07-15 18:41 ` sashiko-bot
2026-07-15 18:34 ` [PATCH v2 7/7] arm64: dts: imx8dxl-evk: add lcdif overlay Frank.Li
2026-07-15 19:10 ` sashiko-bot [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260715191030.CA6511F000E9@smtp.kernel.org \
--to=sashiko-bot@kernel.org \
--cc=Frank.Li@kernel.org \
--cc=Frank.Li@oss.nxp.com \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=imx@lists.linux.dev \
--cc=robh@kernel.org \
--cc=sashiko-reviews@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.