All of lore.kernel.org
 help / color / mirror / Atom feed
From: sashiko-bot@kernel.org
To: "SJ Park" <sj@kernel.org>
Cc: damon@lists.linux.dev
Subject: Re: [RFC PATCH 04/17] Docs/mm/damon/design: document pgidle_unset probe filter type
Date: Sat, 25 Jul 2026 21:05:25 +0000	[thread overview]
Message-ID: <20260725210525.8D4CD1F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260725210225.129944-5-sj@kernel.org>

Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Low] Typos and grammatically awkward phrasing in the newly added documentation.
--

--- Patch [4]: [RFC PATCH 04/17] Docs/mm/damon/design: document pgidle_unset probe filter type ---
commit 616f638e60cd5170d7a26046797874f2e31071a4
Author: SJ Park <sj@kernel.org>

Docs/mm/damon/design: document pgidle_unset probe filter type
    
This commit updates the DAMON design document to include the newly added
pgidle_unset probe filter type. It also formats the supported filter types
into a list for improved readability.

> diff --git a/Documentation/mm/damon/design.rst b/Documentation/mm/damon/design.rst
> index aed6cb1cf4831..d9f64e9ae2879 100644
> --- a/Documentation/mm/damon/design.rst
> +++ b/Documentation/mm/damon/design.rst
> @@ -293,8 +293,14 @@ registration is made by specifying a probe per attribute.  Each of the probe
>  specifies a rule to determine if a given memory region has the related
>  attribute.  The rule is constructed with multiple filters.  The filters work
>  same to :ref:`DAMOS filters <damon_design_damos_filters>` except the supported
> -filter types.  Currently only ``anon`` and ``memcg`` filter types are supported
> -for data attributes monitoring.
> +filter types.  Currently below fitler types are supported.

[Severity: Low]
This isn't a bug, but there is a typo here ("fitler" instead of "filter").

> +
> +- ``anon``: Same to that for DAMOS filters.
> +- ``memcg``: Same to that for DAMOS filters.
> +- ``pgidle_unset``: Matches if the page for the memory is marked as not
> +  access-idle.
> +  Matches if the memory is not backed by pages that DAMON can idnetify

[Severity: Low]
This isn't a bug, but there is a typo here ("idnetify" instead of "identify").
Could this phrasing also be slightly adjusted for better flow? Something like
"pages for which DAMON can identify idleness" might read more naturally.

> +  idleness.
>  
>  If such probes are registered, DAMON executes the probes for each region's
>  sampling memory when it does the access :ref:`sampling

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/20260725210225.129944-1-sj@kernel.org?part=4

  reply	other threads:[~2026-07-25 21:05 UTC|newest]

Thread overview: 38+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-25 21:02 [RFC PATCH 00/17] mm/damon: introduce data access-as-a-data attribute SJ Park
2026-07-25 21:02 ` [RFC PATCH 01/17] mm/damon/core: introduce DAMON_FILTER_TYPE_PGIDLE_UNSET SJ Park
2026-07-25 21:11   ` sashiko-bot
2026-07-25 21:28     ` SJ Park
2026-07-25 21:02 ` [RFC PATCH 02/17] mm/damon/paddr: support PGIDLE_UNSET probe filter type SJ Park
2026-07-25 21:17   ` sashiko-bot
2026-07-25 21:30     ` SJ Park
2026-07-25 21:02 ` [RFC PATCH 03/17] mm/damon/sysfs: support pgidle_unset " SJ Park
2026-07-25 21:02 ` [RFC PATCH 04/17] Docs/mm/damon/design: document " SJ Park
2026-07-25 21:05   ` sashiko-bot [this message]
2026-07-25 21:39     ` SJ Park
2026-07-25 21:02 ` [RFC PATCH 05/17] mm/damon/core: introduce damon_prep struct SJ Park
2026-07-25 21:02 ` [RFC PATCH 06/17] mm/damon/core: commit preps SJ Park
2026-07-25 21:02 ` [RFC PATCH 07/17] mm/damon/core: introduce damon_operations->prep_probes() SJ Park
2026-07-25 21:14   ` sashiko-bot
2026-07-25 21:52     ` SJ Park
2026-07-25 21:02 ` [RFC PATCH 08/17] mm/damon/paddr: support damon_prep SJ Park
2026-07-25 21:15   ` sashiko-bot
2026-07-25 21:54     ` SJ Park
2026-07-25 21:02 ` [RFC PATCH 09/17] mm/damon/sysfs: implement preps directory SJ Park
2026-07-25 21:13   ` sashiko-bot
2026-07-25 21:57     ` SJ Park
2026-07-25 21:02 ` [RFC PATCH 10/17] mm/damon/sysfs: create probe " SJ Park
2026-07-25 21:02 ` [RFC PATCH 11/17] mm/damon/sysfs: implement probe prep directory SJ Park
2026-07-25 21:10   ` sashiko-bot
2026-07-25 21:59     ` SJ Park
2026-07-25 21:02 ` [RFC PATCH 12/17] mm/damon/sysfs: create probe prep files for preps/nr file write SJ Park
2026-07-25 21:02 ` [RFC PATCH 13/17] mm/damon/sysfs: pass preps to DAMON core SJ Park
2026-07-25 21:02 ` [RFC PATCH 14/17] selftests/damon/sysfs.sh: test probe prep sysfs files SJ Park
2026-07-25 21:02 ` [RFC PATCH 15/17] Docs/mm/damon/design: document probe preps SJ Park
2026-07-25 21:06   ` sashiko-bot
2026-07-25 22:00     ` SJ Park
2026-07-25 21:02 ` [RFC PATCH 16/17] Docs/admin-guide/mm/damon/usage: document probe preps sysfs files SJ Park
2026-07-25 21:08   ` sashiko-bot
2026-07-25 22:06     ` SJ Park
2026-07-25 21:02 ` [RFC PATCH 17/17] Docs/ABI/damon: document probe prep " SJ Park
2026-07-25 21:12   ` sashiko-bot
2026-07-25 22:09     ` SJ Park

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260725210525.8D4CD1F000E9@smtp.kernel.org \
    --to=sashiko-bot@kernel.org \
    --cc=damon@lists.linux.dev \
    --cc=sashiko-reviews@lists.linux.dev \
    --cc=sj@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.