From: sashiko-bot@kernel.org
To: "Pawel Zalewski (The Capable Hub)" <pzalewski@thegoodpenguin.co.uk>
Cc: linux-pci@vger.kernel.org, nvdimm@lists.linux.dev
Subject: Re: [PATCH 3/9] ACPI: pci: drop unused assignment of acpi_device_id::driver_data
Date: Mon, 27 Jul 2026 12:16:01 +0000 [thread overview]
Message-ID: <20260727121601.996E11F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260727-acpi-refactor-v1-3-ff900aa326ee@thegoodpenguin.co.uk>
> These modules set the acpi_device_id::driver_data to 0 but
> the field is not actually used within the module, we can
> just drop it from the table.
>
> While we are at it - used a named initializer for the
> acpi_device_id::id field to increase readability and
> drop explicitly setting the list terminator fields.
>
> Signed-off-by: Pawel Zalewski (The Capable Hub) <pzalewski@thegoodpenguin.co.uk>
Sashiko has reviewed this patch and found no issues. It looks great!
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260727-acpi-refactor-v1-0-ff900aa326ee@thegoodpenguin.co.uk?part=3
next prev parent reply other threads:[~2026-07-27 12:16 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-27 12:10 [PATCH 0/9] ACPI: use named initializers for acpi_device_id Pawel Zalewski (The Capable Hub)
2026-07-27 12:10 ` [PATCH 1/9] ACPI: use a named initializer " Pawel Zalewski (The Capable Hub)
2026-07-27 12:17 ` sashiko-bot
2026-07-27 12:10 ` [PATCH 2/9] ACPI: drop unused assignment of acpi_device_id::driver_data Pawel Zalewski (The Capable Hub)
2026-07-27 12:17 ` sashiko-bot
2026-07-27 12:10 ` [PATCH 3/9] ACPI: pci: " Pawel Zalewski (The Capable Hub)
2026-07-27 12:16 ` sashiko-bot [this message]
2026-07-27 12:10 ` [PATCH 4/9] ACPI: ghes-nvidia: use a named initializer for acpi_device_id::id Pawel Zalewski (The Capable Hub)
2026-07-27 12:14 ` sashiko-bot
2026-07-27 12:10 ` [PATCH 5/9] ACPI: amba: drop unused assignment of acpi_device_id::driver_data Pawel Zalewski (The Capable Hub)
2026-07-27 12:16 ` sashiko-bot
2026-07-27 12:10 ` [PATCH 6/9] ACPI: dptf: " Pawel Zalewski (The Capable Hub)
2026-07-27 12:14 ` sashiko-bot
2026-07-27 12:10 ` [PATCH 7/9] ACPI: nfit: core: " Pawel Zalewski (The Capable Hub)
2026-07-27 12:15 ` sashiko-bot
2026-07-27 12:10 ` [PATCH 8/9] ACPI: x86: use a named initializer for acpi_device_id::id Pawel Zalewski (The Capable Hub)
2026-07-27 12:15 ` sashiko-bot
2026-07-27 12:10 ` [PATCH 9/9] ACPI: " Pawel Zalewski (The Capable Hub)
2026-07-27 12:17 ` sashiko-bot
2026-07-27 12:15 ` [PATCH 0/9] ACPI: use named initializers for acpi_device_id Rafael J. Wysocki (Intel)
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260727121601.996E11F000E9@smtp.kernel.org \
--to=sashiko-bot@kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=nvdimm@lists.linux.dev \
--cc=pzalewski@thegoodpenguin.co.uk \
--cc=sashiko-reviews@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.