All of lore.kernel.org
 help / color / mirror / Atom feed
From: sashiko-bot@kernel.org
To: "Mikhail Kshevetskiy" <mikhail.kshevetskiy@iopsys.eu>
Cc: robh@kernel.org, conor+dt@kernel.org, devicetree@vger.kernel.org
Subject: Re: [PATCH v9 16/36] pinctrl: airoha: minor improvements
Date: Tue, 04 Aug 2026 16:23:19 +0000	[thread overview]
Message-ID: <20260804162319.6A8331F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260804160419.3592327-17-mikhail.kshevetskiy@iopsys.eu>

Thank you for your contribution! Sashiko AI review found 2 potential issue(s) to consider:

New issues:
- [Low] The newly added function-scoped `err` variable is shadowed by an existing local `err` variable inside the switch statement.

Pre-existing issues:
- [High] The commit adds missing error checks for PIN_CONFIG_BIAS_* settings but fails to do the same for PIN_CONFIG_DRIVE_STRENGTH and PIN_CONFIG_DRIVE_OPEN_DRAIN in the same switch statement.
--

--- Patch [16]: [PATCH v9 16/36] pinctrl: airoha: minor improvements ---
commit f4dfe61b91abddcba631650033db26be051c2e35
Author: Mikhail Kshevetskiy <mikhail.kshevetskiy@iopsys.eu>

pinctrl: airoha: minor improvements

Changes:
 * use field_get() macro instead of direct bit operations
 * improve error handling

> diff --git a/drivers/pinctrl/airoha/pinctrl-airoha.c b/drivers/pinctrl/airoha/pinctrl-airoha.c
> index e4ccf357df892..f982a75d4253e 100644
> --- a/drivers/pinctrl/airoha/pinctrl-airoha.c
> +++ b/drivers/pinctrl/airoha/pinctrl-airoha.c
[ ... ]
> @@ -2996,7 +2996,7 @@ static int airoha_pinconf_set(struct pinctrl_dev *pctrl_dev,
>  			      unsigned int num_configs)
>  {
>  	struct airoha_pinctrl *pinctrl = pinctrl_dev_get_drvdata(pctrl_dev);
> -	int i;
> +	int i, err;

[Severity: Low]
Does the inner err declaration inside the PIN_CONFIG_OUTPUT_ENABLE block
shadow this newly added function-scoped err variable?

drivers/pinctrl/airoha/pinctrl-airoha.c:airoha_pinconf_set() {
    ...
		case PIN_CONFIG_OUTPUT_ENABLE:
		case PIN_CONFIG_INPUT_ENABLE:
		case PIN_CONFIG_LEVEL: {
			bool input = param == PIN_CONFIG_INPUT_ENABLE;
			int err;
    ...
}

This could trigger -Wshadow compiler warnings.

>  
>  	for (i = 0; i < num_configs; i++) {
>  		u32 param = pinconf_to_config_param(configs[i]);
[ ... ]
>  		case PIN_CONFIG_BIAS_PULL_DOWN:
> -			airoha_pinctrl_set_pulldown_conf(pinctrl, pin, 1);
> -			airoha_pinctrl_set_pullup_conf(pinctrl, pin, 0);
> +			err = airoha_pinctrl_set_pulldown_conf(pinctrl, pin, 1);
> +			if (err)
> +				return err;
> +
> +			err = airoha_pinctrl_set_pullup_conf(pinctrl, pin, 0);
> +			if (err)
> +				return err;
> +
>  			break;
>  		case PIN_CONFIG_DRIVE_STRENGTH: {
>  			u32 e2 = 0, e4 = 0;

[Severity: High]
This is a pre-existing issue, but since this patch improves error handling for
the PIN_CONFIG_BIAS_* settings, shouldn't we also check the return values for
PIN_CONFIG_DRIVE_STRENGTH and PIN_CONFIG_DRIVE_OPEN_DRAIN in the same switch
statement?

drivers/pinctrl/airoha/pinctrl-airoha.c:airoha_pinconf_set() {
    ...
			airoha_pinctrl_set_drive_e2_conf(pinctrl, pin, e2);
			airoha_pinctrl_set_drive_e4_conf(pinctrl, pin, e4);
			break;
		}
		case PIN_CONFIG_DRIVE_OPEN_DRAIN:
			airoha_pinctrl_set_pcie_rst_od_conf(pinctrl, pin, !!arg);
			break;
    ...
}

If a caller requests these configurations on a pin that does not support them,
the underlying airoha_pinctrl_get_conf_reg() returns NULL, causing
airoha_pinctrl_set_conf() to return -EINVAL.

Because the macro invocations ignore this return value, airoha_pinconf_set()
silently succeeds. Could this make board bring-up or device configuration bugs
hard to debug?

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/20260804160419.3592327-1-mikhail.kshevetskiy@iopsys.eu?part=16

  reply	other threads:[~2026-08-04 16:23 UTC|newest]

Thread overview: 58+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-04 16:03 [PATCH v9 00/36] pinctrl: airoha: split on shared and SoC drivers, add more SoCs Mikhail Kshevetskiy
2026-08-04 16:03 ` [PATCH v9 01/36] dt-bindings: pinctrl: airoha: en7581: fix misprint in i2s function name Mikhail Kshevetskiy
2026-08-04 16:03 ` [PATCH v9 02/36] dt-bindings: pinctrl: airoha: an7583: fix device tree binding schema Mikhail Kshevetskiy
2026-08-04 16:03 ` [PATCH v9 03/36] pinctrl: airoha: fix mdio bitfield names Mikhail Kshevetskiy
2026-08-04 16:03 ` [PATCH v9 04/36] pinctrl: airoha: an7581: fix pinconf of i2c_scl/i2c_sda pins Mikhail Kshevetskiy
2026-08-04 16:03 ` [PATCH v9 05/36] pinctrl: airoha: an7583: fix I2C0_SDA_PD register bit order Mikhail Kshevetskiy
2026-08-04 16:03 ` [PATCH v9 06/36] pinctrl: airoha: an7581: fix mux/conf of pcie_reset pins Mikhail Kshevetskiy
2026-08-04 16:27   ` sashiko-bot
2026-08-04 16:03 ` [PATCH v9 07/36] dt-bindings: pinctrl: airoha: en7581: allow configuration of pcie_reset pins as gpio or pwm Mikhail Kshevetskiy
2026-08-04 16:03 ` [PATCH v9 08/36] pinctrl: airoha: an7583: fix muxing of non-gpio default pins Mikhail Kshevetskiy
2026-08-04 16:03 ` [PATCH v9 09/36] dt-bindings: pinctrl: airoha: an7583: allow configuration of non-gpio default pins as gpio and pwm Mikhail Kshevetskiy
2026-08-04 16:03 ` [PATCH v9 10/36] pinctrl: airoha: fix I2C1 pin mux config for AN7581 Mikhail Kshevetskiy
2026-08-04 16:28   ` sashiko-bot
2026-08-04 16:03 ` [PATCH v9 11/36] pinctrl: airoha: fix I2C pin mux config for AN7583 Mikhail Kshevetskiy
2026-08-04 16:03 ` [PATCH v9 12/36] pinctrl: airoha: fix AN7583 MDIO pin mux config Mikhail Kshevetskiy
2026-08-04 16:28   ` sashiko-bot
2026-08-04 16:03 ` [PATCH v9 13/36] pinctrl: airoha: an7583: fix spi group pins Mikhail Kshevetskiy
2026-08-04 16:03 ` [PATCH v9 14/36] pinctrl: airoha: add missed get_direction() function for gpio_chip Mikhail Kshevetskiy
2026-08-04 16:26   ` sashiko-bot
2026-08-04 16:03 ` [PATCH v9 15/36] pinctrl: airoha: add set_direction() helper " Mikhail Kshevetskiy
2026-08-04 16:26   ` sashiko-bot
2026-08-04 16:03 ` [PATCH v9 16/36] pinctrl: airoha: minor improvements Mikhail Kshevetskiy
2026-08-04 16:23   ` sashiko-bot [this message]
2026-08-04 16:04 ` [PATCH v9 17/36] pinctrl: airoha: fix getting gpiochip/pinctrl pointers in the IRQ handling code Mikhail Kshevetskiy
2026-08-04 16:04 ` [PATCH v9 18/36] pinctrl: airoha: add missed IRQ resource helpers Mikhail Kshevetskiy
2026-08-04 16:24   ` sashiko-bot
2026-08-04 16:04 ` [PATCH v9 19/36] pinctrl: airoha: fix IRQ mask/unmask code Mikhail Kshevetskiy
2026-08-04 16:32   ` sashiko-bot
2026-08-04 16:04 ` [PATCH v9 20/36] pinctrl: airoha: fix edge-triggered interrupts handling Mikhail Kshevetskiy
2026-08-04 16:23   ` sashiko-bot
2026-08-04 16:04 ` [PATCH v9 21/36] pinctrl: airoha: remove not needed irq_type[] array Mikhail Kshevetskiy
2026-08-04 16:04 ` [PATCH v9 22/36] pinctrl: airoha: statically allocate gpio regs structure Mikhail Kshevetskiy
2026-08-04 16:30   ` sashiko-bot
2026-08-04 16:04 ` [PATCH v9 23/36] pinctrl: airoha: move common definitions to the separate header Mikhail Kshevetskiy
2026-08-04 16:04 ` [PATCH v9 24/36] pinctrl: airoha: split driver on shared code and SoC specific drivers Mikhail Kshevetskiy
2026-08-04 16:38   ` sashiko-bot
2026-08-04 16:04 ` [PATCH v9 25/36] pinctrl: airoha: an7581: remove en7581 prefix from variable names Mikhail Kshevetskiy
2026-08-04 16:04 ` [PATCH v9 26/36] pinctrl: airoha: an7583: remove an7583 prefix from variable names and definitions Mikhail Kshevetskiy
2026-08-04 16:04 ` [PATCH v9 27/36] pinctrl: airoha: an7583: rename registers to match its an7583 names Mikhail Kshevetskiy
2026-08-04 16:04 ` [PATCH v9 28/36] pinctrl: airoha: an7583: add support for npu_uart pinmux Mikhail Kshevetskiy
2026-08-04 16:30   ` sashiko-bot
2026-08-04 16:04 ` [PATCH v9 29/36] pinctrl: airoha: an7583: add support for pon_alt pinmux Mikhail Kshevetskiy
2026-08-04 16:29   ` sashiko-bot
2026-08-04 16:04 ` [PATCH v9 30/36] pinctrl: airoha: an7583: add support for olt pinmux Mikhail Kshevetskiy
2026-08-04 16:38   ` sashiko-bot
2026-08-04 16:04 ` [PATCH v9 31/36] dt-bindings: pinctrl: airoha: an7583: add missed features Mikhail Kshevetskiy
2026-08-04 16:04 ` [PATCH v9 32/36] pinctrl: airoha: add support of en7523 SoC Mikhail Kshevetskiy
2026-08-04 16:44   ` sashiko-bot
2026-08-04 16:04 ` [PATCH v9 33/36] pinctrl: airoha: try to find chip scu node by phandle first Mikhail Kshevetskiy
2026-08-04 16:30   ` sashiko-bot
2026-08-04 16:04 ` [PATCH v9 34/36] dt-bindings: pinctrl: airoha: add support of en7523 pin controller Mikhail Kshevetskiy
2026-08-04 16:34   ` sashiko-bot
2026-08-04 18:19   ` Rob Herring (Arm)
2026-08-04 16:04 ` [PATCH v9 35/36] pinctrl: airoha: add support of an7563 SoC Mikhail Kshevetskiy
2026-08-04 16:35   ` sashiko-bot
2026-08-04 16:04 ` [PATCH v9 36/36] dt-bindings: pinctrl: airoha: add support of an7563 pin controller Mikhail Kshevetskiy
2026-08-04 16:33   ` sashiko-bot
2026-08-04 18:19   ` Rob Herring (Arm)

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260804162319.6A8331F000E9@smtp.kernel.org \
    --to=sashiko-bot@kernel.org \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=mikhail.kshevetskiy@iopsys.eu \
    --cc=robh@kernel.org \
    --cc=sashiko-reviews@lists.linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.