From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from bombadil.infradead.org (bombadil.infradead.org [198.137.202.133]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.lore.kernel.org (Postfix) with ESMTPS id E6DA3C5CFCF for ; Tue, 11 Aug 2026 16:26:59 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=lists.infradead.org; s=bombadil.20210309; h=Sender:List-Subscribe:List-Help :List-Post:List-Archive:List-Unsubscribe:List-Id:Content-Transfer-Encoding: MIME-Version:Message-ID:Date:Subject:Cc:To:From:Reply-To:Content-Type: Content-ID:Content-Description:Resent-Date:Resent-From:Resent-Sender: Resent-To:Resent-Cc:Resent-Message-ID:In-Reply-To:References:List-Owner; bh=OGvQP4rTfDtqzEoXAJvcK2bQDBmijHAZnmypqO/G+ig=; b=OxvNLZjamWb5XddflI84B184F/ dcalmfoPHV4h8ApYXPq682hkzrilZQdBgk1KmXq5rq472mR3P6lb4IX1UJJgu0KwUUlar8SED+2lo TpG0rugG5djcvBPz2GpikUziTgTpBtruxuzJkBBcENcrZFCfCZCbVeyiQK/n3xmMPeMX98Qm+L1+F EkfH0HRCbmJo8itAlluAr+wMiU9QK80LCUW4N4n3LI32LhBFFCB+PUp2qaYQJTiWtWQapHK3tX79J 4rT8Hmtp67z/MYNQatkwV/ONKeoA454pYNGBV050idIztfc0MzX9EiveY93t1BzVCH2ddja3oAvCt jcYCh6gA==; Received: from localhost ([::1] helo=bombadil.infradead.org) by bombadil.infradead.org with esmtp (Exim 4.99.1 #2 (Red Hat Linux)) id 1wtpJZ-0000000EUer-1xxH; Tue, 11 Aug 2026 16:26:57 +0000 Received: from sea.source.kernel.org ([172.234.252.31]) by bombadil.infradead.org with esmtps (Exim 4.99.1 #2 (Red Hat Linux)) id 1wtpJY-0000000EUeX-1Idi for kexec@lists.infradead.org; Tue, 11 Aug 2026 16:26:56 +0000 Received: from smtp.kernel.org (quasi.space.kernel.org [100.103.45.18]) by sea.source.kernel.org (Postfix) with ESMTP id E09DA41B39; Tue, 11 Aug 2026 16:26:55 +0000 (UTC) Received: by smtp.kernel.org (Postfix) with ESMTPSA id A986B1F000E9; Tue, 11 Aug 2026 16:26:50 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=kernel.org; s=k20260515; t=1786465615; bh=OGvQP4rTfDtqzEoXAJvcK2bQDBmijHAZnmypqO/G+ig=; h=From:To:Cc:Subject:Date; b=Kc0kfLnPcphAgE8pEpNIHiPSnSgqFFYu15OAJQ7689fKkqv0uf1xN82X5BlruxAb1 +QVheRnjiKkms31uMeLjbXRXjCDUv1b9wMj7Jc4/37XsdoPzk0PpeWcKnzFsCskDad 3M5L/b1LIofah7chZsD+zQsUXHu1kuet+PjZNkK9Me6xjUHa2eJdBQqflG1+XMsM3j XE5e/yHWpgYWKrwLBhPnIIRraVzU2xdL8C8PKw9C6Ij+qaXpn2jUUQZJeIczgziF9s ElLR4CbM64NIqFwOnGyZ/9M+nVw8Iv9jKkhYqH0wffo9OJu96GCbogJE95ESCBYFOT vJQeGUOX5+yVA== From: Pratyush Yadav To: Jonathan Corbet , Shuah Khan , Mike Rapoport , Pasha Tatashin , Pratyush Yadav , Alexander Graf , Andrew Morton , David Hildenbrand , Lorenzo Stoakes , "Liam R. Howlett" , Vlastimil Babka , Suren Baghdasaryan , Michal Hocko , Thomas Gleixner , Ingo Molnar , Borislav Petkov , Dave Hansen , "H. Peter Anvin" , Ard Biesheuvel , Ilias Apalodimas , Rob Herring , Saravana Kannan , Arnd Bergmann , Baoquan He Cc: x86@kernel.org, linux-doc@vger.kernel.org, linux-kernel@vger.kernel.org, kexec@lists.infradead.org, linux-mm@kvack.org, linux-efi@vger.kernel.org, devicetree@vger.kernel.org, linux-arch@vger.kernel.org Subject: [PATCH 0/4] kho: rename "scratch" to "bootmem" Date: Tue, 11 Aug 2026 18:26:36 +0200 Message-ID: <20260811162642.3504565-1-pratyush@kernel.org> X-Mailer: git-send-email 2.55.0.679.g6767b8d81c-goog MIME-Version: 1.0 Content-Transfer-Encoding: 8bit X-BeenThere: kexec@lists.infradead.org X-Mailman-Version: 2.1.34 Precedence: list List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: "kexec" Errors-To: kexec-bounces+kexec=archiver.kernel.org@lists.infradead.org From: "Pratyush Yadav (Google)" The term "KHO scratch" is vague and overloaded. It does not accurately describe what the memory is for. This was discussed previously at [0]. The conclusion was to rename "KHO scratch" to "KHO bootmem", since this is memory passed by the previous kernel for early boot allocations. In addition, memblock does not care about the provenance of the memory. It cares more about how it should use it. Use MEMBLOCK_KHO_NOPRSRV, instead of MEMBLOCK_KHO_SCRATCH, to describe this memory to memblock. This series does the renames. It also gets rid of a redundant Kconfig. While the diffstat is big and scary, most of the changes are mechanical. The most interesting functional change is in patch 4. This series touches a lot of files across a lot of trees. But since all of that is purely KHO-related code, I would like to collect ACKs from the maintainers and take it via the liveupdate tree. Ideally we should queue it in liveupdate/next early in the v7.4 cycle since it will cause a lot of conflicts with other patches throughout the KHO tree. [0] https://lore.kernel.org/kexec/agHGOxSnP_VraH1M@kernel.org/T/#u Pratyush Yadav (Google) (4): memblock: get rid of CONFIG_MEMBLOCK_KHO_SCRATCH memblock: rename KHO_SCRATCH to KHO_NOPRSRV kho: rename KHO scratch to KHO bootmem kho: rename kho_scratch= commandline parameter to kho_bootmem= .../admin-guide/kernel-parameters.txt | 15 +- Documentation/admin-guide/mm/kho.rst | 18 +- Documentation/core-api/kho/index.rst | 36 +- arch/x86/boot/compressed/kaslr.c | 12 +- arch/x86/include/uapi/asm/setup_data.h | 4 +- arch/x86/kernel/e820.c | 2 +- arch/x86/kernel/kexec-bzimage64.c | 6 +- arch/x86/kernel/setup.c | 2 +- arch/x86/realmode/init.c | 2 +- drivers/firmware/efi/efi-init.c | 6 +- drivers/of/kexec.c | 16 +- include/asm-generic/kexec_handover.h | 2 +- include/linux/kexec.h | 2 +- include/linux/kexec_handover.h | 16 +- include/linux/memblock.h | 30 +- kernel/liveupdate/Kconfig | 1 - kernel/liveupdate/kexec_handover.c | 340 +++++++++--------- kernel/liveupdate/kexec_handover_debugfs.c | 24 +- kernel/liveupdate/kexec_handover_internal.h | 4 +- mm/Kconfig | 4 - mm/memblock.c | 56 +-- mm/mm_init.c | 6 +- tools/testing/memblock/internal.h | 2 +- 23 files changed, 302 insertions(+), 304 deletions(-) base-commit: 352ebb57013a08679788bc18c7f9af90903db256 -- 2.55.0.679.g6767b8d81c-goog