From: sashiko-bot@kernel.org
To: "Cosmin Tanislav" <cosmin-gabriel.tanislav.xa@renesas.com>
Cc: robh@kernel.org, conor+dt@kernel.org, devicetree@vger.kernel.org,
linux-clk@vger.kernel.org, wsa+renesas@sang-engineering.com
Subject: Re: [PATCH 02/11] mfd: rz-mtu3: use device-managed reset deassert
Date: Thu, 13 Aug 2026 23:03:03 +0000 [thread overview]
Message-ID: <20260813230304.38C321F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260327192425.438263-3-cosmin-gabriel.tanislav.xa@renesas.com>
Thank you for your contribution! Sashiko AI review found 3 potential issue(s) to consider:
- [Low] The commit message description is not capitalized, violating MFD subsystem guidelines.
- [Low] Open-coding of `devm_mfd_add_devices()`.
- [Low] The newly renamed callback function 'rz_mtu3_mfd_remove' includes the string 'mfd' and the driver's name.
--
--- Patch [2]: [PATCH 02/11] mfd: rz-mtu3: use device-managed reset deassert ---
commit f1182ddc967373a6fde2ebff19ae553068ff4988
Author: Cosmin Tanislav <cosmin-gabriel.tanislav.xa@renesas.com>
mfd: rz-mtu3: use device-managed reset deassert
This commit replaces manual reset control handling with
devm_reset_control_get_exclusive_deasserted(). It also removes the manual
reset assert in the remove callback and renames it.
> mfd: rz-mtu3: use device-managed reset deassert
[Severity: Low]
This isn't a bug, but the MFD subsystem guidelines request that the
description after the subsystem prefix be capitalized. Could this be
updated to "mfd: rz-mtu3: Use device-managed reset deassert"?
> diff --git a/drivers/mfd/rz-mtu3.c b/drivers/mfd/rz-mtu3.c
> index 9cdfef610398f..6b9c6831dffa9 100644
> --- a/drivers/mfd/rz-mtu3.c
> +++ b/drivers/mfd/rz-mtu3.c
[ ... ]
> @@ -301,13 +300,9 @@ void rz_mtu3_disable(struct rz_mtu3_channel *ch)
> }
> EXPORT_SYMBOL_GPL(rz_mtu3_disable);
>
> -static void rz_mtu3_reset_assert(void *data)
> +static void rz_mtu3_mfd_remove(void *data)
[Severity: Low]
This isn't a bug, but the MFD subsystem guidelines state we should avoid
including the string "mfd" or the driver's own filename in names. Does it
make sense to rename this callback to avoid these strings?
> {
> - struct rz_mtu3 *mtu = dev_get_drvdata(data);
> - struct rz_mtu3_priv *priv = mtu->priv_data;
> -
> mfd_remove_devices(data);
> - reset_control_assert(priv->rstc);
> }
[ ... ]
> @@ -361,14 +356,10 @@ static int rz_mtu3_probe(struct platform_device *pdev)
> ret = mfd_add_devices(&pdev->dev, 0, rz_mtu3_devs,
> ARRAY_SIZE(rz_mtu3_devs), NULL, 0, NULL);
> if (ret < 0)
> - goto err_assert;
> + return ret;
>
> - return devm_add_action_or_reset(&pdev->dev, rz_mtu3_reset_assert,
> + return devm_add_action_or_reset(&pdev->dev, rz_mtu3_mfd_remove,
> &pdev->dev);
[Severity: Low]
Since the custom reset assertion has been removed and this callback now only
calls mfd_remove_devices(), this essentially open-codes devm_mfd_add_devices().
Could this code be simplified by calling devm_mfd_add_devices() directly and
deleting the custom removal callback altogether?
> -
> -err_assert:
> - reset_control_assert(priv->rstc);
> - return ret;
> }
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260327192425.438263-1-cosmin-gabriel.tanislav.xa@renesas.com?part=2
next prev parent reply other threads:[~2026-08-13 23:03 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-03-27 19:24 [PATCH 00/11] Add MTU3 for RZ/T2H and RZ/N2H Cosmin Tanislav
2026-03-27 19:24 ` [PATCH 01/11] clk: renesas: r9a09g077: add MTU3 module clock Cosmin Tanislav
2026-03-27 19:24 ` [PATCH 02/11] mfd: rz-mtu3: use device-managed reset deassert Cosmin Tanislav
2026-08-13 23:03 ` sashiko-bot [this message]
2026-03-27 19:24 ` [PATCH 03/11] mfd: rz-mtu3: use device-managed mfd_add_devices() Cosmin Tanislav
2026-03-27 19:24 ` [PATCH 04/11] mfd: rz-mtu3: store &pdev->dev in local variable Cosmin Tanislav
2026-08-13 23:00 ` sashiko-bot
2026-03-27 19:24 ` [PATCH 05/11] mfd: rz-mtu3: make reset optional Cosmin Tanislav
2026-03-27 19:24 ` [PATCH 06/11] dt-bindings: timer: renesas,rz-mtu3: remove TCIU8 interrupt Cosmin Tanislav
2026-04-07 19:21 ` Rob Herring (Arm)
2026-04-08 7:57 ` Geert Uytterhoeven
2026-03-27 19:24 ` [PATCH 07/11] dt-bindings: timer: renesas,rz-mtu3: move required resets to conditional Cosmin Tanislav
2026-04-07 19:22 ` Rob Herring (Arm)
2026-03-27 19:24 ` [PATCH 08/11] dt-bindings: timer: renesas,rz-mtu3: document RZ/{T2H,N2H} Cosmin Tanislav
2026-04-07 19:24 ` Rob Herring
2026-03-27 19:24 ` [PATCH 09/11] arm64: dts: renesas: r9a07g0{43,44,54}: remove TCIU8 interrupt from MTU3 Cosmin Tanislav
2026-03-27 19:24 ` [PATCH 10/11] arm64: dts: renesas: r9a09g077: add MTU3 support Cosmin Tanislav
2026-03-27 19:24 ` [PATCH 11/11] arm64: dts: renesas: r9a09g087: " Cosmin Tanislav
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260813230304.38C321F000E9@smtp.kernel.org \
--to=sashiko-bot@kernel.org \
--cc=conor+dt@kernel.org \
--cc=cosmin-gabriel.tanislav.xa@renesas.com \
--cc=devicetree@vger.kernel.org \
--cc=linux-clk@vger.kernel.org \
--cc=robh@kernel.org \
--cc=sashiko-reviews@lists.linux.dev \
--cc=wsa+renesas@sang-engineering.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.