From: "Anoop, Vijay" <anoop.c.vijay@intel.com>
To: intel-xe@lists.freedesktop.org
Cc: umesh.nerlige.ramappa@intel.com, badal.nilawar@intel.com,
rodrigo.vivi@intel.com, aravind.iddamsetty@intel.com,
riana.tauro@intel.com, anshuman.gupta@intel.com,
matthew.d.roper@intel.com, michael.j.ruhl@intel.com,
paul.e.luse@intel.com, mohamed.mansoor.v@intel.com,
kam.nasim@intel.com, anoop.c.vijay@intel.com
Subject: [PATCH v7 0/2] drm/xe/sysctrl: Add helper to query application status
Date: Fri, 14 Aug 2026 02:53:05 -0700 [thread overview]
Message-ID: <20260814095306.2482289-4-anoop.c.vijay@intel.com> (raw)
From: Anoop Vijay <anoop.c.vijay@intel.com>
This series adds helpers to query the readiness state of individual
System Controller (sysctrl) firmware applications via the
get_app_status_by_id mailbox command.
xe_sysctrl_check_app_status() maps an xe_sysctrl_app_id to its firmware
application identifier and returns the reported application state:
not supported, communication failure, booted, or fully initialized.
Convenience wrappers are added on top of this helper to check
readiness of the Diagnostics (diag) and oCode firmware applications.
Initial consumers of these wrappers are added in the following series.
- https://patchwork.freedesktop.org/series/171728/
- https://patchwork.freedesktop.org/series/161655/
---
v2: (Badal)
- Return SysCtrl firmware application states instead of errno for
application lifecycle conditions
v3: (Riana, Badal)
- Replace string-based app identifiers with enum xe_sysctrl_app_id
- Use get_app_status_by_id (opcode 0x05)
- Move mailbox definitions to xe_sysctrl_mailbox_types.h
- Return enum xe_sysctrl_fw_status consistently
- Map communication failures to COMM_FAILURE
- Add INITIALIZED state and status helpers
- Fix Diagnostics typo
v4: (Anshuman)
- Make xe_sysctrl_check_app_status() internal
- Remove unused app identifier
v5: (Anshuman)
- Rename OOBMSM status helper to use xe_sysctrl_* prefix
- Remove xe_is_diag_fw_ready() helper
v6: (Riana)
- Use xe_sysctrl_create_command() helper instead of manual FIELD_PREP
header packing
- Rename xe_sysctrl_get_app_status_by_id_{req,resp} to shorter names
- Use hex constant for application ID
- Split oCode application readiness helper into its own patch
- Add xe_sysctrl_is_diag_fw_ready() helper; consumer lands in the RAS
error-injection series
v7: (Umesh)
- Clarify diag/oCode firmware readiness helper comments for platforms
without System Controller support
- Move XE_SYSCTRL_APP_RESP_* flags and enum xe_sysctrl_app_id out of
xe_sysctrl_mailbox_types.h into xe_sysctrl.c
---
Anoop Vijay (2):
drm/xe/sysctrl: Add helper to query application status
drm/xe/sysctrl: Add helper to check oCode firmware readiness
drivers/gpu/drm/xe/xe_sysctrl.c | 103 ++++++++++++++++++
drivers/gpu/drm/xe/xe_sysctrl.h | 2 +
drivers/gpu/drm/xe/xe_sysctrl_mailbox_types.h | 47 ++++++++
3 files changed, 152 insertions(+)
--
2.43.0
next reply other threads:[~2026-08-14 9:53 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-14 9:53 Anoop, Vijay [this message]
2026-08-14 9:53 ` [PATCH v7 1/2] drm/xe/sysctrl: Add helper to query application status Anoop, Vijay
2026-08-14 21:21 ` Umesh Nerlige Ramappa
2026-08-18 17:41 ` Anoop Vijay
2026-08-19 21:00 ` Umesh Nerlige Ramappa
2026-08-20 16:37 ` Umesh Nerlige Ramappa
2026-08-14 9:53 ` [PATCH v7 2/2] drm/xe/sysctrl: Add helper to check oCode firmware readiness Anoop, Vijay
2026-08-14 21:22 ` Umesh Nerlige Ramappa
2026-08-14 10:00 ` ✓ CI.KUnit: success for drm/xe/sysctrl: Add helper to query application status (rev7) Patchwork
2026-08-14 10:40 ` ✓ Xe.CI.BAT: " Patchwork
2026-08-14 12:10 ` ✓ Xe.CI.FULL: " Patchwork
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260814095306.2482289-4-anoop.c.vijay@intel.com \
--to=anoop.c.vijay@intel.com \
--cc=anshuman.gupta@intel.com \
--cc=aravind.iddamsetty@intel.com \
--cc=badal.nilawar@intel.com \
--cc=intel-xe@lists.freedesktop.org \
--cc=kam.nasim@intel.com \
--cc=matthew.d.roper@intel.com \
--cc=michael.j.ruhl@intel.com \
--cc=mohamed.mansoor.v@intel.com \
--cc=paul.e.luse@intel.com \
--cc=riana.tauro@intel.com \
--cc=rodrigo.vivi@intel.com \
--cc=umesh.nerlige.ramappa@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.