All of lore.kernel.org
 help / color / mirror / Atom feed
From: Vincent Donnefort <vdonnefort@google.com>
To: rostedt@goodmis.org, mhiramat@kernel.org,
	 linux-trace-kernel@vger.kernel.org
Cc: mathieu.desnoyers@efficios.com, kernel-team@android.com,
	 linux-kernel@vger.kernel.org,
	Vincent Donnefort <vdonnefort@google.com>
Subject: [PATCH v2 0/3] tracing: Rename to "capacity"
Date: Tue,  8 Sep 2026 10:09:34 +0100	[thread overview]
Message-ID: <20260908090937.838544-1-vdonnefort@google.com> (raw)

A few places in ring-buffer and tracing are using "size" or "entries"
while it means "capacity", that is the amount of memory available for
raw data in a ring buffer. Rename functions and member where
appropriate.

v2:
  - Fix "subbufer" typo
  - Rename trace_array::entries (Masami)
  - Rename tracing_entries_fops and tracing_total_entries_fops

v1 (https://lore.kernel.org/all/20260907094238.3624013-1-vdonnefort@google.com/)

Vincent Donnefort (3):
  ring-buffer: Rename ring_buffer_size() to ring_buffer_capacity()
  tracing: Rename trace_array::entries to capacity
  tracing: Rename tracing_entries_fops to tracing_capacity_fops

 include/linux/ring_buffer.h   |  2 +-
 kernel/trace/ring_buffer.c    | 13 ++++++---
 kernel/trace/trace.c          | 51 +++++++++++++++++------------------
 kernel/trace/trace.h          |  4 +--
 kernel/trace/trace_snapshot.c | 14 +++++-----
 5 files changed, 43 insertions(+), 41 deletions(-)


base-commit: df2908090cda368b01ff43709f51890076c56157
-- 
2.55.0.979.g7e5102b832-goog


             reply	other threads:[~2026-09-08  9:09 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-08  9:09 Vincent Donnefort [this message]
2026-09-08  9:09 ` [PATCH v2 1/3] ring-buffer: Rename ring_buffer_size() to ring_buffer_capacity() Vincent Donnefort
2026-09-08  9:09 ` [PATCH v2 2/3] tracing: Rename trace_array::entries to capacity Vincent Donnefort
2026-09-08  9:09 ` [PATCH v2 3/3] tracing: Rename tracing_entries_fops to tracing_capacity_fops Vincent Donnefort

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260908090937.838544-1-vdonnefort@google.com \
    --to=vdonnefort@google.com \
    --cc=kernel-team@android.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-trace-kernel@vger.kernel.org \
    --cc=mathieu.desnoyers@efficios.com \
    --cc=mhiramat@kernel.org \
    --cc=rostedt@goodmis.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.