From: sashiko-bot@kernel.org
To: "SJ Park" <sj@kernel.org>
Cc: damon@lists.linux.dev
Subject: Re: [RFC PATCH v2.1 1/7] mm/damon/api: introduce DAMOS_FILTER_TYPE_PROBE_HITS_WSUM
Date: Thu, 10 Sep 2026 04:13:58 +0000 [thread overview]
Message-ID: <20260910041358.8DB181F000FF@smtp.kernel.org> (raw)
In-Reply-To: <20260910040319.147037-2-sj@kernel.org>
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Low] The kernel-doc comment for `enum damos_filter_type` inaccurately describes `DAMOS_FILTER_TYPE_PROBE_HITS_WSUM` as an operations-handled filter instead of a core-handled filter.
--
commit 03957fb4685434f4e403efc7bb804cb84f796dbd
Author: SJ Park <sj@kernel.org>
mm/damon/api: introduce DAMOS_FILTER_TYPE_PROBE_HITS_WSUM
This commit updates the DAMON kernel API by introducing the new DAMOS core
filter type, PROBE_HITS_WSUM. It allows API callers to filter target regions
based on their probe hits weighted sum by adding range fields to the
damos_filter structure.
> diff --git a/include/linux/damon.h b/include/linux/damon.h
> index 871d26adf6ae5..1deda16bb70b5 100644
> --- a/include/linux/damon.h
> +++ b/include/linux/damon.h
> @@ -399,6 +399,7 @@ struct damos_stat {
> * @DAMOS_FILTER_TYPE_UNMAPPED: Unmapped pages.
> * @DAMOS_FILTER_TYPE_ADDR: Address range.
> * @DAMOS_FILTER_TYPE_TARGET: Data Access Monitoring target.
> + * @DAMOS_FILTER_TYPE_PROBE_HITS_WSUM: probe_hits weighted sum range.
> * @NR_DAMOS_FILTER_TYPES: Number of filter types.
> *
> * All types except &DAMOS_FILTER_TYPE_ADDR and &DAMOS_FILTER_TYPE_TARGET
> * are handled by the underlying &struct damon_operations as a part of scheme
> * action trying
[Severity: Low]
Should &DAMOS_FILTER_TYPE_PROBE_HITS_WSUM be added to this exception list?
Since PROBE_HITS_WSUM is implemented as a core-handled filter rather than an
operations-handled filter, this kernel-doc comment for enum damos_filter_type
might need an update. Otherwise, the documentation inaccurately describes it
as handled by operations, creating a mismatch with the actual core logic
implementation.
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260910040319.147037-1-sj@kernel.org?part=1
next prev parent reply other threads:[~2026-09-10 4:13 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-10 4:03 [RFC PATCH v2.1 0/7] mm/damon: introduce probe_hits_wsum DAMOS core filter SJ Park
2026-09-10 4:03 ` [RFC PATCH v2.1 1/7] mm/damon/api: introduce DAMOS_FILTER_TYPE_PROBE_HITS_WSUM SJ Park
2026-09-10 4:13 ` sashiko-bot [this message]
2026-09-10 4:17 ` SJ Park
2026-09-10 4:03 ` [RFC PATCH v2.1 2/7] mm/damon/core: extend probe_hits_wsum() for moving sum based calculation SJ Park
2026-09-10 4:08 ` sashiko-bot
2026-09-10 4:03 ` [RFC PATCH v2.1 3/7] mm/damon/core: support probe_hits_wsum damos core filter SJ Park
2026-09-10 4:16 ` sashiko-bot
2026-09-10 4:20 ` SJ Park
2026-09-10 4:03 ` [RFC PATCH v2.1 4/7] mm/damon/sysfs-schemes: rename sysfs_filter->sz_range to range_{min,max} SJ Park
2026-09-10 4:14 ` sashiko-bot
2026-09-10 4:03 ` [RFC PATCH v2.1 5/7] mm/damon/sysfs-schemes: support probe_hits_wsum damos core filter SJ Park
2026-09-10 4:18 ` sashiko-bot
2026-09-10 4:23 ` SJ Park
2026-09-10 4:03 ` [RFC PATCH v2.1 6/7] Docs/mm/damon/design: update for probe_hits_wsum DAMOS " SJ Park
2026-09-10 4:05 ` sashiko-bot
2026-09-10 4:03 ` [RFC PATCH v2.1 7/7] Docs/admin-guide/mm/damon/usage: update for probe_hits_wsum DAMOS filter SJ Park
2026-09-10 4:05 ` sashiko-bot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260910041358.8DB181F000FF@smtp.kernel.org \
--to=sashiko-bot@kernel.org \
--cc=damon@lists.linux.dev \
--cc=sashiko-reviews@lists.linux.dev \
--cc=sj@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.