From: SJ Park <sj@kernel.org>
To: sashiko-bot@kernel.org
Cc: SJ Park <sj@kernel.org>, damon@lists.linux.dev
Subject: Re: [RFC PATCH v2.2 3/7] mm/damon/core: support probe_hits_wsum damos core filter
Date: Thu, 10 Sep 2026 18:28:42 -0700 [thread overview]
Message-ID: <20260911012843.94560-1-sj@kernel.org> (raw)
In-Reply-To: <20260911012249.541D21F000FF@smtp.kernel.org>
On Fri, 11 Sep 2026 01:22:48 +0000 sashiko-bot@kernel.org wrote:
> Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
> - [Medium] Missing test coverage for new DAMOS_FILTER_TYPE_PROBE_HITS_WSUM filter type.
> --
>
> commit 6772f4f420525d4fa844eff78fb5f202b6550013
> Author: SJ Park <sj@kernel.org>
>
> mm/damon/core: support probe_hits_wsum damos core filter
>
> Implement probe_hits_wsum DAMOS core filter support in the core layer
> by updating filter operations, argument commits, and match handlers.
>
> > diff --git a/mm/damon/core.c b/mm/damon/core.c
> > index e9630f41e51fe..d9d56f4be1a97 100644
> > --- a/mm/damon/core.c
> > +++ b/mm/damon/core.c
> [ ... ]
> > @@ -1332,6 +1333,10 @@ static void damos_commit_filter_arg(
> > case DAMOS_FILTER_TYPE_HUGEPAGE_SIZE:
> > dst->sz_range = src->sz_range;
> > break;
> > + case DAMOS_FILTER_TYPE_PROBE_HITS_WSUM:
> > + dst->range_min = src->range_min;
> > + dst->range_max = src->range_max;
> > + break;
>
> [Severity: Medium]
> Should this new filter type also be added to the kunit tests in
> mm/damon/tests/core-kunit.h?
>
> Looking at mm/damon/tests/core-kunit.h, damos_test_commit_filter_for() has a
> switch statement verifying that filter arguments are copied, but it lacks a
> case to verify range_min and range_max for DAMOS_FILTER_TYPE_PROBE_HITS_WSUM.
>
> Similarly, damos_test_commit_filter() invokes tests for all other filter types
> but seems to omit the newly added DAMOS_FILTER_TYPE_PROBE_HITS_WSUM.
>
> Could test coverage be added for this new filter type to prevent future
> regressions?
We could improve the test coverage, but it is not a blocker of this patch. I
will consider adding the test in future.
>
> --
> Sashiko AI review · https://sashiko.dev/#/patchset/20260911011330.93678-1-sj@kernel.org?part=3
Thanks,
SJ
next prev parent reply other threads:[~2026-09-11 1:28 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-11 1:13 [RFC PATCH v2.2 0/7] mm/damon: introduce probe_hits_wsum DAMOS core filter SJ Park
2026-09-11 1:13 ` [RFC PATCH v2.2 1/7] mm/damon/api: introduce DAMOS_FILTER_TYPE_PROBE_HITS_WSUM SJ Park
2026-09-11 1:20 ` sashiko-bot
2026-09-11 1:27 ` SJ Park
2026-09-11 1:13 ` [RFC PATCH v2.2 2/7] mm/damon/core: extend probe_hits_wsum() for moving sum based calculation SJ Park
2026-09-11 1:21 ` sashiko-bot
2026-09-11 1:13 ` [RFC PATCH v2.2 3/7] mm/damon/core: support probe_hits_wsum damos core filter SJ Park
2026-09-11 1:22 ` sashiko-bot
2026-09-11 1:28 ` SJ Park [this message]
2026-09-11 1:13 ` [RFC PATCH v2.2 4/7] mm/damon/sysfs-schemes: rename sysfs_filter->sz_range to range_{min,max} SJ Park
2026-09-11 1:19 ` sashiko-bot
2026-09-11 1:13 ` [RFC PATCH v2.2 5/7] mm/damon/sysfs-schemes: support probe_hits_wsum damos core filter SJ Park
2026-09-11 1:21 ` sashiko-bot
2026-09-11 1:13 ` [RFC PATCH v2.2 6/7] Docs/mm/damon/design: update for probe_hits_wsum DAMOS " SJ Park
2026-09-11 1:15 ` sashiko-bot
2026-09-11 1:13 ` [RFC PATCH v2.2 7/7] Docs/admin-guide/mm/damon/usage: update for probe_hits_wsum DAMOS filter SJ Park
2026-09-11 1:15 ` sashiko-bot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260911012843.94560-1-sj@kernel.org \
--to=sj@kernel.org \
--cc=damon@lists.linux.dev \
--cc=sashiko-bot@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.