All of lore.kernel.org
 help / color / mirror / Atom feed
From: sashiko-bot@kernel.org
To: "SJ Park" <sj@kernel.org>
Cc: damon@lists.linux.dev
Subject: Re: [PATCH v2 1/7] mm/damon/api: introduce DAMOS_FILTER_TYPE_PROBE_HITS_WSUM
Date: Fri, 11 Sep 2026 14:04:24 +0000	[thread overview]
Message-ID: <20260911140425.390011F000FF@smtp.kernel.org> (raw)
In-Reply-To: <20260911135510.96914-2-sj@kernel.org>

Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Low] The docstring for damos_filter_type omits DAMOS_FILTER_TYPE_PROBE_HITS_WSUM from the list of core filters in the second sentence, creating a contradiction in the documentation.
--

commit e68a3c149b1b27ea94bc8212e0cde17817f1e4cc
Author: SJ Park <sj@kernel.org>

mm/damon/api: introduce DAMOS_FILTER_TYPE_PROBE_HITS_WSUM

Update DAMON kernel API to introduce new DAMOS core filter type,
PROBE_HITS_WSUM. It allows API callers to describe the DAMOS action
target regions based on their probe_hits weighted sum.

> diff --git a/include/linux/damon.h b/include/linux/damon.h
> index 16800b3dc379b..9e84bdeb5616d 100644
> --- a/include/linux/damon.h
> +++ b/include/linux/damon.h
> @@ -399,14 +399,15 @@ struct damos_stat {
>   * @DAMOS_FILTER_TYPE_UNMAPPED:	Unmapped pages.
>   * @DAMOS_FILTER_TYPE_ADDR:	Address range.
>   * @DAMOS_FILTER_TYPE_TARGET:	Data Access Monitoring target.
> + * @DAMOS_FILTER_TYPE_PROBE_HITS_WSUM:	probe_hits weighted sum range.
>   * @NR_DAMOS_FILTER_TYPES:	Number of filter types.
>   *
> - * All types except &DAMOS_FILTER_TYPE_ADDR and &DAMOS_FILTER_TYPE_TARGET
> - * are handled by the underlying &struct damon_operations as a part of scheme
> - * action trying, and therefore accounted as 'tried'.  In contrast,
> - * &DAMOS_FILTER_TYPE_ADDR and &DAMOS_FILTER_TYPE_TARGET filters are handled
> - * by the core layer before trying of the action, and therefore not accounted
> - * as 'tried'.
> + * All types except &DAMOS_FILTER_TYPE_ADDR, &DAMOS_FILTER_TYPE_TARGET and
> + * &DAMOS_FILTER_TYPE_PROBE_HITS_WSUM are handled by the underlying &struct
> + * damon_operations as a part of scheme action trying, and therefore accounted
> + * as 'tried'.  In contrast, &DAMOS_FILTER_TYPE_ADDR and
> + * &DAMOS_FILTER_TYPE_TARGET filters are handled by the core layer before
> + * trying of the action, and therefore not accounted as 'tried'.

[Severity: Low]
This isn't a bug, but should &DAMOS_FILTER_TYPE_PROBE_HITS_WSUM be included
in this second sentence?

The first sentence explicitly excludes it from being handled by the underlying
operations, but the second sentence omits it when listing the filters handled
by the core layer. 

Could this omission in the enum damos_filter_type docstring confuse developers 
about whether PROBE_HITS_WSUM is accounted as 'tried'?

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/20260911135510.96914-1-sj@kernel.org?part=1

  reply	other threads:[~2026-09-11 14:04 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-11 13:55 [PATCH v2 0/7] mm/damon: introduce probe_hits_wsum DAMOS core filter SJ Park
2026-09-11 13:55 ` [PATCH v2 1/7] mm/damon/api: introduce DAMOS_FILTER_TYPE_PROBE_HITS_WSUM SJ Park
2026-09-11 14:04   ` sashiko-bot [this message]
2026-09-11 14:20     ` SJ Park
2026-09-11 14:25   ` SJ Park
2026-09-11 13:55 ` [PATCH v2 2/7] mm/damon/core: extend probe_hits_wsum() for moving sum based calculation SJ Park
2026-09-11 14:05   ` sashiko-bot
2026-09-11 13:55 ` [PATCH v2 3/7] mm/damon/core: support probe_hits_wsum damos core filter SJ Park
2026-09-11 14:05   ` sashiko-bot
2026-09-11 13:55 ` [PATCH v2 4/7] mm/damon/sysfs-schemes: rename sysfs_filter->sz_range to range_{min,max} SJ Park
2026-09-11 14:10   ` sashiko-bot
2026-09-11 13:55 ` [PATCH v2 5/7] mm/damon/sysfs-schemes: support probe_hits_wsum damos core filter SJ Park
2026-09-11 14:14   ` sashiko-bot
2026-09-11 13:55 ` [PATCH v2 6/7] Docs/mm/damon/design: update for probe_hits_wsum DAMOS " SJ Park
2026-09-11 14:06   ` sashiko-bot
2026-09-11 13:55 ` [PATCH v2 7/7] Docs/admin-guide/mm/damon/usage: update for probe_hits_wsum DAMOS filter SJ Park
2026-09-11 14:06   ` sashiko-bot
2026-09-11 14:28 ` [PATCH v2 0/7] mm/damon: introduce probe_hits_wsum DAMOS core filter SJ Park
2026-09-11 23:19 ` Andrew Morton

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260911140425.390011F000FF@smtp.kernel.org \
    --to=sashiko-bot@kernel.org \
    --cc=damon@lists.linux.dev \
    --cc=sashiko-reviews@lists.linux.dev \
    --cc=sj@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.