All of lore.kernel.org
 help / color / mirror / Atom feed
From: sashiko-bot@kernel.org
To: "Lorenzo Stoakes" <ljs@kernel.org>,
	"Jonathan Corbet" <corbet@lwn.net>,
	"Alexander Graf" <graf@amazon.com>,
	"Liam R. Howlett" <liam@infradead.org>,
	"Vlastimil Babka" <vbabka@kernel.org>,
	"Suren Baghdasaryan" <surenb@google.com>,
	"Dave Hansen" <dave.hansen@linux.intel.com>,
	"Rob Herring" <robh@kernel.org>,
	"Mike Rapoport" <rppt@kernel.org>,
	"Pratyush Yadav" <pratyush@kernel.org>,
	"Pasha Tatashin" <pasha.tatashin@soleen.com>,
	"Ingo Molnar" <mingo@redhat.com>,
	"Shuah Khan" <skhan@linuxfoundation.org>,
	"Ilias Apalodimas" <ilias.apalodimas@linaro.org>,
	"H. Peter Anvin" <hpa@zytor.com>,
	"Baoquan He" <baoquan.he@linux.dev>,
	"Ard Biesheuvel" <ardb@kernel.org>,
	"Andrew Morton" <akpm@linux-foundation.org>,
	"Thomas Gleixner" <tglx@kernel.org>,
	"Saravana Kannan" <saravanak@kernel.org>,
	"Arnd Bergmann" <arnd@arndb.de>,
	"David Hildenbrand" <david@kernel.org>,
	"Michal Hocko" <mhocko@suse.com>,
	"Borislav Petkov" <bp@alien8.de>
Cc: x86@kernel.org, devicetree@vger.kernel.org, conor+dt@kernel.org,
	linux-kernel@vger.kernel.org, robh@kernel.org,
	linux-arch@vger.kernel.org, linux-doc@vger.kernel.org,
	linux-mm@kvack.org, linux-efi@vger.kernel.org,
	kexec@lists.infradead.org
Subject: Re: [PATCH v3 3/4] kho: rename KHO scratch to KHO bootmem
Date: Tue, 22 Sep 2026 04:21:52 +0000	[thread overview]
Message-ID: <20260922042152.D1D851F000FF@smtp.kernel.org> (raw)
In-Reply-To: <20260922041321.233986-4-pratyush@kernel.org>

> From: "Pratyush Yadav (Google)" <pratyush@kernel.org>
> 
> The term "KHO scratch" is vague and overloaded.
> 
> For one, it does not accurately describe what the memory is for. From
> KHO's perspective, it is memory passed by the previous kernel that is
> guaranteed to have no allocations and hence it is safe to allocate from.
> 
> For another, the term is overloaded. KHO also knows to discover other
> ranges of memory that don't have any preservations and are safe to
> allocate from. This is done by kho_extend_scratch(). These areas, while
> called "scratch", are completely different from the chunk of memory
> passed by the previous kernel for early boot allocations.
> 
> Rename "KHO scratch" to "KHO boot memory", or "KHO bootmem" in short.
> Update all function names, variable names, comments, and documentation
> to use this.
> 
> Call the discovered areas "noprsrv", matching what memblock would see
> them as. Rename kho_extend_scratch() to reflect this.
> 
> This patch largely has no functional changes. The only functional
> changes are renames of debugfs files from "scratch_phys" and
> "scratch_len" to "bootmem_phys" and "bootmem_len" respectively.
> 
> Signed-off-by: Pratyush Yadav (Google) <pratyush@kernel.org>

Sashiko has reviewed this patch and found no issues. It looks great!

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/20260922041321.233986-1-pratyush@kernel.org?part=3



  reply	other threads:[~2026-09-22  4:21 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-22  4:13 [PATCH v3 0/4] kho: rename "scratch" to "bootmem" Pratyush Yadav
2026-09-22  4:13 ` [PATCH v3 1/4] memblock: get rid of CONFIG_MEMBLOCK_KHO_SCRATCH Pratyush Yadav
2026-09-22  4:21   ` sashiko-bot
2026-09-22  4:13 ` [PATCH v3 2/4] memblock: rename KHO_SCRATCH to KHO_NOPRSRV Pratyush Yadav
2026-09-22  4:19   ` sashiko-bot
2026-09-22  4:13 ` [PATCH v3 3/4] kho: rename KHO scratch to KHO bootmem Pratyush Yadav
2026-09-22  4:21   ` sashiko-bot [this message]
2026-09-22  4:13 ` [PATCH v3 4/4] kho: rename kho_scratch= commandline parameter to kho_bootmem= Pratyush Yadav
2026-09-22  4:19   ` sashiko-bot
2026-09-24  8:35 ` [PATCH v3 0/4] kho: rename "scratch" to "bootmem" Mike Rapoport

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260922042152.D1D851F000FF@smtp.kernel.org \
    --to=sashiko-bot@kernel.org \
    --cc=akpm@linux-foundation.org \
    --cc=ardb@kernel.org \
    --cc=arnd@arndb.de \
    --cc=baoquan.he@linux.dev \
    --cc=bp@alien8.de \
    --cc=conor+dt@kernel.org \
    --cc=corbet@lwn.net \
    --cc=dave.hansen@linux.intel.com \
    --cc=david@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=graf@amazon.com \
    --cc=hpa@zytor.com \
    --cc=ilias.apalodimas@linaro.org \
    --cc=kexec@lists.infradead.org \
    --cc=liam@infradead.org \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-efi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=ljs@kernel.org \
    --cc=mhocko@suse.com \
    --cc=mingo@redhat.com \
    --cc=pasha.tatashin@soleen.com \
    --cc=pratyush@kernel.org \
    --cc=robh@kernel.org \
    --cc=rppt@kernel.org \
    --cc=saravanak@kernel.org \
    --cc=sashiko-reviews@lists.linux.dev \
    --cc=skhan@linuxfoundation.org \
    --cc=surenb@google.com \
    --cc=tglx@kernel.org \
    --cc=vbabka@kernel.org \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.