All of lore.kernel.org
 help / color / mirror / Atom feed
From: Dave Hansen <dave.hansen@intel.com>
To: Chao Gao <chao.gao@intel.com>,
	"Edgecombe, Rick P" <rick.p.edgecombe@intel.com>
Cc: "kvm@vger.kernel.org" <kvm@vger.kernel.org>,
	"linux-coco@lists.linux.dev" <linux-coco@lists.linux.dev>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"bp@alien8.de" <bp@alien8.de>, "x86@kernel.org" <x86@kernel.org>,
	"kas@kernel.org" <kas@kernel.org>,
	"hpa@zytor.com" <hpa@zytor.com>,
	"yilun.xu@linux.intel.com" <yilun.xu@linux.intel.com>,
	"mingo@redhat.com" <mingo@redhat.com>,
	"dave.hansen@linux.intel.com" <dave.hansen@linux.intel.com>,
	"tglx@kernel.org" <tglx@kernel.org>
Subject: Re: [RFC PATCH v2 02/10] x86/virt/tdx: Convert the version metadata reader
Date: Thu, 24 Sep 2026 12:12:11 -0700	[thread overview]
Message-ID: <2042fa92-0b33-4ce2-a288-8eebda2b7305@intel.com> (raw)
In-Reply-To: <arS6D6KoPbqVBtPl@intel.com>

On 9/23/26 22:50, Chao Gao wrote:
>>> +static int get_tdx_sys_info_version(struct tdx_sys_info_version *version)
>>> +{
>>> +	return read_sys_metadata_table(version_mappings, version);
>>> +}
>> I'm not sure we need all of these helpers that are each only called once?
> I'd prefer to keep them, for a few reasons:
> 
> 1. This one is actually called twice: from get_tdx_sys_info() and from
>    tdx_module_run_update().

Neither has any real space constraints, I'll note.

> 2. The helper name describes what is being read better than a bare
>    read_sys_metadata_table() call.

What part? that it comes from "sys_info" as opposed to it being
"metadata". Meh. Why does it matter?

> 3. Some helpers do more than read a table (see get_tdx_sys_info_td_conf()).
>    Without per-class helpers, get_tdx_sys_info() would open-code
>    read_sys_metadata_table() for some classes and call a helper for
>    others, which looks inconsistent. With one helper per metadata class,
>    every class is read the same way.

I value lower levels of abstraction over naming consistency.

Remove the helper, please.

  reply	other threads:[~2026-09-24 19:12 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-18 13:29 [RFC PATCH v2 00/10] TDX: Stop auto-generating the global metadata code Chao Gao
2026-09-18 13:29 ` [RFC PATCH v2 01/10] x86/virt/tdx: Add a helper to read a table of metadata fields Chao Gao
2026-09-23 22:20   ` Edgecombe, Rick P
2026-09-24  5:36     ` Chao Gao
2026-09-24  6:13   ` Binbin Wu
2026-09-18 13:29 ` [RFC PATCH v2 02/10] x86/virt/tdx: Convert the version metadata reader Chao Gao
2026-09-23 22:26   ` Edgecombe, Rick P
2026-09-24  5:50     ` Chao Gao
2026-09-24 19:12       ` Dave Hansen [this message]
2026-09-28 11:32         ` Chao Gao
2026-09-28 14:25           ` Dave Hansen
2026-09-24 19:53       ` Edgecombe, Rick P
2026-09-24  6:40   ` Binbin Wu
2026-09-18 13:29 ` [RFC PATCH v2 03/10] x86/virt/tdx: Convert the features " Chao Gao
2026-09-18 13:29 ` [RFC PATCH v2 04/10] x86/virt/tdx: Convert the tdmr " Chao Gao
2026-09-18 13:29 ` [RFC PATCH v2 05/10] x86/virt/tdx: Convert the td_ctrl " Chao Gao
2026-09-18 13:29 ` [RFC PATCH v2 06/10] x86/virt/tdx: Convert the handoff " Chao Gao
2026-09-18 13:29 ` [RFC PATCH v2 07/10] x86/virt/tdx: Convert the td_conf " Chao Gao
2026-09-18 13:29 ` [RFC PATCH v2 08/10] x86/virt/tdx: Remove tdx_global_metadata.c Chao Gao
2026-09-23 22:53   ` Edgecombe, Rick P
2026-09-18 13:29 ` [RFC PATCH v2 09/10] x86/virt/tdx: Use early returns in get_tdx_sys_info() Chao Gao
2026-09-23 22:52   ` Edgecombe, Rick P
2026-09-24  7:28     ` Chao Gao
2026-09-18 13:29 ` [RFC PATCH v2 10/10] x86/virt/tdx: Verify structure member sizes against metadata field IDs Chao Gao
2026-09-23 22:47   ` Edgecombe, Rick P
2026-09-24  7:20     ` Chao Gao
2026-09-23  0:47 ` [RFC PATCH v2 00/10] TDX: Stop auto-generating the global metadata code Edgecombe, Rick P
2026-09-23  8:23   ` Chao Gao
2026-09-23  5:44 ` Tony Lindgren
2026-09-23  8:19   ` Chao Gao
2026-09-23  8:37     ` Tony Lindgren

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2042fa92-0b33-4ce2-a288-8eebda2b7305@intel.com \
    --to=dave.hansen@intel.com \
    --cc=bp@alien8.de \
    --cc=chao.gao@intel.com \
    --cc=dave.hansen@linux.intel.com \
    --cc=hpa@zytor.com \
    --cc=kas@kernel.org \
    --cc=kvm@vger.kernel.org \
    --cc=linux-coco@lists.linux.dev \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=rick.p.edgecombe@intel.com \
    --cc=tglx@kernel.org \
    --cc=x86@kernel.org \
    --cc=yilun.xu@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.