diff for duplicates of <22098838.zqKo9eB0Jt@avalon> diff --git a/a/1.txt b/N1/1.txt index 51f237d..53366f2 100644 --- a/a/1.txt +++ b/N1/1.txt @@ -132,7 +132,7 @@ can remove them if you have a strong objection. > > + struct tpu_device *tpu = to_tpu_device(chip); > > + struct tpu_pwm_device *pwm = &tpu->pwms[_pwm->hwpwm]; > > + -> > + return pwm->pdata = NULL ? -EPROBE_DEFER : 0; +> > + return pwm->pdata == NULL ? -EPROBE_DEFER : 0; > > +} > > If you use the same method as the pwm-bfin or pwm-atmel-tcb drivers, you @@ -180,11 +180,11 @@ calls if possible. And I prefer the opposite :-) I can change that if you insist. -> > + duty_only = pwm->prescaler = prescaler && pwm->period = period; +> > + duty_only = pwm->prescaler == prescaler && pwm->period == period; > > Maybe the following would be easier to read? > -> if (prescaler = pwm->prescaler && period = pwm->period) +> if (prescaler == pwm->prescaler && period == pwm->period) > duty_only = true; > > And initialize duty_only = false when declaring it. @@ -205,7 +205,7 @@ I agree, I'll change that. > > + } > > + > > + tpu = devm_kzalloc(&pdev->dev, sizeof(*tpu), GFP_KERNEL); -> > + if (tpu = NULL) { +> > + if (tpu == NULL) { > > + dev_err(&pdev->dev, "failed to allocate driver data\n"); > > + return -ENOMEM; > > + } @@ -219,7 +219,7 @@ I agree, I'll change that. > > + > > + tpu->base = devm_ioremap_nocache(&pdev->dev, res->start, > > + resource_size(res)); -> > + if (tpu->base = NULL) { +> > + if (tpu->base == NULL) { > > + dev_err(&pdev->dev, "failed to remap I/O memory\n"); > > + return -ENXIO; > > + } diff --git a/a/content_digest b/N1/content_digest index bd78a74..9efc958 100644 --- a/a/content_digest +++ b/N1/content_digest @@ -3,7 +3,7 @@ "ref\020130523214517.GA18249@avionic-0098.adnet.avionic-design.de\0" "From\0Laurent Pinchart <laurent.pinchart@ideasonboard.com>\0" "Subject\0Re: [PATCH v2 04/11] pwm: Add Renesas TPU PWM driver\0" - "Date\0Wed, 29 May 2013 15:48:50 +0000\0" + "Date\0Wed, 29 May 2013 17:48:50 +0200\0" "To\0Thierry Reding <thierry.reding@avionic-design.de>\0" "Cc\0Laurent Pinchart <laurent.pinchart+renesas@ideasonboard.com>" linux-sh@vger.kernel.org @@ -147,7 +147,7 @@ "> > +\tstruct tpu_device *tpu = to_tpu_device(chip);\n" "> > +\tstruct tpu_pwm_device *pwm = &tpu->pwms[_pwm->hwpwm];\n" "> > +\n" - "> > +\treturn pwm->pdata = NULL ? -EPROBE_DEFER : 0;\n" + "> > +\treturn pwm->pdata == NULL ? -EPROBE_DEFER : 0;\n" "> > +}\n" "> \n" "> If you use the same method as the pwm-bfin or pwm-atmel-tcb drivers, you\n" @@ -195,11 +195,11 @@ "\n" "And I prefer the opposite :-) I can change that if you insist.\n" "\n" - "> > +\tduty_only = pwm->prescaler = prescaler && pwm->period = period;\n" + "> > +\tduty_only = pwm->prescaler == prescaler && pwm->period == period;\n" "> \n" "> Maybe the following would be easier to read?\n" "> \n" - "> \tif (prescaler = pwm->prescaler && period = pwm->period)\n" + "> \tif (prescaler == pwm->prescaler && period == pwm->period)\n" "> \t\tduty_only = true;\n" "> \n" "> And initialize duty_only = false when declaring it.\n" @@ -220,7 +220,7 @@ "> > +\t}\n" "> > +\n" "> > +\ttpu = devm_kzalloc(&pdev->dev, sizeof(*tpu), GFP_KERNEL);\n" - "> > +\tif (tpu = NULL) {\n" + "> > +\tif (tpu == NULL) {\n" "> > +\t\tdev_err(&pdev->dev, \"failed to allocate driver data\\n\");\n" "> > +\t\treturn -ENOMEM;\n" "> > +\t}\n" @@ -234,7 +234,7 @@ "> > +\n" "> > +\ttpu->base = devm_ioremap_nocache(&pdev->dev, res->start,\n" "> > +\t\t\t\t\t resource_size(res));\n" - "> > +\tif (tpu->base = NULL) {\n" + "> > +\tif (tpu->base == NULL) {\n" "> > +\t\tdev_err(&pdev->dev, \"failed to remap I/O memory\\n\");\n" "> > +\t\treturn -ENXIO;\n" "> > +\t}\n" @@ -314,4 +314,4 @@ "\n" Laurent Pinchart -a47472f222319e7b175b61d6f3034673c9417b187a2fdfd74d28d5d4f63d329a +43c4f18e988b6e6707fd5befc37122a77cfd6840cf4e8ce28a422fbd99577f17
This is an external index of several public inboxes, see mirroring instructions on how to clone and mirror all data and code used by this external index.