All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Rafael J. Wysocki" <rjw@rjwysocki.net>
To: Arnd Bergmann <arnd@arndb.de>
Cc: linux-omap@vger.kernel.org, Sebastian Reichel <sre@kernel.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	Linux PM list <linux-pm@vger.kernel.org>
Subject: Re: [PATCH] hsi / OMAP / PM: Replace CONFIG_PM_RUNTIME with CONFIG_PM
Date: Wed, 03 Dec 2014 23:45:22 +0100	[thread overview]
Message-ID: <22524926.vCRamu0d6Y@vostro.rjw.lan> (raw)
In-Reply-To: <2553100.3OLsEPLv6G@wuerfel>

On Wednesday, December 03, 2014 08:49:12 PM Arnd Bergmann wrote:
> On Wednesday 03 December 2014 03:02:24 Rafael J. Wysocki wrote:
> > From: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
> > 
> > After commit b2b49ccbdd54 (PM: Kconfig: Set PM_RUNTIME if PM_SLEEP is
> > selected) PM_RUNTIME is always set if PM is set, so #ifdef blocks
> > depending on CONFIG_PM_RUNTIME may now be changed to depend on
> > CONFIG_PM.
> > 
> > Do that for the omap_ssi driver.
> > 
> 
> Just for clarification: does that mean that PM, PM_RUNTIME, and PM_SLEEP
> are all synonyms now, or is there still some other combination that
> allows a subset to be set?

PM_RUNTIME is always set when PM is, but PM_SLEEP still may not be set then.

The plan is to drop PM_RUNTIME and use PM as a user-visible option instead
of it (which can be selected automatically by PM_SLEEP too).

As stated here:
http://marc.info/?l=linux-kernel&m=141710589711818&w=4
http://marc.info/?l=linux-kernel&m=141712284917133&w=4

> Before we do lots of s/CONFIG_PM_SLEEP/CONFIG_PM/ changes in lots of
> other drivers, it would be nice to come up with a new set of macros
> to replace all the SET_RUNTIME_PM_OPS/SIMPLE_DEV_PM_OPS/..._OPS
> with a version that avoided the #ifdefs altogether.

I don't think we can avoid all of the #ifdefs and the macros still work
(except for one which is redundant, but I have a patch to clean that up).

Rafael

  reply	other threads:[~2014-12-03 22:45 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-12-03  2:02 [PATCH] hsi / OMAP / PM: Replace CONFIG_PM_RUNTIME with CONFIG_PM Rafael J. Wysocki
2014-12-03  1:57 ` Sebastian Reichel
2014-12-03 19:49 ` Arnd Bergmann
2014-12-03 22:45   ` Rafael J. Wysocki [this message]
2014-12-04  9:23     ` Arnd Bergmann

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=22524926.vCRamu0d6Y@vostro.rjw.lan \
    --to=rjw@rjwysocki.net \
    --cc=arnd@arndb.de \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-omap@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=sre@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.