All of lore.kernel.org
 help / color / mirror / Atom feed
From: Shay Drori <shayd@nvidia.com>
To: Simon Horman <horms@kernel.org>, Tariq Toukan <tariqt@nvidia.com>
Cc: Andrew Lunn <andrew+netdev@lunn.ch>,
	"David S. Miller" <davem@davemloft.net>,
	Eric Dumazet <edumazet@google.com>,
	Jakub Kicinski <kuba@kernel.org>, <netdev@vger.kernel.org>,
	Paolo Abeni <pabeni@redhat.com>, Gal Pressman <gal@nvidia.com>,
	Leon Romanovsky <leon@kernel.org>, <linux-kernel@vger.kernel.org>,
	<linux-rdma@vger.kernel.org>, Mark Bloch <mbloch@nvidia.com>,
	Moshe Shemesh <moshe@nvidia.com>,
	Saeed Mahameed <saeedm@nvidia.com>
Subject: Re: [PATCH net-next] net/mlx5: SD, prefer sd_group_size from vport context
Date: Wed, 12 Aug 2026 09:03:57 +0300	[thread overview]
Message-ID: <229ccb80-9dc8-44b1-adff-51139200d15b@nvidia.com> (raw)
In-Reply-To: <20260811124407.GF51943@horms.kernel.org>



On 11/08/2026 15:44, Simon Horman wrote:
> External email: Use caution opening links or attachments
> 
> 
> On Mon, Aug 10, 2026 at 12:30:37PM +0300, Tariq Toukan wrote:
>> From: Shay Drory <shayd@nvidia.com>
>>
>> Newer FW reports the SD group size directly in the NIC vport context
>> via the sd_group_size field, gated by the sd_group_size capability.
>> Switch sd_init() to source the group size from there and fall back to
>> the MPIR-based host_buses query only when the cap is absent.
>> sd_group_size might return 1 in some FW configuration. Add explicit
>> check to disable SD creation in this case.
>>
>> While here, rename host_buses to group_size throughout sd.c to follow
>> the new name on capable FW.
>>
>> issue: 4680618
>> Signed-off-by: Shay Drory <shayd@nvidia.com>
>> Reviewed-by: Moshe Shemesh <moshe@nvidia.com>
>> Signed-off-by: Tariq Toukan <tariqt@nvidia.com>
> 
> Hi,
> 
> I'd appreciate it if you could take a look over the AI-generated review
> of this patch at https://netdev-ai.bots.linux.dev/sashiko/#/patchset/20260810093037.3138197-1-tariqt%40nvidia.com
> 
> But my feeling is that this patch is good as-is.
> 
> Reviewed-by: Simon Horman <horms@kernel.org>

Hi,

thanks for the review.

Regarding the comment:
"Can an MPIR-derived group_size of 0 or 1 therefore still reach
sd->group_size?"

[SD] AFAIK, no.
MPIR can't be 1, and if sdm bit is set, it means group_size != 0.


Regarding the comment:
"Would it be clearer to always write a defined value in the callee, or 
to report capability validity explicitly (for example a bool *valid), or
to have sd.c test MLX5_CAP_GEN(dev, sd_group_size) directly instead of
overloading a representable field encoding?

[SD] We considered it, and prefer keeping the cap check confined to
mlx5_query_nic_vport_sd_group() so callers don't have to repeat it.

  reply	other threads:[~2026-08-12  6:04 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-10  9:30 [PATCH net-next] net/mlx5: SD, prefer sd_group_size from vport context Tariq Toukan
2026-08-11 12:44 ` Simon Horman
2026-08-12  6:03   ` Shay Drori [this message]
2026-08-14 19:27 ` Jakub Kicinski
2026-08-14 19:51 ` patchwork-bot+netdevbpf

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=229ccb80-9dc8-44b1-adff-51139200d15b@nvidia.com \
    --to=shayd@nvidia.com \
    --cc=andrew+netdev@lunn.ch \
    --cc=davem@davemloft.net \
    --cc=edumazet@google.com \
    --cc=gal@nvidia.com \
    --cc=horms@kernel.org \
    --cc=kuba@kernel.org \
    --cc=leon@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-rdma@vger.kernel.org \
    --cc=mbloch@nvidia.com \
    --cc=moshe@nvidia.com \
    --cc=netdev@vger.kernel.org \
    --cc=pabeni@redhat.com \
    --cc=saeedm@nvidia.com \
    --cc=tariqt@nvidia.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.