From: Alexander Stein <alexander.stein@ew.tq-group.com>
To: Krzysztof Kozlowski <krzk@kernel.org>, Frank Li <Frank.li@nxp.com>
Cc: Christophe Leroy <christophe.leroy@csgroup.eu>,
Rob Herring <robh@kernel.org>,
Krzysztof Kozlowski <krzk+dt@kernel.org>,
Conor Dooley <conor+dt@kernel.org>,
linuxppc-dev@lists.ozlabs.org,
linux-arm-kernel@lists.infradead.org, devicetree@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 1/1] dt-bindings: fsl: fsl, rcpm: Add #power-domain-cells
Date: Tue, 12 Aug 2025 08:14:24 +0200 [thread overview]
Message-ID: <2799138.mvXUDI8C0e@steina-w> (raw)
In-Reply-To: <aIv+CgkePusUoT6Q@lizhi-Precision-Tower-5810>
Hi Frank,
Am Freitag, 1. August 2025, 01:36:42 CEST schrieb Frank Li:
> On Thu, Jul 31, 2025 at 08:32:57AM +0200, Krzysztof Kozlowski wrote:
> > On Thu, Jul 31, 2025 at 07:58:04AM +0200, Alexander Stein wrote:
> > > dtbs_check for ls1021.dtsi warns about unsupported property:
> > > power-controller@1ee2140 (fsl,ls1021a-rcpm): '#power-domain-cells' does not match any of the regexes: '^pinctrl-[0-9]+$'
> > >
> > > But if removed the check warns about missing property:
> > > power-controller@1ee2140 (fsl,ls1021a-rcpm): '#power-domain-cells' is a required property
> >
> >
> > And if any other warning says something, are you going to do that as
> > well?
> >
> > >
> > > Given commit 8bcf67b8d893b ("ARM: dts: ls1021a: add #power-domain-cells
> > > for power-controller node") explicitly added that property, add it
> > > to the expected property list as well.
> >
> > No, commit does not explain why! It's one of this NXP commits without
> > explanation, doing random things.
> >
> > No, explain why do you think this is a power domain provider - fast
> > look told me that it is NOT.
>
> It is not power controller. rcpm controller enable wakeup source.
>
> In arm64, use below patch to fix warning
>
> commit e39f567e1c38c29629962ab327f0ad1a288dcab2
> Author: Frank Li <Frank.Li@nxp.com>
> Date: Mon Jul 29 14:59:24 2024 -0400
>
> arm64: dts: layerscape: rename rcpm as wakeup-control from power-control
>
> Invoke power-domain.yaml if node name as 'power-control'.
>
> Rcpm actually are not power domain controller. It just control wakeup
> capability. So rename it as wakeup-control. Fix below CHECK_DTBS warning.
>
> power-controller@1ee2140: '#power-domain-cells' is a required property
> from schema $id: http://devicetree.org/schemas/power/power-domain.yaml#
>
> Signed-off-by: Frank Li <Frank.Li@nxp.com>
> Signed-off-by: Shawn Guo <shawnguo@kernel.org>
>
Thanks for the link. I've applied a similar change to ls1021 instead of this patch.
Thanks and best regards,
Alexander
--
TQ-Systems GmbH | Mühlstraße 2, Gut Delling | 82229 Seefeld, Germany
Amtsgericht München, HRB 105018
Geschäftsführer: Detlef Schneider, Rüdiger Stahl, Stefan Schneider
http://www.tq-group.com/
prev parent reply other threads:[~2025-08-12 6:21 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-07-31 5:58 [PATCH v2 1/1] dt-bindings: fsl: fsl,rcpm: Add #power-domain-cells Alexander Stein
2025-07-31 6:32 ` Krzysztof Kozlowski
2025-07-31 23:36 ` Frank Li
2025-08-12 6:14 ` Alexander Stein [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2799138.mvXUDI8C0e@steina-w \
--to=alexander.stein@ew.tq-group.com \
--cc=Frank.li@nxp.com \
--cc=christophe.leroy@csgroup.eu \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=krzk+dt@kernel.org \
--cc=krzk@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linuxppc-dev@lists.ozlabs.org \
--cc=robh@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.