From: Quentin Monnet <qmo@qmon.net>
To: Sahil <icegambit91@gmail.com>,
ast@kernel.org, daniel@iogearbox.net, andrii@kernel.org,
Quentin Monnet <quentin@isovalent.com>
Cc: martin.lau@linux.dev, eddyz87@gmail.com, song@kernel.org,
yonghong.song@linux.dev, john.fastabend@gmail.com,
kpsingh@kernel.org, sdf@google.com, haoluo@google.com,
jolsa@kernel.org, bpf@vger.kernel.org
Subject: Re: [PATCH bpf-next v2] bpftool: Mount bpffs on provided dir instead of parent dir
Date: Fri, 15 Mar 2024 09:59:28 +0000 [thread overview]
Message-ID: <355ad113-ce6c-4bfb-8ae3-8b1a37bdcda0@qmon.net> (raw)
In-Reply-To: <10467264.nUPlyArG6x@valdaarhun>
2024-03-14 21:16 UTC+0000 ~ Sahil <icegambit91@gmail.com>
> Hi,
>
> On Wednesday, March 13, 2024 9:17:44 PM IST Quentin Monnet wrote:
>> Thanks! Apologies for the delay.
>
> No worries! Thank you for the review.
>
>> [...]
>> Note: you don't need the blank lines between the tags.
>> [...]
>> You can keep the changelog as part of the patch description.
>
> Got it. I'll keep this in mind when I submit v3.
>
>> [...]
>> With all the checks and the potential directory creation, we could maybe
>> rename this into "prepare_bpffs_dir()" or something like this?
>
> "prepare_bpffs_dir" is quite apt. If longer names are acceptable then I
> would also recommend "prepare_and_mount_bpffs_dir" so it indicates
> that it'll also mount the bpffs on the dir (when relevant) after performing
> the checks.
The length looks acceptable to me. I used "prepare" to summarise "create
and mount", if you prefer "mount" explicitly then maybe
"create_and_mount_bpffs_dir()"? There's no other preparation step as far
as I remember so we should as well make it clear.
> That's really nice to hear. I'll incorporate the recommended changes and
> will send v3 soon.
Thanks a lot,
Quentin
next prev parent reply other threads:[~2024-03-15 10:09 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-03-08 13:06 [PATCH bpf-next v2] bpftool: Mount bpffs on provided dir instead of parent dir Sahil Siddiq
2024-03-13 15:47 ` Quentin Monnet
2024-03-14 21:16 ` Sahil
2024-03-15 9:59 ` Quentin Monnet [this message]
2024-03-21 19:22 ` Sahil
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=355ad113-ce6c-4bfb-8ae3-8b1a37bdcda0@qmon.net \
--to=qmo@qmon.net \
--cc=andrii@kernel.org \
--cc=ast@kernel.org \
--cc=bpf@vger.kernel.org \
--cc=daniel@iogearbox.net \
--cc=eddyz87@gmail.com \
--cc=haoluo@google.com \
--cc=icegambit91@gmail.com \
--cc=john.fastabend@gmail.com \
--cc=jolsa@kernel.org \
--cc=kpsingh@kernel.org \
--cc=martin.lau@linux.dev \
--cc=quentin@isovalent.com \
--cc=sdf@google.com \
--cc=song@kernel.org \
--cc=yonghong.song@linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.