From: "Christian König" <ckoenig.leichtzumerken@gmail.com>
To: Ce Sun <cesun102@amd.com>, amd-gfx@lists.freedesktop.org
Cc: dan.carpenter@linaro.org
Subject: Re: [PATCH] drm/amdgpu: Replace tmp_adev with hive in amdgpu_pci_slot_reset
Date: Wed, 9 Apr 2025 15:44:07 +0200 [thread overview]
Message-ID: <37c69d11-c82e-4ef9-9e01-661869cdb9d0@gmail.com> (raw)
In-Reply-To: <20250409133955.26169-1-cesun102@amd.com>
Am 09.04.25 um 15:39 schrieb Ce Sun:
> Checking hive is more readable.
>
> The following smatch warning:
> drivers/gpu/drm/amd/amdgpu/amdgpu_device.c:6820 amdgpu_pci_slot_reset()
> warn: iterator used outside loop: 'tmp_adev'
>
> Fixes: 8ba904f54148 ("drm/amdgpu: Multi-GPU DPC recovery support")
I think we should drop that. While the existing code didn't looked nice it would actually work as far as I can see.
> Reported-by: Dan Carpenter <dan.carpenter@linaro.org>
> Signed-off-by: Ce Sun <cesun102@amd.com>
Apart from that Reviewed-by: Christian König <christian.koenig@amd.com>.
Regards,
Christian
> ---
> drivers/gpu/drm/amd/amdgpu/amdgpu_device.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c
> index 60269fba5745..6fb234832ff3 100644
> --- a/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c
> +++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c
> @@ -6784,8 +6784,8 @@ pci_ers_result_t amdgpu_pci_slot_reset(struct pci_dev *pdev)
> struct drm_device *dev = pci_get_drvdata(pdev);
> struct amdgpu_device *adev = drm_to_adev(dev);
> struct amdgpu_reset_context reset_context;
> - struct amdgpu_device *tmp_adev = NULL;
> - struct amdgpu_hive_info *hive = NULL;
> + struct amdgpu_device *tmp_adev;
> + struct amdgpu_hive_info *hive;
> struct list_head device_list;
> int r = 0, i;
> u32 memsize;
> @@ -6846,7 +6846,7 @@ pci_ers_result_t amdgpu_pci_slot_reset(struct pci_dev *pdev)
> dev_info(adev->dev, "PCIe error recovery succeeded\n");
> } else {
> dev_err(adev->dev, "PCIe error recovery failed, err:%d\n", r);
> - if (tmp_adev) {
> + if (hive) {
> list_for_each_entry(tmp_adev, &device_list, reset_list)
> amdgpu_device_unset_mp1_state(tmp_adev);
> amdgpu_device_unlock_reset_domain(adev->reset_domain);
next prev parent reply other threads:[~2025-04-09 13:44 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-04-09 13:39 [PATCH] drm/amdgpu: Replace tmp_adev with hive in amdgpu_pci_slot_reset Ce Sun
2025-04-09 13:44 ` Christian König [this message]
2025-04-09 13:49 ` Lazar, Lijo
2025-04-09 13:56 ` Dan Carpenter
2025-04-10 8:09 ` Lazar, Lijo
-- strict thread matches above, loose matches on Subject: below --
2025-04-09 13:18 Ce Sun
2025-04-09 13:32 ` Christian König
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=37c69d11-c82e-4ef9-9e01-661869cdb9d0@gmail.com \
--to=ckoenig.leichtzumerken@gmail.com \
--cc=amd-gfx@lists.freedesktop.org \
--cc=cesun102@amd.com \
--cc=dan.carpenter@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.