From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from lists.gnu.org (lists.gnu.org [209.51.188.17]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.lore.kernel.org (Postfix) with ESMTPS id 0F976C369D1 for ; Fri, 25 Apr 2025 12:34:11 +0000 (UTC) Received: from localhost ([::1] helo=lists1p.gnu.org) by lists.gnu.org with esmtp (Exim 4.90_1) (envelope-from ) id 1u8IFR-0002FN-8j; Fri, 25 Apr 2025 08:33:41 -0400 Received: from eggs.gnu.org ([2001:470:142:3::10]) by lists.gnu.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.90_1) (envelope-from ) id 1u8IFP-0002CX-5c for qemu-riscv@nongnu.org; Fri, 25 Apr 2025 08:33:39 -0400 Received: from mail-pl1-x634.google.com ([2607:f8b0:4864:20::634]) by eggs.gnu.org with esmtps (TLS1.2:ECDHE_RSA_AES_128_GCM_SHA256:128) (Exim 4.90_1) (envelope-from ) id 1u8IFN-0005ZE-5V for qemu-riscv@nongnu.org; Fri, 25 Apr 2025 08:33:38 -0400 Received: by mail-pl1-x634.google.com with SMTP id d9443c01a7336-223fb0f619dso24153885ad.1 for ; Fri, 25 Apr 2025 05:33:36 -0700 (PDT) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=ventanamicro.com; s=google; t=1745584415; x=1746189215; darn=nongnu.org; h=content-transfer-encoding:in-reply-to:from:content-language :references:cc:to:subject:user-agent:mime-version:date:message-id :from:to:cc:subject:date:message-id:reply-to; bh=UIyb3tajohBn41IvsVzzTeHub8Xedi+O49qE04sxOw0=; b=XLVxdKRxRfIaVko5qsdxbkff76OcFJ+KFu/Qf3R+zY/b+w9cF2V9hHzJ7EjyDziyep WlJ8Ce42xd9YgafssvNAmWt6UCfg98k+V5OLHc1Ppw+mTQYBuxbQn6coi1Q6w4cePm6L ARKptFX7W0CUvUXIcWhTjmbcbQog3KAcMe2l7gvqapbqTv+m8RAEjny7Dtelz49FQMgm CMO4fp9YztM41AyFK68onFTVIYznAYYjoCpaQegCK6CYn6PSJc5/F0/ATAsK8E4EWG1K D6QLoMMh3gyziW0LJlDQoxedeUHU3kccIBUrRw8K9RrSCaXSLYV+EnTDlSPY6nOahpez FJQQ== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1745584415; x=1746189215; h=content-transfer-encoding:in-reply-to:from:content-language :references:cc:to:subject:user-agent:mime-version:date:message-id :x-gm-message-state:from:to:cc:subject:date:message-id:reply-to; bh=UIyb3tajohBn41IvsVzzTeHub8Xedi+O49qE04sxOw0=; b=YS5t1aMDIE/iXq7IyCXrr1NGOO4HEFsmUploH8fHo8H4J+0PvHMDVGEWJSTyEuUKXx 0KzTYMHcBCaPr95QqforNSMKPWOFq34S2XJDn1Ie/z/eA9nuGcRCBdijBYFtUqklkIaI 1cIFrTYlIi8gp+0acOolNZ+3SYmUKhVKjdKGzTziqm7URiWet7UNKJZwqWQC5fKqQ8+a hibteZtD1Ro3oFTN+7K4l7kXNus2w1VIfL2KnwG2Ogzb5G0XcFbG0eRy5hzwM8LQbUmh mjnVmfr65oQ5Sv3pBQPeUbVvYSolVCXNzGa3dXQtuA/Fv95UjHBIPwvi3/yweRITQOoU vr1Q== X-Forwarded-Encrypted: i=1; AJvYcCWz9PNk65fUnUpcS/8PkaH3P8V7oixCqE8B4Ruu4cc1bA1JW5qb5BBXL4ynh7hTMIl8XJUqy8eleLfe@nongnu.org X-Gm-Message-State: AOJu0YxU2wla9nKBOHKlHLYr7B9Q1v/NO60kfNXdEa4kgGYO/JMNpJ5d ge5OglX1rifb9d6JbF+7BmjzGBTP47kN+QuT9vk5vThPSxG/ahnbRq1nNFl48ML3caEJcHj4VDV W X-Gm-Gg: ASbGncsk1ryZ99igKET/42aKjJpXVD89Ii3NapNOQfslAcj05gzeDtSQY0GfXB51br3 KPTH6cjWGx0inOF0+QX9oMJEzyqr/zb4YE3r//hELpRVwO/TNVY88sBWLaGts/hvNpFtPB/q+dG PNOjTahhzqbEgyL4u/9rDMLFBUWqMER7bF2HDpd1CQZsb7vDQkKRcK4g1/2KzKrMP65lUFHwI/P smAdlhiJidmKqmTTHLRi1zlXUGWxdTzd/9isMVhJRVhtjRu0wQGih8Od+2JgA5AiBShT/boVNA0 cK1exHF1TGlFxaqfqjp/reVLyuz/pjBQpdv5XLj2CkBhZTGUaS9KeoI= X-Google-Smtp-Source: AGHT+IFsuOgb4AfDfFtK9DsAg/Z4N27i3msPmoOHBa83Kd+/b7ivqbld+jhH/B9tX7qIkhqzLhoKTA== X-Received: by 2002:a17:902:d492:b0:221:331:1d46 with SMTP id d9443c01a7336-22dbf5d9d49mr32266565ad.2.1745584415652; Fri, 25 Apr 2025 05:33:35 -0700 (PDT) Received: from [192.168.68.110] ([152.234.125.33]) by smtp.gmail.com with ESMTPSA id d9443c01a7336-22db5216a32sm30695405ad.219.2025.04.25.05.33.33 (version=TLS1_3 cipher=TLS_AES_128_GCM_SHA256 bits=128/128); Fri, 25 Apr 2025 05:33:35 -0700 (PDT) Message-ID: <3b31ef8d-87aa-4a38-8ada-39490f7a4908@ventanamicro.com> Date: Fri, 25 Apr 2025 09:33:31 -0300 MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Subject: Re: [PATCH 9/9] hw/riscv/virt.c: remove 'long' casts in fmt strings To: Joel Stanley Cc: qemu-devel@nongnu.org, qemu-riscv@nongnu.org, alistair.francis@wdc.com, liwei1518@gmail.com, zhiwei_liu@linux.alibaba.com, palmer@rivosinc.com References: <20250423110630.2249904-1-dbarboza@ventanamicro.com> <20250423110630.2249904-10-dbarboza@ventanamicro.com> Content-Language: en-US From: Daniel Henrique Barboza In-Reply-To: Content-Type: text/plain; charset=UTF-8; format=flowed Content-Transfer-Encoding: 7bit Received-SPF: pass client-ip=2607:f8b0:4864:20::634; envelope-from=dbarboza@ventanamicro.com; helo=mail-pl1-x634.google.com X-Spam_score_int: -20 X-Spam_score: -2.1 X-Spam_bar: -- X-Spam_report: (-2.1 / 5.0 requ) BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001 autolearn=ham autolearn_force=no X-Spam_action: no action X-BeenThere: qemu-riscv@nongnu.org X-Mailman-Version: 2.1.29 Precedence: list List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: qemu-riscv-bounces+qemu-riscv=archiver.kernel.org@nongnu.org Sender: qemu-riscv-bounces+qemu-riscv=archiver.kernel.org@nongnu.org On 4/24/25 6:41 AM, Joel Stanley wrote: > On Wed, 23 Apr 2025 at 20:39, Daniel Henrique Barboza > wrote: >> >> We can avoid the 'long' casts by using PRIx64 and HWADDR_PRIx on the fmt >> strings for uint64_t and hwaddr types. >> >> Signed-off-by: Daniel Henrique Barboza >> --- >> hw/riscv/virt.c | 29 +++++++++++++++-------------- >> 1 file changed, 15 insertions(+), 14 deletions(-) >> >> diff --git a/hw/riscv/virt.c b/hw/riscv/virt.c >> index 036a0a9bfb..075c035f25 100644 >> --- a/hw/riscv/virt.c >> +++ b/hw/riscv/virt.c >> @@ -309,7 +309,7 @@ static void create_fdt_socket_memory(RISCVVirtState *s, int socket) >> >> addr = s->memmap[VIRT_DRAM].base + riscv_socket_mem_offset(ms, socket); >> size = riscv_socket_mem_size(ms, socket); >> - mem_name = g_strdup_printf("/memory@%lx", (long)addr); >> + mem_name = g_strdup_printf("/memory@%"PRIx64, addr); > > I wondered why this wasn't a HWADDR_PRIx. > > addr (and NodeInfo::node_mem?) could be a hwaddr? That would make > everything more consistent. I didn't put too much thought about it in this patch. I saw that 'addr' was an uint64_t and just matched the format string. As for whether this 'addr' var and NodeInfo::node_mem could be a hwaddr, at first glance I don't see why not. There are lots of 'hwaddr' references in the memory API (memory_region_* functions, address_space* functions, etc) so using hwaddr in the memory context is valid. If we want to go further, the patch that introduced hwaddr in QEMU (commit a8170e5e) states: --------- Rename target_phys_addr_t to hwaddr target_phys_addr_t is unwieldly, violates the C standard (_t suffixes are reserved) and its purpose doesn't match the name (most target_phys_addr_t addresses are not target specific). Replace it with a finger-friendly, standards conformant hwaddr. --------- So it seems to me that the idea is to have an abstraction of target independent physical addresses, and memory is a good example of that. I believe we're not making full use of hwaddr and overusing uint64_t. Thanks, Daniel > > Cheers, > > Joel