From mboxrd@z Thu Jan 1 00:00:00 1970 From: Jernej =?utf-8?B?xaBrcmFiZWM=?= Date: Mon, 15 May 2017 21:47:57 +0200 Subject: [U-Boot] [PATCH 3/3] sunxi: video: Add H3/H5 TV out driver In-Reply-To: <20170515061155.jgz3yyzalsefudhp@flea.home> References: <20170510164630.22775-1-jernej.skrabec@siol.net> <20170515061155.jgz3yyzalsefudhp@flea.home> Message-ID: <4516924.7OMaFMZ77c@jernej-laptop> List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: u-boot@lists.denx.de Hi, Dne ponedeljek, 15. maj 2017 ob 08:11:55 CEST je Maxime Ripard napisal(a): > On Sun, May 14, 2017 at 09:03:19PM -0600, Simon Glass wrote: > > Hi, > > > > On 12 May 2017 at 10:06, Maxime Ripard wrote: > > > Hi Jernej, > > > > > > The patch content looks fine, but there's a few things that would need > > > to be addressed. > > > > > > On Wed, May 10, 2017 at 06:46:30PM +0200, Jernej Skrabec wrote: > > >> This commit adds support for TV (composite) output. > > >> > > >> Signed-off-by: Jernej Skrabec > > >> --- > > >> > > >> arch/arm/include/asm/arch-sunxi/cpu_sun4i.h | 10 ++ > > >> arch/arm/include/asm/arch-sunxi/display2.h | 17 +++ > > >> arch/arm/include/asm/arch-sunxi/tve.h | 17 ++- > > >> drivers/video/sunxi/Makefile | 2 +- > > >> drivers/video/sunxi/sunxi_de2.c | 60 ++++++++--- > > >> drivers/video/sunxi/sunxi_tve.c | 156 > > >> ++++++++++++++++++++++++++++ drivers/video/sunxi/tve.c > > >> | 6 +- > > > > > > The difference between sunxi_tve and tve is not really obvious. What > > > about calling sunxi_tve tve-uclass, or something like that? > > > > That name is reserved for actual uclasses. > > Ok. How are the driver-part usually called? I wanted to suggest that common part should be renamed to tve_common.c, but Anatolij already merged the patch. Best regards, Jernej