All of lore.kernel.org
 help / color / mirror / Atom feed
From: Mark Hollomon <markhollomon@comcast.net>
To: kernel-janitors@vger.kernel.org
Subject: Re: [KJ] [PATCH] Kconfig refactoring for better menu nesting
Date: Wed, 04 Oct 2006 20:02:59 +0000	[thread overview]
Message-ID: <45241373.4010503@comcast.net> (raw)
In-Reply-To: <1159944763.7669.6.camel@localhost.localdomain>

Randy Dunlap wrote:
> On Tue, 03 Oct 2006 23:52:43 -0700 Don Mullis wrote:
> 
>> Refactor Kconfig content to maximize nesting of menus by menuconfig
>> and xconfig.  No functional changes.
>>

...

>> Index: linux-2.6.18/drivers/pci/hotplug/Kconfig
>> =================================>> --- linux-2.6.18.orig/drivers/pci/hotplug/Kconfig
>> +++ linux-2.6.18/drivers/pci/hotplug/Kconfig
>> @@ -76,7 +76,8 @@ config HOTPLUG_PCI_IBM
>>  
>>  config HOTPLUG_PCI_ACPI
>>  	tristate "ACPI PCI Hotplug driver"
>> -	depends on (!ACPI_DOCK && ACPI && HOTPLUG_PCI) || (ACPI_DOCK && HOTPLUG_PCI)
>> +	depends on HOTPLUG_PCI
>> +	depends on (!ACPI_DOCK && ACPI) || (ACPI_DOCK)
> 
> Yep, much more readable to me.

I'm not sure about the semantics of "depends on" but in boolean logic:

(!ACPI_DOCK && ACPI) || (ACPI_DOCK) = (!ACPI_DOCK || ACPI_DOCK) && (ACPI || ACPI_DOCK)

= (true) && (ACPI || ACPI_DOCK)
= ACPI || ACPI_DOCK

Is there something about "depends on" that would make the far simpler expression incorrect?



-- 
Mark Hollomon
_______________________________________________
Kernel-janitors mailing list
Kernel-janitors@lists.osdl.org
https://lists.osdl.org/mailman/listinfo/kernel-janitors

  parent reply	other threads:[~2006-10-04 20:02 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2006-10-04  6:52 [KJ] [PATCH] Kconfig refactoring for better menu nesting Don Mullis
2006-10-04 17:47 ` Randy Dunlap
2006-10-04 20:02 ` Mark Hollomon [this message]
2006-10-04 20:32 ` Randy Dunlap
2006-10-05  7:08 ` Don Mullis
2006-10-05  8:21 ` Don Mullis
2006-10-05  8:24 ` Don Mullis
2006-10-09  2:29 ` [KJ] [PATCH] Kconfig refactoring for better menu nesting, v.2 Randy Dunlap
2006-10-09  4:56 ` [KJ] [PATCH] Kconfig refactoring for better menu nesting, v.3 Don Mullis
2006-10-09  5:12 ` Randy Dunlap

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=45241373.4010503@comcast.net \
    --to=markhollomon@comcast.net \
    --cc=kernel-janitors@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.