From: Patrick McHardy <kaber@trash.net>
To: Jan Engelhardt <jengelh@computergmbh.de>
Cc: Netfilter Developer Mailing List <netfilter-devel@vger.kernel.org>
Subject: Re: [PATCH] Unique symbol names
Date: Sat, 20 Oct 2007 17:17:39 +0200 [thread overview]
Message-ID: <471A1C13.7080807@trash.net> (raw)
In-Reply-To: <Pine.LNX.4.64.0710201711320.1997@fbirervta.pbzchgretzou.qr>
Jan Engelhardt wrote:
> On Oct 20 2007 17:09, Patrick McHardy wrote:
>> Jan Engelhardt wrote:
>>> Give the target, match, check, etc. functions unique names.
>>>
>>> static unsigned int
>>> -target(struct sk_buff *skb,
>>> - const struct net_device *in,
>>> - const struct net_device *out,
>>> - unsigned int hooknum,
>>> - const struct xt_target *target,
>>> - const void *targinfo)
>>> +CLUSTERIP_target(struct sk_buff *skb, const struct net_device *in,
>>> + const struct net_device *out, unsigned int hooknum,
>>> + const struct xt_target *target, const void *targinfo)
>>> {
>> I don't really like this naming scheme since it uses capital letters
>> in the function name. The _target prefix should be enough to distinguish
>> matches and targets, no?
>
> Had not thought about that yet, but yes.
>
> What about MARK_parse_v0 vs. mark_parse_v0? I did not feel like
> elongating that to xt_mark_target_parse_v0 and xt_mark_match_parse_v0.
Yeah, thats not so great either. Can't think of a better scheme
right now, anyone else got some suggestions?
prev parent reply other threads:[~2007-10-20 15:18 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-10-20 11:44 [PATCH] Unique symbol names Jan Engelhardt
2007-10-20 15:09 ` Patrick McHardy
2007-10-20 15:12 ` Jan Engelhardt
2007-10-20 15:17 ` Patrick McHardy [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=471A1C13.7080807@trash.net \
--to=kaber@trash.net \
--cc=jengelh@computergmbh.de \
--cc=netfilter-devel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.