From: Jan Beulich <jbeulich@suse.com>
To: dmkhn@proton.me
Cc: andrew.cooper3@citrix.com, anthony.perard@vates.tech,
julien@xen.org, michal.orzel@amd.com, roger.pau@citrix.com,
sstabellini@kernel.org, dmukhin@ford.com,
xen-devel@lists.xenproject.org
Subject: Re: [PATCH v1 3/8] xen/domain: introduce domid_top
Date: Wed, 26 Mar 2025 14:52:37 +0100 [thread overview]
Message-ID: <4d24b27a-df7c-45cc-85d4-a1dbc4057aac@suse.com> (raw)
In-Reply-To: <20250318233617.849903-4-dmukhin@ford.com>
On 19.03.2025 00:36, dmkhn@proton.me wrote:
> Rename max_init_domid to domid_top to align with its usage in the code
> (Arm), where it represents the upper boundary of the non-system domain
> ID range.
I think I said before that I don't share this view of yours. The variable
is quite appropriately named; it's the further use you made of it in earlier
versions of work of yours in this area where the name ended up no longer
reflecting the purpose. Yet that's not a reason to change the name.
I'm unconvinced we actually need a variable tracking the largest known
non-system domain ID. The domain list is sorted, so obtaining that ID
should be reasonably easy and cheap without such a variable.
Furthermore such a variable would likely also need reducing when the
domain with the highest ID dies.
> --- a/xen/drivers/char/console.c
> +++ b/xen/drivers/char/console.c
> @@ -472,7 +472,7 @@ static void cf_check dump_console_ring_key(unsigned char key)
> */
> static unsigned int __read_mostly console_rx = 0;
>
> -#define max_console_rx (max_init_domid + 1)
> +#define max_console_rx (domid_top + 1)
This use in particular is bogus. The intention here is to permit console
access only to (some?) domains created during boot. Making a (conceptual)
change here would require separate justification.
Jan
next prev parent reply other threads:[~2025-03-26 13:53 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-03-18 23:36 [PATCH v1 0/8] xen/console: cleanup console input switch logic dmkhn
2025-03-18 23:36 ` [PATCH v1 1/8] xen/console: fix trailing whitespaces dmkhn
2025-03-19 9:45 ` Jan Beulich
2025-03-18 23:36 ` [PATCH v1 2/8] xen/console: introduce console input permission dmkhn
2025-03-26 13:44 ` Jan Beulich
2025-03-29 0:03 ` Denis Mukhin
2025-03-18 23:36 ` [PATCH v1 3/8] xen/domain: introduce domid_top dmkhn
2025-03-26 13:52 ` Jan Beulich [this message]
2025-03-18 23:36 ` [PATCH v1 4/8] xen/domain: introduce domid_alloc() dmkhn
2025-03-26 13:56 ` Jan Beulich
2025-03-18 23:36 ` [PATCH v1 5/8] xen/console: rename switch_serial_input() to console_switch_focus() dmkhn
2025-03-26 13:58 ` Jan Beulich
2025-03-18 23:36 ` [PATCH v1 6/8] xen/console: rename console_rx to console_focus dmkhn
2025-03-26 14:00 ` Jan Beulich
2025-03-18 23:37 ` [PATCH v1 7/8] xen/console: introduce console_set_focus() dmkhn
2025-03-19 19:53 ` Denis Mukhin
2025-03-26 14:28 ` Jan Beulich
2025-03-26 14:32 ` Jan Beulich
2025-03-18 23:37 ` [PATCH v1 8/8] xen/console: introduce console_get_focus() dmkhn
2025-03-19 19:52 ` [PATCH v1 0/8] xen/console: cleanup console input switch logic Denis Mukhin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4d24b27a-df7c-45cc-85d4-a1dbc4057aac@suse.com \
--to=jbeulich@suse.com \
--cc=andrew.cooper3@citrix.com \
--cc=anthony.perard@vates.tech \
--cc=dmkhn@proton.me \
--cc=dmukhin@ford.com \
--cc=julien@xen.org \
--cc=michal.orzel@amd.com \
--cc=roger.pau@citrix.com \
--cc=sstabellini@kernel.org \
--cc=xen-devel@lists.xenproject.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.