From mboxrd@z Thu Jan 1 00:00:00 1970 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: base64 Subject: [v2,01/21] usb: phy: use match_string() helper From: Xie Yisheng Message-Id: <4ea021ae-1284-4519-e467-5c03bc62c98b@huawei.com> Date: Tue, 5 Jun 2018 17:28:32 +0800 To: Andy Shevchenko , Sergei Shtylyov Cc: Linux Kernel Mailing List , USB , Felipe Balbi , Greg Kroah-Hartman List-ID: T24gMjAxOC82LzEgMjo1OSwgQW5keSBTaGV2Y2hlbmtvIHdyb3RlOgo+IE9uIFRodSwgTWF5IDMx LCAyMDE4IGF0IDk6NTYgUE0sIFNlcmdlaSBTaHR5bHlvdgo+IDxzZXJnZWkuc2h0eWx5b3ZAY29n ZW50ZW1iZWRkZWQuY29tPiB3cm90ZToKPj4gT24gMDUvMzEvMjAxOCAwOTo0NyBQTSwgQW5keSBT aGV2Y2hlbmtvIHdyb3RlOgo+IAo+Pj4+PiAtICAgICBpbnQgZXJyLCBpOwo+IAo+Pj4+PiArICAg ICBlcnIgPSBtYXRjaF9zdHJpbmcodXNicGh5X21vZGVzLCBBUlJBWV9TSVpFKHVzYnBoeV9tb2Rl cyksIHBoeV90eXBlKTsKPj4+Pj4gKyAgICAgaWYgKGVyciA8IDApCj4+Pj4KPj4+PiAgICBUaGlz IGlzIG9uZSBvZiB0aGUgZmV3IGNhc2VzIHdoZW4gJ2VycicgaXMgbm90IHRoZSBiZXN0IG5hbWUg Zm9yIHN1Y2ggYQo+Pj4+IHZhcmlhYmxlLiBJJ2QgcHJlZmVyIHRvIHNlZSBzb21ldGhpbmcgbGlr ZSAnbWF0Y2gnIG9yIGV2ZW4gJ3JjJyBvciAncmV0Jy4uLiA6LSkKPj4+Cj4+PiBUaGVuIGxlYXZp bmcgaSB3b3VsZCBtYWtlIGl0Pwo+PiAgICBZZXMuIDotKQo+IAo+IFNvLCBJIGxlYXZlIGl0IHRv IEdyZWcgdG8gZGVjaWRlIGVpdGhlciBpdCdzIG9rYXkgaW4gdGhpcyB2ZXJzaW9uLCBvcgo+IG5l ZWRzIHVwZGF0ZSB3aXRoIGkgbGVmdCB1bnRvdWNoZWQuCkhpIEdyZWcsCgpJSVJDLCB5b3Ugc2Vl bXMgd2FudCB0byBrZWVwIHRoZSBlcnIgdW5jaGFuZ2VkLCByaWdodD8KClBsZWFzZSBsZXQgbWUg a25vdyBpZiBhbm90aGVyIHZlcnNpb24gaXMgbmVlZC4KClRoYW5rcwpZaXNoZW5nCgo+IAo+Pj4g SSdtIG9rYXkgd2l0aCBlaXRoZXIgd2hpY2gganVzdCBub3QgcmVuYW1lcyBlcnIsIGIvYyBpdCdz IHVzZWQgd2l0aAo+Pj4gc29tZXRoaW5nIGVsc2UgaW4gdGhpcyBmdW5jdGlvbi4KPj4KPj4gICAg TG9va2luZyBhdCBpdCBhZ2FpbiwgJ2Vycicgc2VlbXMgZXF1YWxseSBiYWQgZm9yIHRoZSByZXN1 bHQgb2YKPj4gb2ZfcHJvcGVydHlfcmVhZF9zdHJpbmcoKS4uLiB1bmxlc3MgdGhlIGNoZWNrIHRo ZXJlIGlzIGNoYW5nZWQgdG8ganVzdCAqaWYqIChlcnIpIC0tCj4+IHRoaXMgZnVuY3Rpb24gbmV2 ZXIgcmV0dXJucyBwb3NpdGl2ZSB2YWx1ZXMsIDAgbWVhbnMgc3VjY2Vzcywgb3RoZXJzIG1lYW4g ZXJyb3IuCj4gCj4gV2hpbGUgeW91IHNlZW1zIHJpZ2h0LCB0aGlzIGlzIG1hdHRlciBvZiBhbm90 aGVyIGNoYW5nZSB3aGljaCB5b3UgYXJlCj4gd2VsY29tZSB0byBwcm9wb3NlLgo+Ci0tLQpUbyB1 bnN1YnNjcmliZSBmcm9tIHRoaXMgbGlzdDogc2VuZCB0aGUgbGluZSAidW5zdWJzY3JpYmUgbGlu dXgtdXNiIiBpbgp0aGUgYm9keSBvZiBhIG1lc3NhZ2UgdG8gbWFqb3Jkb21vQHZnZXIua2VybmVs Lm9yZwpNb3JlIG1ham9yZG9tbyBpbmZvIGF0ICBodHRwOi8vdmdlci5rZXJuZWwub3JnL21ham9y ZG9tby1pbmZvLmh0bWwK From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751577AbeFEJ3c (ORCPT ); Tue, 5 Jun 2018 05:29:32 -0400 Received: from szxga04-in.huawei.com ([45.249.212.190]:8643 "EHLO huawei.com" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1751437AbeFEJ3b (ORCPT ); Tue, 5 Jun 2018 05:29:31 -0400 Subject: Re: [PATCH v2 01/21] usb: phy: use match_string() helper To: Andy Shevchenko , Sergei Shtylyov References: <1527765086-19873-1-git-send-email-xieyisheng1@huawei.com> <1527765086-19873-2-git-send-email-xieyisheng1@huawei.com> CC: Linux Kernel Mailing List , USB , Felipe Balbi , "Greg Kroah-Hartman" From: Yisheng Xie Message-ID: <4ea021ae-1284-4519-e467-5c03bc62c98b@huawei.com> Date: Tue, 5 Jun 2018 17:28:32 +0800 User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Thunderbird/45.1.0 MIME-Version: 1.0 In-Reply-To: Content-Type: text/plain; charset="utf-8" Content-Transfer-Encoding: 7bit X-Originating-IP: [10.177.29.40] X-CFilter-Loop: Reflected Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 2018/6/1 2:59, Andy Shevchenko wrote: > On Thu, May 31, 2018 at 9:56 PM, Sergei Shtylyov > wrote: >> On 05/31/2018 09:47 PM, Andy Shevchenko wrote: > >>>>> - int err, i; > >>>>> + err = match_string(usbphy_modes, ARRAY_SIZE(usbphy_modes), phy_type); >>>>> + if (err < 0) >>>> >>>> This is one of the few cases when 'err' is not the best name for such a >>>> variable. I'd prefer to see something like 'match' or even 'rc' or 'ret'... :-) >>> >>> Then leaving i would make it? >> Yes. :-) > > So, I leave it to Greg to decide either it's okay in this version, or > needs update with i left untouched. Hi Greg, IIRC, you seems want to keep the err unchanged, right? Please let me know if another version is need. Thanks Yisheng > >>> I'm okay with either which just not renames err, b/c it's used with >>> something else in this function. >> >> Looking at it again, 'err' seems equally bad for the result of >> of_property_read_string()... unless the check there is changed to just *if* (err) -- >> this function never returns positive values, 0 means success, others mean error. > > While you seems right, this is matter of another change which you are > welcome to propose. >