All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jaehoon Chung <jh80.chung@samsung.com>
To: Alim Akhtar <alim.akhtar@gmail.com>
Cc: Sachin Kamat <sachin.kamat@linaro.org>,
	linux-mmc@vger.kernel.org, cjb@laptop.org, tgih.jun@samsung.com,
	jh80.chung@samsung.com, patches@linaro.org,
	Thomas Abraham <thomas.abraham@linaro.org>
Subject: Re: [PATCH 1/2] mmc: dw_mmc: exynos: Add compatibility for exynos4412 SoC
Date: Fri, 15 Feb 2013 14:24:05 +0900	[thread overview]
Message-ID: <511DC675.4050004@samsung.com> (raw)
In-Reply-To: <CAGOxZ52iXBzv9capeJoe0-_GXEABOmuTOUzSWXX2vV174n7C3g@mail.gmail.com>

On 02/15/2013 02:09 PM, Alim Akhtar wrote:
> Hi Sachin,
> 
> On Thu, Feb 14, 2013 at 8:55 PM, Sachin Kamat <sachin.kamat@linaro.org> wrote:
>> On 07/02/2013, Sachin Kamat <sachin.kamat@linaro.org> wrote:
>>> Added compatibility string for Exynos4412 SoC.
>>>
>>> Cc: Thomas Abraham <thomas.abraham@linaro.org>
>>> Signed-off-by: Sachin Kamat <sachin.kamat@linaro.org>
>>
>> Any comments on this patch?
>>
>>> ---
>>>  drivers/mmc/host/dw_mmc-exynos.c |    2 ++
>>>  1 files changed, 2 insertions(+), 0 deletions(-)
>>>
>>> diff --git a/drivers/mmc/host/dw_mmc-exynos.c
>>> b/drivers/mmc/host/dw_mmc-exynos.c
>>> index 72fd0f2..f15b4d3 100644
>>> --- a/drivers/mmc/host/dw_mmc-exynos.c
>>> +++ b/drivers/mmc/host/dw_mmc-exynos.c
>>> @@ -209,6 +209,8 @@ static const struct dw_mci_drv_data exynos5250_drv_data
>>> = {
>>>  };
>>>
>>>  static const struct of_device_id dw_mci_exynos_match[] = {
>>> +     { .compatible = "samsung,exynos4412-dw-mshc",
>>> +                     .data = &exynos5250_drv_data, },
>>>       { .compatible = "samsung,exynos5250-dw-mshc",
>>>                       .data = &exynos5250_drv_data, },
>>>       {},
> 
> Looks like dw_mci_drv_data is a generic enough to be used for all
> exynos SoCs including exynos4210. My thought is, if 4412 and 5250 is
> using the same drv_data(please check 4210 once), let rename them as
> exynos. In that case we still have different compatible name and not
> so __confusing__ .data field.
I agreed Alim's opinion. Actually, i mentioned this point at the Dongin's patch.
If using same drv_data, i would prefer to use "&exynos_drv_data" instead of &exynos5250_drv_data.

This patch could be separated into two patches. like this "compatibility for exynos4412 SOC" and "rename the drv_data"

Best Regards,
Jaehoon Chung
> I am ok if maintainers suggested something else/better here.
>>>
>>> 1.7.4.1
>>>
>>>
>>
>>
>> --
>> With warm regards,
>> Sachin
>> --
>> To unsubscribe from this list: send the line "unsubscribe linux-mmc" in
>> the body of a message to majordomo@vger.kernel.org
>> More majordomo info at  http://vger.kernel.org/majordomo-info.html


  reply	other threads:[~2013-02-15  5:24 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-02-07 11:57 [PATCH 1/2] mmc: dw_mmc: exynos: Add compatibility for exynos4412 SoC Sachin Kamat
2013-02-07 11:57 ` [PATCH 2/2] mmc: dw_mmc: exynos: Add pinctrl support Sachin Kamat
2013-02-07 15:30   ` Linus Walleij
2013-02-25  4:39     ` Sachin Kamat
2013-02-27 23:19       ` Linus Walleij
2013-02-14 15:25 ` [PATCH 1/2] mmc: dw_mmc: exynos: Add compatibility for exynos4412 SoC Sachin Kamat
2013-02-15  5:09   ` Alim Akhtar
2013-02-15  5:24     ` Jaehoon Chung [this message]
2013-02-15  9:10       ` Sachin Kamat
2013-02-18  8:46       ` Sachin Kamat
2013-02-18  9:04         ` Dongjin Kim
2013-02-18  9:09           ` Sachin Kamat

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=511DC675.4050004@samsung.com \
    --to=jh80.chung@samsung.com \
    --cc=alim.akhtar@gmail.com \
    --cc=cjb@laptop.org \
    --cc=linux-mmc@vger.kernel.org \
    --cc=patches@linaro.org \
    --cc=sachin.kamat@linaro.org \
    --cc=tgih.jun@samsung.com \
    --cc=thomas.abraham@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.