From: "Arnd Bergmann" <arnd@arndb.de>
To: "Greg Kroah-Hartman" <gregkh@linuxfoundation.org>,
"Alex Elder" <elder@riscstar.com>
Cc: "Rob Herring" <robh@kernel.org>,
krzk+dt@kernel.org, "Conor Dooley" <conor+dt@kernel.org>,
bhelgaas@google.com, daniel@riscstar.com,
mohdayaa@qti.qualcomm.com, lbiancon@qti.qualcomm.com,
devicetree@vger.kernel.org, linux-pci@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2/2] misc: tc9564: introduce base PCI driver
Date: Fri, 14 Aug 2026 09:31:11 +0200 [thread overview]
Message-ID: <56aef294-8d1d-40f2-a371-ea3f5ede2ccf@app.fastmail.com> (raw)
In-Reply-To: <2026081455-eternity-douche-900b@gregkh>
On Fri, Aug 14, 2026, at 03:11, Greg KH wrote:
> On Thu, Aug 13, 2026 at 05:29:42PM -0500, Alex Elder wrote:
>> +#define DRIVER_NAME "tc9564-pci"
>
> What about just using KBUILD_MODNAME?
>
>> +static int
>> +tc9564_function_probe(struct pci_dev *pdev, const struct pci_device_id *id)
>
> But wow, this is a tiny driver, feels odd to have it in misc/ but ok, if
> you think it should be here...
We have drivers/misc/rp1/ and drivers/misc/lan966x_pci*.c with similar
functionality, so at least there is precedence for putting them here.
From the old days, we still have drivers/mfd/sm501.c, drivers/mfd/cs5535-mfd.c,
and a few others that open-code the on-chip components as mfd cels
instead of using devicetree description.
At some point, we should think about grouping them into a separate
subdirectory.
Arnd
next prev parent reply other threads:[~2026-08-14 7:32 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-13 22:29 [PATCH 0/2] PCI: introduce TC9564 misc driver Alex Elder
2026-08-13 22:29 ` [PATCH 1/2] dt-bindings: misc: introduce pci1179,0220.yaml Alex Elder
2026-08-14 1:45 ` sashiko-bot
2026-08-14 7:01 ` Krzysztof Kozlowski
2026-08-13 22:29 ` [PATCH 2/2] misc: tc9564: introduce base PCI driver Alex Elder
2026-08-14 1:11 ` Greg KH
2026-08-14 7:31 ` Arnd Bergmann [this message]
2026-08-14 1:59 ` sashiko-bot
2026-08-14 7:03 ` Krzysztof Kozlowski
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=56aef294-8d1d-40f2-a371-ea3f5ede2ccf@app.fastmail.com \
--to=arnd@arndb.de \
--cc=bhelgaas@google.com \
--cc=conor+dt@kernel.org \
--cc=daniel@riscstar.com \
--cc=devicetree@vger.kernel.org \
--cc=elder@riscstar.com \
--cc=gregkh@linuxfoundation.org \
--cc=krzk+dt@kernel.org \
--cc=lbiancon@qti.qualcomm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=mohdayaa@qti.qualcomm.com \
--cc=robh@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.