All of lore.kernel.org
 help / color / mirror / Atom feed
From: Stephen Warren <swarren@wwwdotorg.org>
To: u-boot@lists.denx.de
Subject: [U-Boot] reset uclass rename?
Date: Wed, 11 May 2016 12:45:03 -0600	[thread overview]
Message-ID: <57337DAF.4060300@wwwdotorg.org> (raw)

Simon,

For Tegra186 support, I'd like to introduce a reset subsystem into 
U-Boot, to support the reset DT bindings[1]. It'd be equivalent to the 
existing reset subsystem in Linux. This binding/subsystem does/would 
control reset of e.g. individual HW blocks in an SoC, or individual 
chips on the board.

It looks like there's already a "reset" uclass (include/reset.h, 
drivers/misc/reset*.c). However, that seems to address a slightly 
different case; CPU- or system-level reset rather than individual blocks.

I'd like to propose renaming the existing uclass to sysreset (system 
reset) to allow the new per-block/-module reset uclass/subsystem just 
"reset". Does that make sense to you, or should I name the new 
uclass/subsystem e.g. "module_reset"?

An alternative might be to extend the existing U-Boot reset subsystem to 
cover the new use-case too. However, U-Boot's existing concepts of warm 
vs. cold vs. power reset, and reset_walk_halt() don't exist in the reset 
DT bindings, so my instinct is that combining the two doesn't make sense 
semantically; I believe the sysreset API is a higher level concept that 
may use the raw capabilities of the new reset API in some HW-specific 
implementations.

[1] 
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/tree/Documentation/devicetree/bindings/reset 
(in particular, reset.txt)

             reply	other threads:[~2016-05-11 18:45 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-05-11 18:45 Stephen Warren [this message]
2016-05-11 19:01 ` [U-Boot] reset uclass rename? Simon Glass

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=57337DAF.4060300@wwwdotorg.org \
    --to=swarren@wwwdotorg.org \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.