Attention is currently required from: plaisthos.
Patch set 1:Code-Review -1
1 comment:
File src/openvpn/multi.c:
Patch Set #1, Line 4109: if (mi->context.c2.tls_multi->peer_id > m->max_peerid)
I would suggest moving this code below the ASSERT. In the end it makes no difference. But I think it is easier to read if the code that checks that the loop failed is directly below the loop.
As an aside I think the ASSERT is a bit unclear already. I think what it actually should check is against MAX_PEER_ID, not max_clients. From this code it is not clear that it assumes that peer_id was initialized to MAX_PEER_ID. So I think it would be better to have an ASSERT at the top of the function that checks that peer_id is indeed MAX_PEER_ID and then an assert below that checks that peer_id is not MAX_PEER_ID. Much clearer. But not directly the job of this patch.
To view, visit change 1557. To unsubscribe, or for help writing mail filters, visit settings.