From: "David Hildenbrand (Arm)" <david@kernel.org>
To: Ackerley Tng <ackerleytng@google.com>,
aik@amd.com, andrew.jones@linux.dev, binbin.wu@linux.intel.com,
brauner@kernel.org, chao.p.peng@linux.intel.com,
jmattson@google.com, jthoughton@google.com, michael.roth@amd.com,
oupton@kernel.org, pankaj.gupta@amd.com, qperret@google.com,
rick.p.edgecombe@intel.com, rientjes@google.com,
shivankg@amd.com, steven.price@arm.com, tabba@google.com,
willy@infradead.org, wyihan@google.com, yan.y.zhao@intel.com,
forkloop@google.com, pratyush@kernel.org, suzuki.poulose@arm.com,
aneesh.kumar@kernel.org, liam@infradead.org,
Paolo Bonzini <pbonzini@redhat.com>,
Sean Christopherson <seanjc@google.com>,
Thomas Gleixner <tglx@kernel.org>, Ingo Molnar <mingo@redhat.com>,
Borislav Petkov <bp@alien8.de>,
Dave Hansen <dave.hansen@linux.intel.com>,
x86@kernel.org, "H. Peter Anvin" <hpa@zytor.com>,
Steven Rostedt <rostedt@goodmis.org>,
Masami Hiramatsu <mhiramat@kernel.org>,
Mathieu Desnoyers <mathieu.desnoyers@efficios.com>,
Jonathan Corbet <corbet@lwn.net>,
Shuah Khan <skhan@linuxfoundation.org>,
Shuah Khan <shuah@kernel.org>,
Vishal Annapurve <vannapurve@google.com>,
Andrew Morton <akpm@linux-foundation.org>,
Chris Li <chrisl@kernel.org>, Kairui Song <kasong@tencent.com>,
Kemeng Shi <shikemeng@huaweicloud.com>,
Nhat Pham <nphamcs@gmail.com>, Barry Song <baohua@kernel.org>,
Axel Rasmussen <axelrasmussen@google.com>,
Yuanchu Xie <yuanchu@google.com>, Wei Xu <weixugc@google.com>,
Youngjun Park <youngjun.park@lge.com>,
Qi Zheng <qi.zheng@linux.dev>,
Shakeel Butt <shakeel.butt@linux.dev>,
Kiryl Shutsemau <kas@kernel.org>,
Baoquan He <baoquan.he@linux.dev>, Jason Gunthorpe <jgg@ziepe.ca>,
John Hubbard <jhubbard@nvidia.com>, Peter Xu <peterx@redhat.com>,
Vlastimil Babka <vbabka@kernel.org>,
"hughd@google.com" <hughd@google.com>
Cc: kvm@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-trace-kernel@vger.kernel.org, linux-doc@vger.kernel.org,
linux-kselftest@vger.kernel.org, linux-mm@kvack.org,
linux-coco@lists.linux.dev
Subject: Re: [PATCH v9 14/41] mm: swap: Introduce lru_add_drain_progressive()
Date: Fri, 31 Jul 2026 16:09:14 +0200 [thread overview]
Message-ID: <60552bee-3326-4917-b00f-5fb7ba3b8adb@kernel.org> (raw)
In-Reply-To: <CAEvNRgEas_9BEV-cNxXu4_wQx8sR2M4_OaW6DEd4=fszALMV0w@mail.gmail.com>
On 7/31/26 15:03, Ackerley Tng wrote:
> "David Hildenbrand (Arm)" <david@kernel.org> writes:
>
>> On 7/31/26 12:22, David Hildenbrand (Arm) wrote:
>>>
>>> Just nasty :)
>>>
>>>
>>> mlocked folios in the mlock cache hold a reference as well.
>>>
>>>
>>> I was trying to avoid messing with the refcount for ordinary LRU cache pages.
>>> mlock() should be a corner case for guest_memfd.
>>>
>>> Relying on the refcount just means that one unconditionally performs a lot of LRU
>>> cache draining even though it doesn't make any sense.
>>>
>>>
>>> Again, the problem is that on *any* raised reference you would drain. I
>>> was trying to limit the harm.
>>>
>>> [...]
>>>
>>>
>>> Why?
>>>
>>>
>>> Why?
>>>
>>> That's literally what the existing refcount check tries to do: figure out if
>>> there are LRU caches.
>>>
>>>
>>> I really don't understand what you are trying to say.
>>>
>>> Draining only makes sense if something is on the LRU cache. And there are
>>> better ways of checking that than relying only on even less precise refcounts.
>>>
>>> If someone wants to do an early refcount check to abort the overall
>>> operation, that's fine.
>>>
>>>
>>> ?!
>>>
>>> That's why we have the universal definition of expected references and the
>>> common helper.
>>>
>>> Because pagecache pages commonly don't support the swapcache.
>>>
>>>
>>> It must, because that is used all over the place. The only thing it
>>> cannot deal with is references held by the caller (which could be supplied
>>> through and "additional references" parameter like we do elsewhere).
>>>
>>>
>>> You're not seriously proposing such an abomination I hope?
>>>
>>>
>>> You can just check early for mappings.
>>>
>>> Remember: this is about LRU draining, *not* about your final
>>> "unexpected references" check.
>>>
>>>
>>> Who cares if we end up with a common usable helper? We have usless
>>> checks *all over the place* in common helpers.
>>>
>>>
>>> Yuk.
>>>
>>>
>>> Putting an enum into a header is a problem in which universe? :)
>>>
>>> Ackerley, please stop making up stuff. Having generic helper is not a problem. Doing
>>> checks in common helpers is not a problem. Putting enums in headers is not a problem.
>>>
>>> Your version is just bad.
>>>
>>> I can later try something that keeps the questionable refcount checks in place,
>>> maybe that could do as a temporary solution until Hugh possibly finds a way to
>>> remove the need for draining entirely.
>>>
>>
>> And looking at it, the current folio_ref_count() in GUP is entirely wrong
>> and always makes us drain local+all.
>>
>> Let me fix that first, which will also modify this code.
>>
>> I'd say, to unblock gmem we could have something minimal that I would clean
>> up later, but I think the problem is that lru_add_drain() / lru_add_drain_all()
>> is not exported, right?
>>
>
> My bad, I totally mixed up refcounting to drain with refcounting for the
> safe conversion and didn't have a complete understanding of mlock().
>
> The problem for gmem was that if there was an elevated refcount on some
> folio in the range, it might be because the folio was in the lru_add
> fbatch.
Right.
>
> If it were in the lru_add fbatch, it would be fine to just drain the
> lru_add fbatch and proceed with the conversion.
>
> lru_add_drain() isn't sufficient since the conversion might be handled
> on one CPU when the folio is on another CPU's fbatch, so I had to do
> lru_add_drain_all(), but lru_add_drain_all() causes IPIs which are
> expensive.
Yes.
You should probably do an early
folio_maybe_dma_pinned() || folio_mapped() check and just return -- don't drain.
>
> In an earlier revision I exported lru_add_drain_all(). My understanding
> of the discussion at guest_memfd biweekly was that Sean didn't want us
> to export lru_add_drain_all() now, and then end up exporting some other
> function and unexporting lru_add_drain_all(). To avoid exporting and
> unexporting, we then said we should refactor now.
>
> Happy to go with your proposal too.
Yeah, I have to look into this more closely. I'm now convinced that we really
have to use the refcount for now, but hopefully we can limit it on
folio_expected_refcount() internally + additional references
from the caller.
I'm quite busy today, but let me flesh something out that actually works.
--
Cheers,
David
next prev parent reply other threads:[~2026-07-31 14:09 UTC|newest]
Thread overview: 108+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-29 0:34 [PATCH v9 00/41] guest_memfd: In-place conversion support Ackerley Tng via B4 Relay
2026-07-29 0:34 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 01/41] KVM: guest_memfd: Introduce per-gmem attributes, use to guard user mappings Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-31 8:57 ` Xiaoyao Li
2026-07-31 16:08 ` Sean Christopherson
2026-07-29 0:35 ` [PATCH v9 02/41] KVM: Rename KVM_GENERIC_MEMORY_ATTRIBUTES to KVM_VM_MEMORY_ATTRIBUTES Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 03/41] KVM: Enumerate support for PRIVATE memory iff kvm_arch_has_private_mem is defined Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-30 9:57 ` Xiaoyao Li
2026-07-30 20:34 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 04/41] KVM: Rename memory attribute APIs to prepare for in-place gmem conversion Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-30 8:19 ` Xiaoyao Li
2026-07-29 0:35 ` [PATCH v9 05/41] KVM: Provide generic interface for checking memory private/shared status Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 06/41] KVM: guest_memfd: Introduce function to check GFN " Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 07/41] KVM: guest_memfd: Wire up core private/shared attribute interfaces Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-30 11:05 ` Xiaoyao Li
2026-07-30 20:42 ` Ackerley Tng
2026-07-30 23:49 ` Xiaoyao Li
2026-07-31 16:26 ` Sean Christopherson
2026-07-29 0:35 ` [PATCH v9 08/41] KVM: Consolidate private memory and guest_memfd ifdeffery in kvm_host.h Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 09/41] KVM: guest_memfd: Filter both shared and private when invalidating Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 10/41] KVM: guest_memfd: Add base support for KVM_SET_MEMORY_ATTRIBUTES2 Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-30 22:22 ` Ackerley Tng
2026-07-30 22:26 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 11/41] KVM: guest_memfd: Ensure pages are not in use before conversion Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 12/41] KVM: guest_memfd: Call arch make_shared callback for to-shared conversion Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-30 10:35 ` Fuad Tabba
2026-07-29 0:35 ` [PATCH v9 13/41] KVM: guest_memfd: Return early if range already has requested attributes Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-30 22:31 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 14/41] mm: swap: Introduce lru_add_drain_progressive() Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-30 10:21 ` David Hildenbrand (Arm)
2026-07-30 22:20 ` Ackerley Tng
2026-07-31 10:22 ` David Hildenbrand (Arm)
2026-07-31 11:59 ` David Hildenbrand (Arm)
2026-07-31 13:03 ` Ackerley Tng
2026-07-31 14:09 ` David Hildenbrand (Arm) [this message]
2026-07-31 21:04 ` David Hildenbrand (Arm)
2026-07-29 0:35 ` [PATCH v9 15/41] KVM: guest_memfd: Handle lru_add fbatch refcounts during conversion safety check Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 16/41] KVM: guest_memfd: Zero page while getting pfn Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-31 8:49 ` Xiaoyao Li
2026-07-29 0:35 ` [PATCH v9 17/41] KVM: SEV: Make 'uaddr' parameter optional for KVM_SEV_SNP_LAUNCH_UPDATE Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 18/41] KVM: TDX: Make source page optional for KVM_TDX_INIT_MEM_REGION Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-31 8:26 ` Xiaoyao Li
2026-07-31 16:11 ` Sean Christopherson
2026-07-29 0:35 ` [PATCH v9 19/41] KVM: Move KVM_VM_MEMORY_ATTRIBUTES config definition to x86 Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 20/41] KVM: Let userspace disable per-VM mem attributes, enable per-gmem attributes Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-31 8:48 ` Xiaoyao Li
2026-07-29 0:35 ` [PATCH v9 21/41] KVM: guest_memfd: Enable INIT_SHARED on guest_memfd for x86 Coco VMs Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 22/41] KVM: selftests: Create gmem fd before "regular" fd when adding memslot Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 23/41] KVM: selftests: Rename guest_memfd{,_offset} to gmem_{fd,offset} Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 24/41] KVM: selftests: Add support for mmap() on guest_memfd in core library Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 25/41] KVM: selftests: Add selftests global for guest memory attributes capability Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 26/41] KVM: selftests: Add helpers for calling ioctls on guest_memfd Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 27/41] KVM: selftests: Test basic single-page conversion flow Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 28/41] KVM: selftests: Test conversion flow when INIT_SHARED Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 29/41] KVM: selftests: Test conversion precision in guest_memfd Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 30/41] KVM: selftests: Test conversion before allocation Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 31/41] KVM: selftests: Convert with allocated folios in different layouts Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 32/41] KVM: selftests: Test that truncation does not change shared/private status Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 33/41] KVM: selftests: Test that shared/private status is consistent across processes Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 34/41] KVM: selftests: Add helpers to pin pages with CONFIG_GUP_TEST Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 35/41] KVM: selftests: Test conversion with elevated page refcount Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 36/41] KVM: selftests: Reset shared memory after hole-punching Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 37/41] KVM: selftests: Provide function to look up guest_memfd details from gpa Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 38/41] KVM: selftests: Provide common function to set memory attributes Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 39/41] KVM: selftests: Make TEST_EXPECT_SIGBUS thread-safe Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 40/41] KVM: selftests: Update private_mem_conversions_test to mmap() guest_memfd Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
2026-07-29 0:35 ` [PATCH v9 41/41] KVM: selftests: Update private memory exits test to work with per-gmem attributes Ackerley Tng via B4 Relay
2026-07-29 0:35 ` Ackerley Tng
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=60552bee-3326-4917-b00f-5fb7ba3b8adb@kernel.org \
--to=david@kernel.org \
--cc=ackerleytng@google.com \
--cc=aik@amd.com \
--cc=akpm@linux-foundation.org \
--cc=andrew.jones@linux.dev \
--cc=aneesh.kumar@kernel.org \
--cc=axelrasmussen@google.com \
--cc=baohua@kernel.org \
--cc=baoquan.he@linux.dev \
--cc=binbin.wu@linux.intel.com \
--cc=bp@alien8.de \
--cc=brauner@kernel.org \
--cc=chao.p.peng@linux.intel.com \
--cc=chrisl@kernel.org \
--cc=corbet@lwn.net \
--cc=dave.hansen@linux.intel.com \
--cc=forkloop@google.com \
--cc=hpa@zytor.com \
--cc=hughd@google.com \
--cc=jgg@ziepe.ca \
--cc=jhubbard@nvidia.com \
--cc=jmattson@google.com \
--cc=jthoughton@google.com \
--cc=kas@kernel.org \
--cc=kasong@tencent.com \
--cc=kvm@vger.kernel.org \
--cc=liam@infradead.org \
--cc=linux-coco@lists.linux.dev \
--cc=linux-doc@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-kselftest@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=linux-trace-kernel@vger.kernel.org \
--cc=mathieu.desnoyers@efficios.com \
--cc=mhiramat@kernel.org \
--cc=michael.roth@amd.com \
--cc=mingo@redhat.com \
--cc=nphamcs@gmail.com \
--cc=oupton@kernel.org \
--cc=pankaj.gupta@amd.com \
--cc=pbonzini@redhat.com \
--cc=peterx@redhat.com \
--cc=pratyush@kernel.org \
--cc=qi.zheng@linux.dev \
--cc=qperret@google.com \
--cc=rick.p.edgecombe@intel.com \
--cc=rientjes@google.com \
--cc=rostedt@goodmis.org \
--cc=seanjc@google.com \
--cc=shakeel.butt@linux.dev \
--cc=shikemeng@huaweicloud.com \
--cc=shivankg@amd.com \
--cc=shuah@kernel.org \
--cc=skhan@linuxfoundation.org \
--cc=steven.price@arm.com \
--cc=suzuki.poulose@arm.com \
--cc=tabba@google.com \
--cc=tglx@kernel.org \
--cc=vannapurve@google.com \
--cc=vbabka@kernel.org \
--cc=weixugc@google.com \
--cc=willy@infradead.org \
--cc=wyihan@google.com \
--cc=x86@kernel.org \
--cc=yan.y.zhao@intel.com \
--cc=youngjun.park@lge.com \
--cc=yuanchu@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.