From: Dave Hansen <dave.hansen@intel.com>
To: Maxim Levitsky <mlevitsk@redhat.com>, linux-kernel@vger.kernel.org
Cc: "Chang S. Bae" <chang.seok.bae@intel.com>,
Jiri Olsa <jolsa@kernel.org>,
linux-perf-users@vger.kernel.org,
Peter Zijlstra <peterz@infradead.org>,
"H. Peter Anvin" <hpa@zytor.com>,
"David S. Miller" <davem@davemloft.net>,
Borislav Petkov <bp@alien8.de>, Kees Cook <keescook@chromium.org>,
Mark Rutland <mark.rutland@arm.com>,
Alexander Shishkin <alexander.shishkin@linux.intel.com>,
Namhyung Kim <namhyung@kernel.org>,
Tim Chen <tim.c.chen@linux.intel.com>,
Pawan Gupta <pawan.kumar.gupta@linux.intel.com>,
Herbert Xu <herbert@gondor.apana.org.au>,
Dave Hansen <dave.hansen@linux.intel.com>,
"maintainer:X86 ARCHITECTURE (32-BIT AND 64-BIT)"
<x86@kernel.org>, Jane Malalane <jane.malalane@citrix.com>,
Tony Luck <tony.luck@intel.com>, Ingo Molnar <mingo@redhat.com>,
Thomas Gleixner <tglx@linutronix.de>,
Arnaldo Carvalho de Melo <acme@kernel.org>,
"open list:CRYPTO API" <linux-crypto@vger.kernel.org>,
Paolo Bonzini <pbonzini@redhat.com>
Subject: Re: [PATCH 3/4] x86/cpuid: move filter_cpuid_features to cpuid-deps.c
Date: Wed, 22 Jun 2022 08:07:46 -0700 [thread overview]
Message-ID: <6f83722d-d402-ca68-7d3e-77dca14a794b@intel.com> (raw)
In-Reply-To: <20220622144820.751402-4-mlevitsk@redhat.com>
On 6/22/22 07:48, Maxim Levitsky wrote:
> No functional change intended.
It would be really nice to at least write a "why" sentence. You wrote
the "what" (move code), but I have no idea why you are moving it.
> arch/x86/kernel/cpu/common.c | 46 -----------------------------
> arch/x86/kernel/cpu/cpuid-deps.c | 48 +++++++++++++++++++++++++++++++
That looks a wee bit odd for a code move. Where did the 2 lines go?
> diff --git a/arch/x86/include/asm/cpufeature.h b/arch/x86/include/asm/cpufeature.h
> index ea34cc31b0474f..3eb5fe0d654e63 100644
> --- a/arch/x86/include/asm/cpufeature.h
> +++ b/arch/x86/include/asm/cpufeature.h
> @@ -147,6 +147,7 @@ extern const char * const x86_bug_flags[NBUGINTS*32];
>
> extern void setup_clear_cpu_cap(unsigned int bit);
> extern void clear_cpu_cap(struct cpuinfo_x86 *c, unsigned int bit);
> +extern void filter_cpuid_features(struct cpuinfo_x86 *c, bool warn);
>
> #define setup_force_cpu_cap(bit) do { \
> set_cpu_cap(&boot_cpu_data, bit); \
> diff --git a/arch/x86/kernel/cpu/common.c b/arch/x86/kernel/cpu/common.c
> index 4730b0a58f24a5..4cc79971d2d847 100644
> --- a/arch/x86/kernel/cpu/common.c
> +++ b/arch/x86/kernel/cpu/common.c
> @@ -620,52 +620,6 @@ __noendbr void cet_disable(void)
> wrmsrl(MSR_IA32_S_CET, 0);
> }
>
> -/*
...
> -}
>
> /*
> * Naming convention should be: <Name> [(<Codename>)]
One, by leaving extra whitespace.
> diff --git a/arch/x86/kernel/cpu/cpuid-deps.c b/arch/x86/kernel/cpu/cpuid-deps.c
> index d6777d07ba3302..bcb091d02a754b 100644
> --- a/arch/x86/kernel/cpu/cpuid-deps.c
> +++ b/arch/x86/kernel/cpu/cpuid-deps.c
> @@ -131,3 +131,51 @@ void setup_clear_cpu_cap(unsigned int feature)
> {
> clear_cpu_cap(&boot_cpu_data, feature);
> }
> +
> +
> +/*
Two, by adding extra whitespace.
next prev parent reply other threads:[~2022-06-22 15:09 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-06-22 14:48 [PATCH 0/4] x86: cpuid: improve support for broken CPUID configurations Maxim Levitsky
2022-06-22 14:48 ` [PATCH 1/4] perf/x86/intel/lbr: use setup_clear_cpu_cap instead of clear_cpu_cap Maxim Levitsky
2022-06-22 14:58 ` Dave Hansen
2022-06-22 18:57 ` Liang, Kan
2022-06-22 19:32 ` Liang, Kan
2022-06-22 14:48 ` [PATCH 2/4] x86/cpuid: refactor setup_clear_cpu_cap/clear_feature Maxim Levitsky
2022-06-22 15:07 ` Dave Hansen
2022-06-22 15:59 ` Maxim Levitsky
2022-06-22 14:48 ` [PATCH 3/4] x86/cpuid: move filter_cpuid_features to cpuid-deps.c Maxim Levitsky
2022-06-22 15:07 ` Dave Hansen [this message]
2022-06-22 16:01 ` Maxim Levitsky
2022-06-22 14:48 ` [PATCH 4/4] x86/cpuid: check for dependencies violations in CPUID and attempt to fix them Maxim Levitsky
2022-06-22 15:32 ` Dave Hansen
2022-06-22 17:09 ` Maxim Levitsky
2022-06-22 17:18 ` Dave Hansen
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=6f83722d-d402-ca68-7d3e-77dca14a794b@intel.com \
--to=dave.hansen@intel.com \
--cc=acme@kernel.org \
--cc=alexander.shishkin@linux.intel.com \
--cc=bp@alien8.de \
--cc=chang.seok.bae@intel.com \
--cc=dave.hansen@linux.intel.com \
--cc=davem@davemloft.net \
--cc=herbert@gondor.apana.org.au \
--cc=hpa@zytor.com \
--cc=jane.malalane@citrix.com \
--cc=jolsa@kernel.org \
--cc=keescook@chromium.org \
--cc=linux-crypto@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-perf-users@vger.kernel.org \
--cc=mark.rutland@arm.com \
--cc=mingo@redhat.com \
--cc=mlevitsk@redhat.com \
--cc=namhyung@kernel.org \
--cc=pawan.kumar.gupta@linux.intel.com \
--cc=pbonzini@redhat.com \
--cc=peterz@infradead.org \
--cc=tglx@linutronix.de \
--cc=tim.c.chen@linux.intel.com \
--cc=tony.luck@intel.com \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.