From: Zijun Hu <zijun_hu@icloud.com>
To: "Uwe Kleine-König" <ukleinek@kernel.org>
Cc: "Greg Kroah-Hartman" <gregkh@linuxfoundation.org>,
"James Bottomley" <James.Bottomley@hansenpartnership.com>,
"Thomas Weißschuh" <thomas@t-8ch.de>,
linux-kernel@vger.kernel.org, nvdimm@lists.linux.dev,
linux-sound@vger.kernel.org, sparclinux@vger.kernel.org,
linux-block@vger.kernel.org, linux-cxl@vger.kernel.org,
linux1394-devel@lists.sourceforge.net, arm-scmi@vger.kernel.org,
linux-efi@vger.kernel.org, linux-gpio@vger.kernel.org,
dri-devel@lists.freedesktop.org,
linux-mediatek@lists.infradead.org, linux-hwmon@vger.kernel.org,
linux-media@vger.kernel.org, linux-pwm@vger.kernel.org,
linux-remoteproc@vger.kernel.org, linux-scsi@vger.kernel.org,
open-iscsi@googlegroups.com, linux-usb@vger.kernel.org,
linux-serial@vger.kernel.org, netdev@vger.kernel.org,
"Zijun Hu" <quic_zijuhu@quicinc.com>
Subject: Re: [PATCH v3 04/11] driver core: Constify API device_find_child() then adapt for various usages
Date: Fri, 6 Dec 2024 19:08:37 +0800 [thread overview]
Message-ID: <71d9c99f-aa7d-4697-8561-17b54cfe97c6@icloud.com> (raw)
In-Reply-To: <7ylfj462lf6g3ej6d2cmsxadawsmajogbimi7cl4pjemb7df4h@snr73pd7vaid>
On 2024/12/6 15:21, Uwe Kleine-König wrote:
> Hello,
>
> On Thu, Dec 05, 2024 at 08:10:13AM +0800, Zijun Hu wrote:
>> From: Zijun Hu <quic_zijuhu@quicinc.com>
>>
>> Constify the following API:
>> struct device *device_find_child(struct device *dev, void *data,
>> int (*match)(struct device *dev, void *data));
>> To :
>> struct device *device_find_child(struct device *dev, const void *data,
>> device_match_t match);
>> typedef int (*device_match_t)(struct device *dev, const void *data);
>> with the following reasons:
>>
>> - Protect caller's match data @*data which is for comparison and lookup
>> and the API does not actually need to modify @*data.
>>
>> - Make the API's parameters (@match)() and @data have the same type as
>> all of other device finding APIs (bus|class|driver)_find_device().
>>
>> - All kinds of existing device match functions can be directly taken
>> as the API's argument, they were exported by driver core.
>>
>> Constify the API and adapt for various existing usages by simply making
>> various match functions take 'const void *' as type of match data @data.
>
> With the discussion that a new name would ease the conversion, maybe
> consider device_find_child_device() to also align the name (somewhat) to
> the above mentioned (bus|class|driver)_find_device()?
> i finally select this squashing method after considerations as shown by
link below:
https://lore.kernel.org/all/3a4de1bb-3eb2-469a-8ff7-ff706804f5bb@icloud.com
device_find_child() is consist with existing device_find_child_by_name()
and device_find_any_child, device's child is also a device, so we may
not need the tail _device().
> Do you have a merge plan already? I guess this patch will go through
> Greg's driver core tree?
>
this patch series is already squashing solution.
yes. hope it move toward mainline by Greg's driver core tree.
(^^)(^^)
> Best regards
> Uwe
next prev parent reply other threads:[~2024-12-06 11:08 UTC|newest]
Thread overview: 30+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-12-05 0:10 [PATCH v3 00/11] driver core: Constify API device_find_child() Zijun Hu
2024-12-05 0:10 ` [PATCH v3 01/11] libnvdimm: Simplify nd_namespace_store() implementation Zijun Hu
2024-12-05 23:30 ` Alison Schofield
2024-12-06 0:56 ` Zijun Hu
2024-12-05 0:10 ` [PATCH v3 02/11] slimbus: core: Constify slim_eaddr_equal() Zijun Hu
2024-12-05 0:10 ` [PATCH v3 03/11] bus: fsl-mc: Constify fsl_mc_device_match() Zijun Hu
2024-12-05 0:10 ` [PATCH v3 04/11] driver core: Constify API device_find_child() then adapt for various usages Zijun Hu
2024-12-05 10:41 ` Uwe Kleine-König
2024-12-05 13:16 ` Zijun Hu
2024-12-05 22:39 ` Alison Schofield
2024-12-06 7:21 ` Uwe Kleine-König
2024-12-06 11:08 ` Zijun Hu [this message]
2024-12-06 13:52 ` Takashi Sakamoto
2024-12-08 13:18 ` Zijun Hu
2024-12-05 0:10 ` [PATCH v3 05/11] driver core: Simplify API device_find_child_by_name() implementation Zijun Hu
2024-12-05 0:10 ` [PATCH v3 06/11] driver core: Remove match_any() Zijun Hu
2024-12-05 0:10 ` [PATCH v3 07/11] slimbus: core: Simplify of_find_slim_device() implementation Zijun Hu
2024-12-05 0:10 ` [PATCH v3 08/11] gpio: sim: Remove gpio_sim_dev_match_fwnode() Zijun Hu
2024-12-05 8:10 ` Uwe Kleine-König
2024-12-05 8:37 ` quic_zijuhu
2024-12-05 10:37 ` Uwe Kleine-König
2024-12-05 13:19 ` Zijun Hu
2024-12-05 16:24 ` Bartosz Golaszewski
2024-12-06 1:00 ` Zijun Hu
2024-12-05 0:10 ` [PATCH v3 09/11] driver core: Introduce an device matching API device_match_type() Zijun Hu
2024-12-05 0:10 ` [PATCH v3 10/11] cxl/pmem: Remove match_nvdimm_bridge() Zijun Hu
2024-12-05 22:49 ` Alison Schofield
2024-12-06 1:02 ` Zijun Hu
2024-12-05 0:10 ` [PATCH v3 11/11] usb: typec: class: Remove both cable_match() and partner_match() Zijun Hu
2024-12-05 0:31 ` [PATCH v3 00/11] driver core: Constify API device_find_child() Zijun Hu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=71d9c99f-aa7d-4697-8561-17b54cfe97c6@icloud.com \
--to=zijun_hu@icloud.com \
--cc=James.Bottomley@hansenpartnership.com \
--cc=arm-scmi@vger.kernel.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-block@vger.kernel.org \
--cc=linux-cxl@vger.kernel.org \
--cc=linux-efi@vger.kernel.org \
--cc=linux-gpio@vger.kernel.org \
--cc=linux-hwmon@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=linux-mediatek@lists.infradead.org \
--cc=linux-pwm@vger.kernel.org \
--cc=linux-remoteproc@vger.kernel.org \
--cc=linux-scsi@vger.kernel.org \
--cc=linux-serial@vger.kernel.org \
--cc=linux-sound@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=linux1394-devel@lists.sourceforge.net \
--cc=netdev@vger.kernel.org \
--cc=nvdimm@lists.linux.dev \
--cc=open-iscsi@googlegroups.com \
--cc=quic_zijuhu@quicinc.com \
--cc=sparclinux@vger.kernel.org \
--cc=thomas@t-8ch.de \
--cc=ukleinek@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.