From: John Garry <john.garry@linux.dev>
To: Bart Van Assche <bvanassche@acm.org>,
John Garry <john.g.garry@oracle.com>,
"Martin K . Petersen" <martin.petersen@oracle.com>
Cc: linux-scsi@vger.kernel.org,
"James E.J. Bottomley" <James.Bottomley@HansenPartnership.com>,
"Martin K. Petersen" <mkp@kernel.org>
Subject: Re: [PATCH v2] scsi: core: Rework the DEF_SCSI_QCMD() implementation
Date: Wed, 2 Sep 2026 09:21:56 +0100 [thread overview]
Message-ID: <7687de74-0543-4729-9427-e1cafd4eb105@linux.dev> (raw)
In-Reply-To: <fc05556d-e81f-4039-b62a-d8327bcf6d5b@acm.org>
On 9/1/26 19:17, Bart Van Assche wrote:
> On 9/1/26 1:04 AM, John Garry wrote:
>> On 31/08/2026 23:19, Bart Van Assche wrote:
>>> In DEF_SCSI_QCMD(), make the following changes:
>>> - Assign cmd->device->host to shost because func_name##_lck()
>>> implementations will be annotated with
>>> __must_hold(&cmd->device->host->host_lock). This change prepares
>>> for
>>
>> Why not annotate with __must_hold(&host->host_lock)? That is what we
>> do in scsi_host_set_state().
>
> Because the host pointer is not in the argument list of functions like
> blogic_qcmd_lck().
Yes, silly me.
> Do you perhaps want me to pass the SCSI host pointer
> as an argument to blogic_qcmd_lck()? This could be done by open-coding
> DEF_SCSI_QCMD() in the BusLogic driver.
How would that look? All users of DEF_SCSI_QCMD would need a similar
change, right?
prev parent reply other threads:[~2026-09-02 8:22 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-31 22:19 [PATCH v2] scsi: core: Rework the DEF_SCSI_QCMD() implementation Bart Van Assche
2026-09-01 8:04 ` John Garry
2026-09-01 18:17 ` Bart Van Assche
2026-09-02 8:21 ` John Garry [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=7687de74-0543-4729-9427-e1cafd4eb105@linux.dev \
--to=john.garry@linux.dev \
--cc=James.Bottomley@HansenPartnership.com \
--cc=bvanassche@acm.org \
--cc=john.g.garry@oracle.com \
--cc=linux-scsi@vger.kernel.org \
--cc=martin.petersen@oracle.com \
--cc=mkp@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.