From: Luka Gejak <luka.gejak@linux.dev>
To: Ping-Ke Shih <pkshih@realtek.com>,
"linux-wireless@vger.kernel.org" <linux-wireless@vger.kernel.org>
Cc: "linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
Michael Straube <straube.linux@gmail.com>,
Bitterblue Smith <rtl8821cerfe2@gmail.com>,
Peter Robinson <pbrobinson@gmail.com>,
Hans de Goede <johannes.goede@oss.qualcomm.com>,
luka.gejak@linux.dev
Subject: RE: [PATCH v8 4/6] wifi: rtw88: sdio: track free TX pages and OQT credits for RTL8723BS
Date: Fri, 28 Aug 2026 11:40:04 +0200 [thread overview]
Message-ID: <78117767-9F3F-4A53-A1C0-02B22ED32C52@linux.dev> (raw)
In-Reply-To: <068b8747563444869e19399fbfa78654@realtek.com>
Hi Ping-Ke,
On August 28, 2026 11:23:26 AM GMT+02:00, Ping-Ke Shih <pkshih@realtek.com> wrote:
> Since you have two branches for RTL8723BS and others, let's implement
> them by individual functions. Here can just dispatch, like
Will do in v9.
Two details I would rather ask about than decide on my own, since both
touch the other SDIO parts rather than this chip.
The unaligned SKB warning uses __func__, and today that resolves to
rtw_sdio_write_port on every chip. Once the generic path moves into its
own function the string becomes that function's name for 8703b, 8723d,
8821c, 8822b and 8822c. Nothing reads it, but it is still a visible
change to parts this series is not about. The options I see are to let
it change and say so in the change log, to drop __func__ and word the
message without a function name, or to keep the check in the dispatcher
so the string stays as it is.
I would take the first, since the name then simply follows whichever
function ran. The third is the only one that leaves the other parts
completely alone, but it would move the warning ahead of
rtw_sdio_check_free_txpg() on the generic path, so a page shortage would
start logging a line it does not log today. That seems worse than the
string changing. Say if you would rather have it either of the other
ways.
> rtw_sdio_write_port_8723bs()
The chip specific helpers already use the _8723bs_ prefix, which is the
convention you asked for in v4, so I plan to keep
rtw_sdio_8723bs_write_port() and add rtw_sdio_write_port_common()
next to it. Happy to rename them to match your sketch if you would
rather they read that way.
Best regards,
Luka Gejak
next prev parent reply other threads:[~2026-08-28 9:42 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-25 16:33 [PATCH v8 0/6] wifi: rtw88: preparations for RTL8723B/RTL8723BS luka.gejak
2026-08-25 16:33 ` [PATCH v8 1/6] wifi: rtw88: add the RTL8723B chip type and SDIO helper luka.gejak
2026-08-25 16:33 ` [PATCH v8 2/6] wifi: rtw88: rx: mark zero length packets on RTL8723BS luka.gejak
2026-08-25 16:33 ` [PATCH v8 3/6] wifi: rtw88: tx: extend the TX report purge timeout to RTL8723BS luka.gejak
2026-08-25 16:33 ` [PATCH v8 4/6] wifi: rtw88: sdio: track free TX pages and OQT credits for RTL8723BS luka.gejak
2026-08-28 9:23 ` Ping-Ke Shih
2026-08-28 9:40 ` Luka Gejak [this message]
2026-08-25 16:33 ` [PATCH v8 5/6] wifi: rtw88: sdio: set up RX aggregation and interrupts " luka.gejak
2026-08-25 16:33 ` [PATCH v8 6/6] wifi: rtw88: sdio: add TX back-pressure and retry on page starvation luka.gejak
2026-08-28 9:29 ` Ping-Ke Shih
2026-08-28 9:47 ` Luka Gejak
2026-08-26 17:53 ` [PATCH v8 0/6] wifi: rtw88: preparations for RTL8723B/RTL8723BS Luka Gejak
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=78117767-9F3F-4A53-A1C0-02B22ED32C52@linux.dev \
--to=luka.gejak@linux.dev \
--cc=johannes.goede@oss.qualcomm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-wireless@vger.kernel.org \
--cc=pbrobinson@gmail.com \
--cc=pkshih@realtek.com \
--cc=rtl8821cerfe2@gmail.com \
--cc=straube.linux@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.