From: Junio C Hamano <junkio@cox.net>
To: "Alex Riesen" <raa.lkml@gmail.com>
Cc: "Junio C Hamano" <junkio@cox.net>,
"Johannes Schindelin" <Johannes.Schindelin@gmx.de>,
git@vger.kernel.org
Subject: Re: [PATCH] Allow git-diff exit with codes similar to diff(1)
Date: Wed, 14 Mar 2007 10:06:53 -0700 [thread overview]
Message-ID: <7vodmvah5e.fsf@assigned-by-dhcp.cox.net> (raw)
In-Reply-To: <81b0412b0703140933v5c684aa9g1f61d61e502c6783@mail.gmail.com> (Alex Riesen's message of "Wed, 14 Mar 2007 17:33:21 +0100")
"Alex Riesen" <raa.lkml@gmail.com> writes:
> On 3/14/07, Junio C Hamano <junkio@cox.net> wrote:
>> > - return run_diff_files_cmd(&rev, argc, argv);
>> > + result = run_diff_files_cmd(&rev, argc, argv);
>> > + return rev.diffopt.diff_exit_code ? rev.diffopt.exit_code: result;
>> > }
>>
>> Yuck. Let's call the former "exit_with_status" (meaning, the
>> caller instructed us to do that) and the latter "has_changes".
>
> I like "exit_with_status". But has_changes looks confusing
> good near return value of run_diff_files_cmd, which "has"
> nothing. Or do you mean to highlight this "difference"?
Maybe 'found_changes' would be a better name, then?
if (exit_with_status)
return !!found_changes;
else
return result;
next prev parent reply other threads:[~2007-03-14 17:06 UTC|newest]
Thread overview: 32+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-03-14 0:17 [PATCH] Allow git-diff exit with codes similar to diff(1) Alex Riesen
2007-03-14 1:03 ` Johannes Schindelin
2007-03-14 1:20 ` Linus Torvalds
2007-03-14 1:23 ` Junio C Hamano
2007-03-14 1:13 ` Linus Torvalds
2007-03-14 1:18 ` Johannes Schindelin
2007-03-14 1:34 ` Linus Torvalds
2007-03-14 1:38 ` Johannes Schindelin
2007-03-14 8:37 ` Alex Riesen
2007-03-14 12:05 ` Johannes Schindelin
2007-03-14 12:26 ` Alex Riesen
2007-03-14 12:31 ` Johannes Schindelin
2007-03-15 12:49 ` Simon 'corecode' Schubert
2007-03-15 13:56 ` Alex Riesen
2007-03-14 1:31 ` Junio C Hamano
2007-03-14 8:19 ` Alex Riesen
2007-03-14 8:58 ` Junio C Hamano
2007-03-14 9:06 ` Junio C Hamano
2007-03-14 9:07 ` Alex Riesen
2007-03-14 9:36 ` Junio C Hamano
2007-03-14 9:46 ` Alex Riesen
2007-03-14 4:56 ` Junio C Hamano
2007-03-14 8:28 ` Alex Riesen
2007-03-14 9:04 ` Junio C Hamano
2007-03-14 14:01 ` Alex Riesen
2007-03-14 16:14 ` Junio C Hamano
2007-03-14 16:33 ` Alex Riesen
2007-03-14 16:37 ` Junio C Hamano
2007-03-14 17:12 ` Alex Riesen
2007-03-14 17:20 ` Junio C Hamano
2007-03-14 17:06 ` Junio C Hamano [this message]
2007-03-14 17:15 ` Alex Riesen
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=7vodmvah5e.fsf@assigned-by-dhcp.cox.net \
--to=junkio@cox.net \
--cc=Johannes.Schindelin@gmx.de \
--cc=git@vger.kernel.org \
--cc=raa.lkml@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.