From: Trond Myklebust <trondmy@kernel.org>
To: David Wysochanski <dwysocha@redhat.com>
Cc: Anna Schumaker <anna.schumaker@netapp.com>,
Trond Myklebust <trond.myklebust@hammerspace.com>,
David Howells <dhowells@redhat.com>,
linux-nfs@vger.kernel.org, linux-cachefs@redhat.com,
Benjamin Maynard <benmaynard@google.com>,
Daire Byrne <daire.byrne@gmail.com>
Subject: Re: [PATCH v9 1/5] NFS: Rename readpage_async_filler to nfs_pageio_add_page
Date: Fri, 28 Oct 2022 13:14:17 -0400 [thread overview]
Message-ID: <8675d583b7d3d2832f7c52da01e4b171e8f5ba46.camel@kernel.org> (raw)
In-Reply-To: <CALF+zOkC4F-g5sW1-v5eyyFph_JuSuSrLMbQ-3Uk71_QN2d75Q@mail.gmail.com>
On Fri, 2022-10-28 at 06:32 -0400, David Wysochanski wrote:
> On Thu, Oct 27, 2022 at 2:07 PM Trond Myklebust <trondmy@kernel.org>
> wrote:
> >
> > On Mon, 2022-10-17 at 06:52 -0400, Dave Wysochanski wrote:
> > > Rename readpage_async_filler to nfs_pageio_add_page to
> > > better reflect what this function does (add a page to
> > > the nfs_pageio_descriptor), and simplify arguments to
> > > this function by removing struct nfs_readdesc.
> > >
> > > Signed-off-by: Dave Wysochanski <dwysocha@redhat.com>
> > > Reviewed-by: Jeff Layton <jlayton@kernel.org>
> > > ---
> > > fs/nfs/read.c | 60 +++++++++++++++++++++++++--------------------
> > > ----
> > > --
> > > 1 file changed, 30 insertions(+), 30 deletions(-)
> > >
> > > diff --git a/fs/nfs/read.c b/fs/nfs/read.c
> > > index 8ae2c8d1219d..525e82ea9a9e 100644
> > > --- a/fs/nfs/read.c
> > > +++ b/fs/nfs/read.c
> > > @@ -127,11 +127,6 @@ static void nfs_readpage_release(struct
> > > nfs_page
> > > *req, int error)
> > > nfs_release_request(req);
> > > }
> > >
> > > -struct nfs_readdesc {
> > > - struct nfs_pageio_descriptor pgio;
> > > - struct nfs_open_context *ctx;
> > > -};
> > > -
> > > static void nfs_page_group_set_uptodate(struct nfs_page *req)
> > > {
> > > if (nfs_page_group_sync_on_bit(req, PG_UPTODATE))
> > > @@ -153,7 +148,8 @@ static void nfs_read_completion(struct
> > > nfs_pgio_header *hdr)
> > >
> > > if (test_bit(NFS_IOHDR_EOF, &hdr->flags)) {
> > > /* note: regions of the page not covered
> > > by a
> > > - * request are zeroed in
> > > readpage_async_filler */
> > > + * request are zeroed in
> > > nfs_pageio_add_page
> > > + */
> > > if (bytes > hdr->good_bytes) {
> > > /* nothing in this request was
> > > good,
> > > so zero
> > > * the full extent of the request
> > > */
> > > @@ -281,8 +277,10 @@ static void nfs_readpage_result(struct
> > > rpc_task
> > > *task,
> > > nfs_readpage_retry(task, hdr);
> > > }
> > >
> > > -static int
> > > -readpage_async_filler(struct nfs_readdesc *desc, struct page
> > > *page)
> > > +int
> > > +nfs_pageio_add_page(struct nfs_pageio_descriptor *pgio,
> > > + struct nfs_open_context *ctx,
> > > + struct page *page)
> >
> > If we're going to rename this function, then let's not give it a
> > name
> > that suggests it belongs in pagelist.c. It's not a generic helper
> > function, but is still very much specific to the pagecache read
> > functionality.
> >
>
> How about nfs_read_add_page()?
>
>
That's better.
--
Trond Myklebust
Linux NFS client maintainer, Hammerspace
trond.myklebust@hammerspace.com
next prev parent reply other threads:[~2022-10-28 17:14 UTC|newest]
Thread overview: 31+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-10-17 10:52 [PATCH v9 0/5] Convert NFS with fscache to the netfs API Dave Wysochanski
2022-10-17 10:52 ` [PATCH v9 1/5] NFS: Rename readpage_async_filler to nfs_pageio_add_page Dave Wysochanski
2022-10-27 18:07 ` Trond Myklebust
2022-10-28 10:32 ` David Wysochanski
2022-10-28 17:14 ` Trond Myklebust [this message]
2022-10-17 10:52 ` [PATCH v9 2/5] NFS: Configure support for netfs when NFS fscache is configured Dave Wysochanski
2022-10-17 10:52 ` [PATCH v9 3/5] NFS: Convert buffered read paths to use netfs when fscache is enabled Dave Wysochanski
2022-10-27 19:16 ` Trond Myklebust
2022-10-28 11:50 ` David Wysochanski
2022-10-28 16:59 ` Trond Myklebust
2022-10-29 16:46 ` David Wysochanski
2022-10-30 23:25 ` David Wysochanski
2022-10-31 17:42 ` Benjamin Maynard
[not found] ` <1B2E1442-EB0A-43E3-96BB-15C717E966E5@hammerspace.com>
2022-11-12 12:46 ` Benjamin Maynard
2022-11-14 10:41 ` David Wysochanski
2022-11-14 12:42 ` Benjamin Maynard
2022-11-14 13:07 ` Jeff Layton
2022-11-14 13:14 ` Benjamin Maynard
2022-11-14 13:53 ` Jeff Layton
2022-11-14 13:33 ` Daire Byrne
2022-11-14 13:46 ` David Wysochanski
2022-11-14 16:03 ` Benjamin Maynard
2022-11-14 17:11 ` Jeff Layton
2022-11-14 17:34 ` David Wysochanski
2022-11-14 21:25 ` Benjamin Maynard
2022-11-17 11:03 ` Daire Byrne
2023-01-03 20:33 ` Benjamin Maynard
2023-02-06 17:32 ` Benjamin Maynard
2023-02-09 15:09 ` David Wysochanski
2022-10-17 10:52 ` [PATCH v9 4/5] NFS: Remove all NFSIOS_FSCACHE counters due to conversion to netfs API Dave Wysochanski
2022-10-17 10:52 ` [PATCH v9 5/5] NFS: Remove fscache specific trace points and NFS_INO_FSCACHE bit Dave Wysochanski
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=8675d583b7d3d2832f7c52da01e4b171e8f5ba46.camel@kernel.org \
--to=trondmy@kernel.org \
--cc=anna.schumaker@netapp.com \
--cc=benmaynard@google.com \
--cc=daire.byrne@gmail.com \
--cc=dhowells@redhat.com \
--cc=dwysocha@redhat.com \
--cc=linux-cachefs@redhat.com \
--cc=linux-nfs@vger.kernel.org \
--cc=trond.myklebust@hammerspace.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.