From: Jani Nikula <jani.nikula@intel.com>
To: Suraj Kandpal <suraj.kandpal@intel.com>,
intel-xe@lists.freedesktop.org, intel-gfx@lists.freedesktop.org
Cc: ankit.k.nautiyal@intel.com, uma.shankar@intel.com,
mika.kahola@intel.com, ville.syrjala@intel.com,
Suraj Kandpal <suraj.kandpal@intel.com>
Subject: Re: [PATCH 03/16] drm/i915/dpll: Rename intel_shared_dpll_funcs
Date: Thu, 03 Apr 2025 17:59:05 +0300 [thread overview]
Message-ID: <87bjtd1ebq.fsf@intel.com> (raw)
In-Reply-To: <20250402083204.1523470-4-suraj.kandpal@intel.com>
On Wed, 02 Apr 2025, Suraj Kandpal <suraj.kandpal@intel.com> wrote:
> Rename intel_shared_dpll_funcs to intel_global_dpll_funcs
> since it needs to represent both shared and individual
> dplls.
>
> --v2
> -Change intel_global_dpll to intel_dpll_global to be more
> in line with the naming standard where the name should
> start with the file name [Jani]
Though I'm not sure what we need the "global" for. Just
intel_dpll_funcs?
>
> Signed-off-by: Suraj Kandpal <suraj.kandpal@intel.com>
> ---
> drivers/gpu/drm/i915/display/intel_dpll_mgr.c | 24 +++++++++----------
> drivers/gpu/drm/i915/display/intel_dpll_mgr.h | 4 ++--
> 2 files changed, 14 insertions(+), 14 deletions(-)
>
> diff --git a/drivers/gpu/drm/i915/display/intel_dpll_mgr.c b/drivers/gpu/drm/i915/display/intel_dpll_mgr.c
> index bbb51119ef5b..92ca2a544e2f 100644
> --- a/drivers/gpu/drm/i915/display/intel_dpll_mgr.c
> +++ b/drivers/gpu/drm/i915/display/intel_dpll_mgr.c
> @@ -61,7 +61,7 @@
> */
>
> /* platform specific hooks for managing DPLLs */
> -struct intel_shared_dpll_funcs {
> +struct intel_dpll_global_funcs {
> /*
> * Hook for enabling the pll, called from intel_enable_shared_dpll() if
> * the pll is not already enabled.
> @@ -668,7 +668,7 @@ static bool ibx_compare_hw_state(const struct intel_dpll_hw_state *_a,
> a->fp1 == b->fp1;
> }
>
> -static const struct intel_shared_dpll_funcs ibx_pch_dpll_funcs = {
> +static const struct intel_dpll_global_funcs ibx_pch_dpll_funcs = {
> .enable = ibx_pch_dpll_enable,
> .disable = ibx_pch_dpll_disable,
> .get_hw_state = ibx_pch_dpll_get_hw_state,
> @@ -1268,14 +1268,14 @@ static bool hsw_compare_hw_state(const struct intel_dpll_hw_state *_a,
> a->spll == b->spll;
> }
>
> -static const struct intel_shared_dpll_funcs hsw_ddi_wrpll_funcs = {
> +static const struct intel_dpll_global_funcs hsw_ddi_wrpll_funcs = {
> .enable = hsw_ddi_wrpll_enable,
> .disable = hsw_ddi_wrpll_disable,
> .get_hw_state = hsw_ddi_wrpll_get_hw_state,
> .get_freq = hsw_ddi_wrpll_get_freq,
> };
>
> -static const struct intel_shared_dpll_funcs hsw_ddi_spll_funcs = {
> +static const struct intel_dpll_global_funcs hsw_ddi_spll_funcs = {
> .enable = hsw_ddi_spll_enable,
> .disable = hsw_ddi_spll_disable,
> .get_hw_state = hsw_ddi_spll_get_hw_state,
> @@ -1300,7 +1300,7 @@ static bool hsw_ddi_lcpll_get_hw_state(struct intel_display *display,
> return true;
> }
>
> -static const struct intel_shared_dpll_funcs hsw_ddi_lcpll_funcs = {
> +static const struct intel_dpll_global_funcs hsw_ddi_lcpll_funcs = {
> .enable = hsw_ddi_lcpll_enable,
> .disable = hsw_ddi_lcpll_disable,
> .get_hw_state = hsw_ddi_lcpll_get_hw_state,
> @@ -2002,14 +2002,14 @@ static bool skl_compare_hw_state(const struct intel_dpll_hw_state *_a,
> a->cfgcr2 == b->cfgcr2;
> }
>
> -static const struct intel_shared_dpll_funcs skl_ddi_pll_funcs = {
> +static const struct intel_dpll_global_funcs skl_ddi_pll_funcs = {
> .enable = skl_ddi_pll_enable,
> .disable = skl_ddi_pll_disable,
> .get_hw_state = skl_ddi_pll_get_hw_state,
> .get_freq = skl_ddi_pll_get_freq,
> };
>
> -static const struct intel_shared_dpll_funcs skl_ddi_dpll0_funcs = {
> +static const struct intel_dpll_global_funcs skl_ddi_dpll0_funcs = {
> .enable = skl_ddi_dpll0_enable,
> .disable = skl_ddi_dpll0_disable,
> .get_hw_state = skl_ddi_dpll0_get_hw_state,
> @@ -2484,7 +2484,7 @@ static bool bxt_compare_hw_state(const struct intel_dpll_hw_state *_a,
> a->pcsdw12 == b->pcsdw12;
> }
>
> -static const struct intel_shared_dpll_funcs bxt_ddi_pll_funcs = {
> +static const struct intel_dpll_global_funcs bxt_ddi_pll_funcs = {
> .enable = bxt_ddi_pll_enable,
> .disable = bxt_ddi_pll_disable,
> .get_hw_state = bxt_ddi_pll_get_hw_state,
> @@ -4129,21 +4129,21 @@ static bool icl_compare_hw_state(const struct intel_dpll_hw_state *_a,
> a->mg_pll_tdc_coldst_bias == b->mg_pll_tdc_coldst_bias;
> }
>
> -static const struct intel_shared_dpll_funcs combo_pll_funcs = {
> +static const struct intel_dpll_global_funcs combo_pll_funcs = {
> .enable = combo_pll_enable,
> .disable = combo_pll_disable,
> .get_hw_state = combo_pll_get_hw_state,
> .get_freq = icl_ddi_combo_pll_get_freq,
> };
>
> -static const struct intel_shared_dpll_funcs tbt_pll_funcs = {
> +static const struct intel_dpll_global_funcs tbt_pll_funcs = {
> .enable = tbt_pll_enable,
> .disable = tbt_pll_disable,
> .get_hw_state = tbt_pll_get_hw_state,
> .get_freq = icl_ddi_tbt_pll_get_freq,
> };
>
> -static const struct intel_shared_dpll_funcs mg_pll_funcs = {
> +static const struct intel_dpll_global_funcs mg_pll_funcs = {
> .enable = mg_pll_enable,
> .disable = mg_pll_disable,
> .get_hw_state = mg_pll_get_hw_state,
> @@ -4191,7 +4191,7 @@ static const struct intel_dpll_mgr ehl_pll_mgr = {
> .compare_hw_state = icl_compare_hw_state,
> };
>
> -static const struct intel_shared_dpll_funcs dkl_pll_funcs = {
> +static const struct intel_dpll_global_funcs dkl_pll_funcs = {
> .enable = mg_pll_enable,
> .disable = mg_pll_disable,
> .get_hw_state = dkl_pll_get_hw_state,
> diff --git a/drivers/gpu/drm/i915/display/intel_dpll_mgr.h b/drivers/gpu/drm/i915/display/intel_dpll_mgr.h
> index d93072486831..2080118be523 100644
> --- a/drivers/gpu/drm/i915/display/intel_dpll_mgr.h
> +++ b/drivers/gpu/drm/i915/display/intel_dpll_mgr.h
> @@ -41,7 +41,7 @@ struct intel_crtc;
> struct intel_crtc_state;
> struct intel_encoder;
> struct intel_shared_dpll;
> -struct intel_shared_dpll_funcs;
> +struct intel_dpll_global_funcs;
>
> /**
> * enum intel_dpll_id - possible DPLL ids
> @@ -314,7 +314,7 @@ struct dpll_info {
> /**
> * @funcs: platform specific hooks
> */
> - const struct intel_shared_dpll_funcs *funcs;
> + const struct intel_dpll_global_funcs *funcs;
>
> /**
> * @id: unique identifier for this DPLL
--
Jani Nikula, Intel
next prev parent reply other threads:[~2025-04-03 14:59 UTC|newest]
Thread overview: 35+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-04-02 8:31 [PATCH 00/16] DPLL framework redesign Suraj Kandpal
2025-04-02 8:31 ` [PATCH 01/16] drm/i915/dpll: Rename intel_shared_dpll_state Suraj Kandpal
2025-04-02 8:31 ` [PATCH 02/16] drm/i915/dpll: Rename macro for_each_shared_dpll Suraj Kandpal
2025-04-02 8:31 ` [PATCH 03/16] drm/i915/dpll: Rename intel_shared_dpll_funcs Suraj Kandpal
2025-04-03 14:59 ` Jani Nikula [this message]
2025-04-03 15:11 ` Kandpal, Suraj
2025-04-02 8:31 ` [PATCH 04/16] drm/i915/dpll: Rename intel_shared_dpll Suraj Kandpal
2025-04-03 15:01 ` Jani Nikula
2025-04-03 15:15 ` Kandpal, Suraj
2025-04-02 8:31 ` [PATCH 05/16] drm/i915/dpll: Move away from using shared dpll Suraj Kandpal
2025-04-03 15:03 ` Jani Nikula
2025-04-03 15:17 ` Kandpal, Suraj
2025-04-02 8:31 ` [PATCH 06/16] drm/i915/dpll: Rename crtc_get_shared_dpll Suraj Kandpal
2025-04-02 8:31 ` [PATCH 07/16] drm/i915/dpll: Change argument for enable hook in intel_global_dpll_funcs Suraj Kandpal
2025-04-02 8:31 ` [PATCH 08/16] drm/i915/drm: Rename disable hook in intel_dpll_global_func Suraj Kandpal
2025-04-02 8:31 ` [PATCH 09/16] drm/i915/dpll: Introduce new " Suraj Kandpal
2025-04-02 8:31 ` [PATCH 10/16] drm/i915/dpll: Add intel_encoder argument to get_hw_state hook Suraj Kandpal
2025-04-02 8:31 ` [PATCH 11/16] drm/i915/dpll: Change arguments for get_freq hook Suraj Kandpal
2025-04-02 8:32 ` [PATCH 12/16] drm/i915/dpll: Rename intel_[enable/disable]_global_dpll Suraj Kandpal
2025-04-02 8:32 ` [PATCH 13/16] drm/i915/dpll: Rename intel_unreference_dpll_global_crtc Suraj Kandpal
2025-04-02 8:32 ` [PATCH 14/16] drm/i915/dpll: Rename intel_<release/reserve>_dpll_globals Suraj Kandpal
2025-04-02 8:32 ` [PATCH 15/16] drm/i915/dpll: Rename intel_compute_dpll_globals Suraj Kandpal
2025-04-02 8:32 ` [PATCH 16/16] drm/i915/dpll: Rename intel_update_active_dpll Suraj Kandpal
2025-04-02 8:39 ` ✓ CI.Patch_applied: success for DPLL framework redesign (rev2) Patchwork
2025-04-02 8:40 ` ✗ CI.checkpatch: warning " Patchwork
2025-04-02 8:41 ` ✓ CI.KUnit: success " Patchwork
2025-04-02 8:58 ` ✓ CI.Build: " Patchwork
2025-04-02 9:00 ` ✓ CI.Hooks: " Patchwork
2025-04-02 9:02 ` ✓ CI.checksparse: " Patchwork
2025-04-02 9:12 ` ✗ Fi.CI.CHECKPATCH: warning " Patchwork
2025-04-02 9:12 ` ✗ Fi.CI.SPARSE: " Patchwork
2025-04-02 9:42 ` ✓ i915.CI.BAT: success " Patchwork
2025-04-02 9:47 ` ✓ Xe.CI.BAT: " Patchwork
2025-04-02 11:01 ` ✗ Xe.CI.Full: failure " Patchwork
2025-04-02 11:08 ` ✓ i915.CI.Full: success " Patchwork
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87bjtd1ebq.fsf@intel.com \
--to=jani.nikula@intel.com \
--cc=ankit.k.nautiyal@intel.com \
--cc=intel-gfx@lists.freedesktop.org \
--cc=intel-xe@lists.freedesktop.org \
--cc=mika.kahola@intel.com \
--cc=suraj.kandpal@intel.com \
--cc=uma.shankar@intel.com \
--cc=ville.syrjala@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.