From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from smtp.kernel.org (aws-us-west-2-korg-mail-alma10-1.taild15c8.ts.net [100.103.45.18]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 8E70032B121 for ; Tue, 14 Jul 2026 09:12:43 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=100.103.45.18 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1784020364; cv=none; b=ZhsoLPFmfkMb3BnBsG0nhmPUo/N36JR5eoQIfv9FNVk0n8Fycz9MVagAu7z0Zfe4YWpv6fANzvue0ur2JupEebXVFFp0eyioX7UNf+zX9GxgcpIlQXFVQBwQyxX7hdeKo8YZdc/+z0b5coITT/AbIQNaYJBDXOdI5tHcXcMCZz0= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1784020364; c=relaxed/simple; bh=lYaHBzC0lt/p7T6zvcCFDyu+nvGzVWHXxnFKuRdf+8g=; h=Message-ID:Date:MIME-Version:Subject:To:Cc:References:From: In-Reply-To:Content-Type; b=HvbllxbOZ/xEeb4ndUvXQxJ+7QiUBxCke9BKHfIJujbqRZMpGeU28PyOudZBqROlmG2iuwtaBNZUByNbhpOZlT7St/gNprIwAO2ZqL/vcL0Dr+Rwsg1IJC+WJdk7FtXuD8aDovRKeC1y3wD1/SNXaIon0jz/VmODIqvVqWJkWxg= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b=Z8grzVIW; arc=none smtp.client-ip=100.103.45.18 Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b="Z8grzVIW" Received: by smtp.kernel.org (Postfix) with ESMTPSA id 5EAE11F000E9; Tue, 14 Jul 2026 09:12:40 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=kernel.org; s=k20260515; t=1784020363; bh=6B7VSgEdKQ8mSYNmi/82zeiS1ng907Z0t1XGjxQRCyk=; h=Date:Subject:To:Cc:References:From:In-Reply-To; b=Z8grzVIWvxFRvWcivKYbiWQ/xf/14DTfRk76R3iE3krm2gxyiDFmKU70RDHKK0WUR sInS8C5GHetjjxQ6B/C7Gc1bQsx21iWHqbrHBOY3K37qU6ajGn9xgniU0apj1S1HYW Mhw8lqMQojHqvNJSg/Yc2gTcnQcbkmHu0DHPWAVAca4prtdsAIIicmFRDOLhXwSJiZ /qzOj83hypUu34tVWQvfYY0gYjxEajdz1RX3S5ppthXVbxv8wtwxlCozqY8Cpy41dC za4IOKadexEbfJwRS66RiRkQd/Coc0zPzLXp4zBun2XSvZjm447aO/KI7XqFgTFvLZ 51TS2eQ3GTvaA== Message-ID: <87f607bb-3766-4b90-b3cc-a98d3cadf760@kernel.org> Date: Tue, 14 Jul 2026 11:12:38 +0200 Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Subject: Re: [PATCH slab/for-next-fixes v3 4/4] mm/slab: prevent unbounded recursion in free path with new kmalloc type Content-Language: en-US To: Harry Yoo , Suren Baghdasaryan Cc: Andrew Morton , Hao Li , Christoph Lameter , David Rientjes , Roman Gushchin , "Liam R. Howlett" , Hao Ge , Kees Cook , Pedro Falcato , Shakeel Butt , Danielle Constantino , linux-mm@kvack.org, linux-kernel@vger.kernel.org References: <20260713-kmalloc-no-objext-v3-0-47c7bd138de7@kernel.org> <20260713-kmalloc-no-objext-v3-4-47c7bd138de7@kernel.org> <121dda1a-f050-4035-93c0-6a36278e50b7@kernel.org> From: "Vlastimil Babka (SUSE)" Autocrypt: addr=vbabka@kernel.org; keydata= xsFNBFZdmxYBEADsw/SiUSjB0dM+vSh95UkgcHjzEVBlby/Fg+g42O7LAEkCYXi/vvq31JTB KxRWDHX0R2tgpFDXHnzZcQywawu8eSq0LxzxFNYMvtB7sV1pxYwej2qx9B75qW2plBs+7+YB 87tMFA+u+L4Z5xAzIimfLD5EKC56kJ1CsXlM8S/LHcmdD9Ctkn3trYDNnat0eoAcfPIP2OZ+ 9oe9IF/R28zmh0ifLXyJQQz5ofdj4bPf8ecEW0rhcqHfTD8k4yK0xxt3xW+6Exqp9n9bydiy tcSAw/TahjW6yrA+6JhSBv1v2tIm+itQc073zjSX8OFL51qQVzRFr7H2UQG33lw2QrvHRXqD Ot7ViKam7v0Ho9wEWiQOOZlHItOOXFphWb2yq3nzrKe45oWoSgkxKb97MVsQ+q2SYjJRBBH4 8qKhphADYxkIP6yut/eaj9ImvRUZZRi0DTc8xfnvHGTjKbJzC2xpFcY0DQbZzuwsIZ8OPJCc LM4S7mT25NE5kUTG/TKQCk922vRdGVMoLA7dIQrgXnRXtyT61sg8PG4wcfOnuWf8577aXP1x 6mzw3/jh3F+oSBHb/GcLC7mvWreJifUL2gEdssGfXhGWBo6zLS3qhgtwjay0Jl+kza1lo+Cv BB2T79D4WGdDuVa4eOrQ02TxqGN7G0Biz5ZLRSFzQSQwLn8fbwARAQABzSNWbGFzdGltaWwg QmFia2EgPHZiYWJrYUBrZXJuZWwub3JnPsLBsAQTAQoAWhYhBKlA1DSZLC6OmRA9UCJPp+fM gqZkBQJqFFy6GxSAAAAAAAQADm1hbnUyLDIuNSsxLjEyLDIsMgIbAwUJGtCBUAULCQgHAwUV CgkICwUWAgMBAAIeBQIXgAAKCRAiT6fnzIKmZJIUEADFx/tREzUImHrEwVHeSvDFmA7tJysI UVrlvrM09E7GIuzphzv7jYmo8n3ANpCczLEVr4G0syYQdTigaZgv3+FQDIIzhKih1IHhu1Ei XHlywNWKnQxxQEUNi5Mwx43wQz5XVw9F1A7gtKBKNtfogO511hAbrzagrYajyQacEJ/+sfhZ 9Da8ltHIXD8pcYaHUfQgEusCgmEd9+KrUwrTbckFKmYq5chuE6yJ4J0EmWknL096jIE6CnzF FRslQ3B1UKDjxVsm1ZHfir5NeWszLkTvGFsddFaWTgh8UycESG6VQzKXjjewXu2pG7YQYRpj QKm1W5X2TkwWkXRBZTmfmbhxIUMh3+zf5wQ463rSmDN/8v81tdqBtAW6rH/kzg1GvkaTHXn0 507yEHFzBksk2viAuIxxr7km8+/KARYLIdGtx30EG8cKzAUZOK6WqxtNCsXUJNrVE8CWrCaD icoNu7Fs1c5hmPHdSTnU48ce67449DdnO4neLSNhRiGlMHJgfJUmgrxu/hcYeOZ3haWmEQ2w uW1Mh01OHi8QZHCEyAbABrPs9GUgccc/4eYXX9hIgxfSkYzn8f+8NuIFPWl/0uTvjgqU29FQ SbzOLxHq9439Ox40G5mS5eZXRGxITYR+6TXvRGI6P/264jvflnr/pDGUttaikU+0W+1uxgKH cmYbEc7ATQRbGTU1AQgAn0H6UrFiWcovkh6EXVcl+SeqyO6JHOPm+e9Wu0Vw+VIUvXZVUVVQ La1PQDUi6j00ChlcR66g9/V0sPIcSutacPKfdKYOBvzd4rlhL8rfrdEsQw5ApZxrA8kYZVMh FmBRKAa6wos25moTlMKpCWzTH84+WO5+ziCTsTUZASAToz3RdunTD+vQcHj0GqNTPAHK63sf bAB2I0BslZkXkY1RLb/YhuA6E7JyEd2pilZOrIuBGl/5q2qSakgnAVFWFBR/DO27JuAksYnq +aH8vI0xGvwn75KqSk4UzAkDzWSmO4ZHuahKtQgZNsMYV+PGayRBX9b9zbldzopoLBdqHc4n jQARAQABwsF8BBgBCgAmAhsMFiEEqUDUNJksLo6ZED1QIk+n58yCpmQFAmfIHFQFCRYU6J8A CgkQIk+n58yCpmS2PA//bqN1LfcotmArgElsa+0EGZSQlYgK48pm8WAeTXTngudP9IJ4SuKY HR5RNjHcBeqN+Me0zxRqYzRb8nGanHEkDyf4Im8DQM8d6vbyU+FcPmG4skud4kgS1zMHnlVd SXfSIwKC/hKgdHG8aBV7545Lz9X6Iohea+94wneD0aw/hqF+QWewGZhWJriWAZtvEkzNjQOi 4U9F/trLten/x7bpphDSnDMKJtITbtzATT1Dq7o7VpIUK1nCTQALMuMjKCdi8OdU/+V+R3O4 0PXWvX8qrvqYapVbZ+9KqT74FsuB0Ya9uXwgBF2Q6cRuETZk5vqaqKxzqoQZCO8AOz/58j6O 2RHNy/mZEN+7tJ5Tsq42zVJ4jxsT8b9YplavCMsnBgDeRWhcbYhCyttoL7nYISyWg4kQYZ/P wIV3OuNv2f8iKYsxNsRuClOAF82+gvqOy1/1pprFjy8uo2pkoOrb63aOP3vO5VHnRKgra6dq NcaZ+c6J4H+nEJGi2SkHAUJz5oBzuThvPudLvPA/SK8sKoM01IRxSihev/S/5WLazXB1PGem OCbvzC1IjWJJraxiDJ5IygokapUa2RP7+WBR22skQ3SSl6G107QgWKSyTOGWEaRmV53vxQLV jXuCmzSSasTL60zq5yGrT4/DYQVSNEUiUbG4pYekxJujNeEDkUlky0Y= In-Reply-To: <121dda1a-f050-4035-93c0-6a36278e50b7@kernel.org> Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit On 7/14/26 07:17, Harry Yoo wrote: > > On 7/14/26 2:08 AM, Suren Baghdasaryan wrote: >> On Mon, Jul 13, 2026 at 7:29 AM Harry Yoo (Oracle) wrote: >>> @@ -386,12 +387,17 @@ static inline unsigned int size_index_elem(unsigned int bytes) >>> * KMALLOC_MAX_CACHE_SIZE and the caller must check that. >>> */ >>> static inline struct kmem_cache * >>> -kmalloc_slab(size_t size, kmem_buckets *b, gfp_t flags, kmalloc_token_t token) >>> +kmalloc_slab(size_t size, kmem_buckets *b, gfp_t flags, kmalloc_token_t token, >>> + unsigned int alloc_flags) >>> { >>> unsigned int index; >>> + enum kmalloc_cache_type type = kmalloc_type(flags, token); >>> + >>> + if (alloc_flags & SLAB_ALLOC_NO_OBJ_EXT) >>> + type = KMALLOC_NO_OBJ_EXT; > > Hi Suren, thanks for the reviews. > It's indeed helpful to have an eye for those bugfixes. > >> Why not let kmalloc_type() handle alloc_flags? > > Good point! > >> Other users (there are >> only 4 of them) can pass SLAB_ALLOC_DEFAULT. That seems cleaner to me >> and more robust. > > Hmm, there was a reason... *checks notes*, oh, there is no note. > IIRC I was afraid of exposing SLAB_ALLOC_* flags to arbitrary users. Hm good point, they are in mm/slab.h and kmalloc_type() needs to be in the public include/linux/slab.h. Given its usage in __builtin_constant_p(size) paths of kmalloc[_node] I would rather not complicate it (even if a hardcoded SLAB_ALLOC_DEFAULT should eliminate the extra code). So I'd rather keep KMALLOC_NO_OBJ_EXT handling hidden in mm/ as long as it's possible. > should probably fine as long as it's not used in > kmalloc/kmem_cache_alloc() APIs, not sure. > >>> if (!b) >>> - b = &kmalloc_caches[kmalloc_type(flags, token)]; >>> + b = &kmalloc_caches[type]; >>> if (size <= 192) >>> index = kmalloc_size_index[size_index_elem(size)]; >>> else >>> diff --git a/mm/slab_common.c b/mm/slab_common.c >>> index b6426d7ceec9..03ecac12cd86 100644 >>> --- a/mm/slab_common.c >>> +++ b/mm/slab_common.c >>> @@ -957,6 +968,12 @@ new_kmalloc_cache(int idx, enum kmalloc_cache_type type) >>> return; >>> } >>> flags |= SLAB_ACCOUNT; >>> + } else if (IS_ENABLED(CONFIG_SLAB_OBJ_EXT) && type == KMALLOC_NO_OBJ_EXT) { >> >> Hmm, you have to check IS_ENABLED(CONFIG_SLAB_OBJ_EXT) here because >> KMALLOC_NO_OBJ_EXT can be aliased with KMALLOC_NORMAL... Could we >> instead have a helper function like this (maybe with a better name): > > Hmm that's fine, but I think that bit should not be part of -stable > fixes at least. Here I tried to make it consistent with KMALLOC_RECLAIM > and KMALLOC_DMA :) Agreed. >> #ifdef CONFIG_SLAB_OBJ_EXT >> bool is_kmalloc_no_obj_ext_type(type) { return type == KMALLOC_NO_OBJ_EXT; } >> #else >> bool is_kmalloc_no_obj_ext_type(type) { return false; } >> #endif >> ? > > is_kmalloc_no_obj_ext_type(), > kmalloc_type_is_no_obj_ext(), > is_kmalloc_type_no_obj_ext(), > ... > > naming is hard, ugh :) > >> >>> + if (!need_kmalloc_no_objext()) { >>> + kmalloc_caches[type][idx] = kmalloc_caches[KMALLOC_NORMAL][idx]; >> >> Could kmalloc_caches[KMALLOC_NORMAL][idx] be NULL here? > > No. KMALLOC_NORMAL caches are created before all other kmalloc > caches. > > IIRC checking if kmalloc_caches[KMALLOC_NORMAL][idx] is NULL was added > by commit 963e84b0f262 ("mm/slab: limit kmalloc() minimum alignment > to dma_get_cache_alignment()") to avoid creating kmalloc caches of same > type and size due to minimum alignment. > >> In general why do we special-case and do an early exit here? >> >> Can we do instead: >> >> if (need_kmalloc_no_objext()) >> flags |= SLAB_NO_OBJ_EXT | SLAB_NO_MERGE; >> >> and use the common path? > > Hmm, but even without SLAB_NO_MERGE, we often end up not merging > kmalloc caches e.g.) because of non-zero s->usersize. > > I think that's why we do special-case and an early exit? > > We could probably do some refactoring to change that, but in general > I'm afraid of backporting refactoring work to -stable because I fear > introducing very subtle behavioral changes that nobody would notice. Agreed, let's keep hotfixes as minimal as possible and refactor later. >>> + return; >>> + } >>> + flags |= SLAB_NO_OBJ_EXT | SLAB_NO_MERGE; >>> } else if (IS_ENABLED(CONFIG_ZONE_DMA) && (type == KMALLOC_DMA)) { >>> flags |= SLAB_CACHE_DMA; >>> } >>> diff --git a/mm/slub.c b/mm/slub.c >>> index abe748b7dddb..a34f9b8770dc 100644 >>> --- a/mm/slub.c >>> +++ b/mm/slub.c >>> @@ -2168,14 +2132,20 @@ int alloc_slab_obj_exts(struct slab *slab, struct kmem_cache *s, >>> unsigned long new_exts; >>> unsigned long old_exts; >>> struct slabobj_ext *vec; >>> - size_t sz; >>> + size_t sz = sizeof(struct slabobj_ext) * slab->objects; >>> >>> gfp &= ~OBJCGS_CLEAR_MASK; >>> - /* Prevent recursive extension vector allocation */ >>> - alloc_flags |= SLAB_ALLOC_NO_RECURSE; >>> - alloc_flags &= ~SLAB_ALLOC_NEW_SLAB; >>> + /* >>> + * In most cases, obj_exts arrays are allocated from normal kmalloc. >>> + * However, normal kmalloc caches must allocate them from >>> + * KMALLOC_NO_OBJ_EXT caches to prevent recursion. >> >> For debugging it would have been convenient to allocate all obj_ext >> vectors from dedicated caches... Maybe we can do that for >> CONFIG_DEBUG_VM or someday when we add CONFIG_OBJ_EXT_DEBUG? Anyway, >> not really a complaint but a wish. > > Vlastimil and I had a conversation on always (even w/o debug options) > having dedicated caches (primarily to separate lifetime and for > simplicity), it would be interesting to explore. > > https://lore.kernel.org/all/2436707a-b6ab-45ec-98e5-538e18589462@kernel.org >