All of lore.kernel.org
 help / color / mirror / Atom feed
From: Markus Armbruster <armbru@redhat.com>
To: Peter Maydell <peter.maydell@linaro.org>
Cc: qemu-devel@nongnu.org, stefanha@redhat.com,
	"Daniel P. Berrangé" <berrange@redhat.com>,
	"Marc-André Lureau" <marcandre.lureau@redhat.com>,
	"Peter Krempa" <pkrempa@redhat.com>
Subject: Re: [PULL 35/35] docs: mark '-mon' as deprecated in favour of -object
Date: Mon, 24 Aug 2026 12:48:36 +0200	[thread overview]
Message-ID: <87o6erssjf.fsf@pond.sub.org> (raw)
In-Reply-To: <CAFEAcA-tUz_YGhvqU8-o-jw-jhR4MTMFDJ3S9rA2ZG-0GpLtVw@mail.gmail.com> (Peter Maydell's message of "Mon, 24 Aug 2026 11:26:31 +0100")

Peter Maydell <peter.maydell@linaro.org> writes:

> On Tue, 7 Jul 2026 at 12:06, Markus Armbruster <armbru@redhat.com> wrote:
>>
>> From: Daniel P. Berrangé <berrange@redhat.com>
>>
>> The high level `-qmp` and `-monitor` options can remain as convenience
>> wrappers, but the low level `-mon` is completed obsoleted by the new
>> `-object` support with 'monitor-qmp' and 'monitor-hmp' types.
>>
>
>> @@ -3239,6 +3239,8 @@ void qemu_init(int argc, char **argv)
>>                  default_monitor = 0;
>>                  break;
>>              case QEMU_OPTION_mon:
>> +                warn_report_once("'-mon' is deprecated, use '-object' with "
>> +                                 "'monitor-hmp' or 'monitor-qmp' types instead");
>
> Can we be more precise in deprecation messages of this kind, please?
> This warning is not enough for the user to be able to figure out how
> to change their existing command line.
>
> I had to look into deprecated.rst, check the git history to see which
> commit added the deprecation, then find out how this commit was adjusting
> the examples in the tree.
>
> Notably, "-object monitor-hmp" appears to require an "id=" despite
> nothing actually caring what that ID is,

Yes, -object requires @id regardless of object type.  It calls
object_new_with_props_from_qdict() via user_creatable_add_qapi().
Together, they create the object at /objects/ID.

>                                          and the warning message
> doesn't say how to determine whether your existing -mon option
> should be changed to monitor-hmp or monitor-qmp. The deprecated.rst
> docs do say that part, but don't mention the ID bit.

Fair points.

Is this just "do better in the future", or are you also asking for a
patch to improve this warning?



  reply	other threads:[~2026-08-24 10:49 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-07 11:02 [PULL 00/35] Monitor patches for 2026-07-07 Markus Armbruster
2026-07-07 11:02 ` [PULL 01/35] qom: replace 'can_be_deleted' with 'prepare_delete' Markus Armbruster
2026-07-07 11:02 ` [PULL 02/35] monitor: replace 'common' with 'parent_obj' in MonitorHMP Markus Armbruster
2026-07-07 11:02 ` [PULL 03/35] monitor: replace 'common' with 'parent_obj' in MonitorQMP Markus Armbruster
2026-07-07 11:02 ` [PULL 04/35] monitor: rename monitor_init* to monitor_new* Markus Armbruster
2026-07-07 11:02 ` [PULL 05/35] monitor: minimal conversion of monitors to QOM Markus Armbruster
2026-07-07 11:02 ` [PULL 06/35] monitor: pass chardev ID into monitor constructor instead of object Markus Armbruster
2026-07-07 11:02 ` [PULL 07/35] monitor: add 'chardev' property to Monitor base class Markus Armbruster
2026-07-07 11:02 ` [PULL 08/35] monitor: add 'readline' property to HMP Monitor class Markus Armbruster
2026-07-07 11:02 ` [PULL 09/35] monitor: add 'pretty' property to QMP " Markus Armbruster
2026-07-07 11:02 ` [PULL 10/35] monitor: remove 'skip_flush' field Markus Armbruster
2026-07-07 11:02 ` [PULL 11/35] monitor: move monitor_data_(init|destroy) into QOM init/finalize Markus Armbruster
2026-07-07 11:02 ` [PULL 12/35] monitor: use class methods for monitor_vprintf Markus Armbruster
2026-07-07 11:02 ` [PULL 13/35] monitor: use class methods for monitor_qapi_event_emit Markus Armbruster
2026-07-07 11:02 ` [PULL 14/35] monitor: use class methods for monitor_accept_input Markus Armbruster
2026-07-07 11:02 ` [PULL 15/35] monitor: use class method for I/O thread request Markus Armbruster
2026-07-07 11:02 ` [PULL 16/35] monitor: use dynamic cast in monitor_qmp_requests_pop_any_with_lock Markus Armbruster
2026-07-07 11:02 ` [PULL 17/35] util: use dynamic cast in error vreport Markus Armbruster
2026-07-07 11:02 ` [PULL 18/35] monitor: drop unused monitor_cur_is_qmp Markus Armbruster
2026-07-07 11:02 ` [PULL 19/35] monitor: use dynamic cast in QMP commands Markus Armbruster
2026-07-07 11:02 ` [PULL 20/35] monitor: use dynamic cast in monitor_is_hmp_non_interactive Markus Armbruster
2026-07-07 11:02 ` [PULL 21/35] monitor: drop unused monitor_is_qmp method Markus Armbruster
2026-07-07 11:02 ` [PULL 22/35] monitor: eliminate monitor_is_hmp_non_interactive method Markus Armbruster
2026-07-07 11:02 ` [PULL 23/35] monitor: implement "user creatable" interface for adding monitors Markus Armbruster
2026-07-07 11:02 ` [PULL 24/35] monitor: convert from oneshot BH to persistent BH Markus Armbruster
2026-07-07 11:02 ` [PULL 25/35] monitor: reject attempts to delete the current monitor Markus Armbruster
2026-07-07 11:02 ` [PULL 26/35] monitor: protect qemu_chr_fe_accept_input with monitor lock Markus Armbruster
2026-07-07 11:02 ` [PULL 27/35] monitor: implement support for deleting QMP objects Markus Armbruster
2026-07-07 11:02 ` [PULL 28/35] tests/qtest: add tests for dynamic monitor add/remove Markus Armbruster
2026-07-07 11:02 ` [PULL 29/35] tests/functional: add e2e test for dynamic QMP monitor hotplug Markus Armbruster
2026-07-07 11:02 ` [PULL 30/35] tests/functional: add a stress test for monitor hot unplug Markus Armbruster
2026-07-07 11:02 ` [PULL 31/35] qom: add trace events for user creatable create/delete APIs Markus Armbruster
2026-07-07 11:02 ` [PULL 32/35] monitor: add support for auto-deleting monitors upon close Markus Armbruster
2026-07-07 11:02 ` [PULL 33/35] tests: switch from -mon to -object monitor-qmp Markus Armbruster
2026-07-07 11:02 ` [PULL 34/35] qemu-options: document new monitor-hmp and monitor-qmp objects Markus Armbruster
2026-07-07 11:03 ` [PULL 35/35] docs: mark '-mon' as deprecated in favour of -object Markus Armbruster
2026-08-24 10:26   ` Peter Maydell
2026-08-24 10:48     ` Markus Armbruster [this message]
2026-08-24 10:58       ` Peter Maydell
2026-08-24 11:39         ` Daniel P. Berrangé
2026-08-24 11:59           ` Peter Maydell
2026-07-08  5:53 ` [PULL 00/35] Monitor patches for 2026-07-07 Stefan Hajnoczi

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87o6erssjf.fsf@pond.sub.org \
    --to=armbru@redhat.com \
    --cc=berrange@redhat.com \
    --cc=marcandre.lureau@redhat.com \
    --cc=peter.maydell@linaro.org \
    --cc=pkrempa@redhat.com \
    --cc=qemu-devel@nongnu.org \
    --cc=stefanha@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.