From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from lists.ozlabs.org (lists.ozlabs.org [112.213.38.117]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.lore.kernel.org (Postfix) with ESMTPS id 6E991C433EF for ; Thu, 21 Apr 2022 15:01:00 +0000 (UTC) Received: from boromir.ozlabs.org (localhost [IPv6:::1]) by lists.ozlabs.org (Postfix) with ESMTP id 4Kkghp51g9z3bYG for ; Fri, 22 Apr 2022 01:00:58 +1000 (AEST) Authentication-Results: lists.ozlabs.org; spf=pass (sender SPF authorized) smtp.mailfrom=linux.alibaba.com (client-ip=115.124.30.56; helo=out30-56.freemail.mail.aliyun.com; envelope-from=jefflexu@linux.alibaba.com; receiver=) Received: from out30-56.freemail.mail.aliyun.com (out30-56.freemail.mail.aliyun.com [115.124.30.56]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by lists.ozlabs.org (Postfix) with ESMTPS id 4Kkghh2XWnz2yHD for ; Fri, 22 Apr 2022 01:00:50 +1000 (AEST) X-Alimail-AntiSpam: AC=PASS; BC=-1|-1; BR=01201311R591e4; CH=green; DM=||false|; DS=||; FP=0|-1|-1|-1|0|-1|-1|-1; HT=e01e04400; MF=jefflexu@linux.alibaba.com; NM=1; PH=DS; RN=19; SR=0; TI=SMTPD_---0VAgCgRW_1650553238; Received: from 192.168.31.65(mailfrom:jefflexu@linux.alibaba.com fp:SMTPD_---0VAgCgRW_1650553238) by smtp.aliyun-inc.com(127.0.0.1); Thu, 21 Apr 2022 23:00:41 +0800 Message-ID: <9b99e246-fbdf-2d78-7773-bf4481a8e122@linux.alibaba.com> Date: Thu, 21 Apr 2022 23:00:38 +0800 MIME-Version: 1.0 User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:91.0) Gecko/20100101 Thunderbird/91.6.1 Subject: Re: [PATCH v9 05/21] cachefiles: implement on-demand read Content-Language: en-US To: David Howells References: <20220415123614.54024-6-jefflexu@linux.alibaba.com> <20220415123614.54024-1-jefflexu@linux.alibaba.com> <1445520.1650550446@warthog.procyon.org.uk> From: JeffleXu In-Reply-To: <1445520.1650550446@warthog.procyon.org.uk> Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 7bit X-BeenThere: linux-erofs@lists.ozlabs.org X-Mailman-Version: 2.1.29 Precedence: list List-Id: Development of Linux EROFS file system List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Cc: linux-erofs@lists.ozlabs.org, fannaihao@baidu.com, willy@infradead.org, linux-kernel@vger.kernel.org, tianzichen@kuaishou.com, joseph.qi@linux.alibaba.com, zhangjiachen.jaycee@bytedance.com, linux-cachefs@redhat.com, gregkh@linuxfoundation.org, linux-fsdevel@vger.kernel.org, luodaowen.backend@bytedance.com, gerry@linux.alibaba.com, torvalds@linux-foundation.org Errors-To: linux-erofs-bounces+linux-erofs=archiver.kernel.org@lists.ozlabs.org Sender: "Linux-erofs" On 4/21/22 10:14 PM, David Howells wrote: > Jeffle Xu wrote: > >> A new NETFS_SREQ_ONDEMAND flag is introduced to indicate that on-demand >> read should be done when a cache miss encountered. > > That may conflict with changes I'm making - but it's just a matter of flag > renumbering. > >> +#define CACHEFILES_IOC_CREAD _IOW(0x98, 1, int) > > I wonder if CACHEFILES_IOC_READ_COMPLETE would be a better name, Okay, it sounds more readable. Thanks. but apart > from that: > > Acked-by: David Howells -- Thanks, Jeffle From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by smtp.lore.kernel.org (Postfix) with ESMTP id 6D987C433EF for ; Thu, 21 Apr 2022 15:01:05 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1349544AbiDUPDx (ORCPT ); Thu, 21 Apr 2022 11:03:53 -0400 Received: from lindbergh.monkeyblade.net ([23.128.96.19]:41410 "EHLO lindbergh.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1389886AbiDUPDq (ORCPT ); Thu, 21 Apr 2022 11:03:46 -0400 Received: from out30-54.freemail.mail.aliyun.com (out30-54.freemail.mail.aliyun.com [115.124.30.54]) by lindbergh.monkeyblade.net (Postfix) with ESMTPS id 5DBA34704D; Thu, 21 Apr 2022 08:00:46 -0700 (PDT) X-Alimail-AntiSpam: AC=PASS;BC=-1|-1;BR=01201311R591e4;CH=green;DM=||false|;DS=||;FP=0|-1|-1|-1|0|-1|-1|-1;HT=e01e04400;MF=jefflexu@linux.alibaba.com;NM=1;PH=DS;RN=19;SR=0;TI=SMTPD_---0VAgCgRW_1650553238; Received: from 192.168.31.65(mailfrom:jefflexu@linux.alibaba.com fp:SMTPD_---0VAgCgRW_1650553238) by smtp.aliyun-inc.com(127.0.0.1); Thu, 21 Apr 2022 23:00:41 +0800 Message-ID: <9b99e246-fbdf-2d78-7773-bf4481a8e122@linux.alibaba.com> Date: Thu, 21 Apr 2022 23:00:38 +0800 MIME-Version: 1.0 User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:91.0) Gecko/20100101 Thunderbird/91.6.1 Subject: Re: [PATCH v9 05/21] cachefiles: implement on-demand read Content-Language: en-US To: David Howells Cc: linux-cachefs@redhat.com, xiang@kernel.org, chao@kernel.org, linux-erofs@lists.ozlabs.org, torvalds@linux-foundation.org, gregkh@linuxfoundation.org, willy@infradead.org, linux-fsdevel@vger.kernel.org, joseph.qi@linux.alibaba.com, bo.liu@linux.alibaba.com, tao.peng@linux.alibaba.com, gerry@linux.alibaba.com, eguan@linux.alibaba.com, linux-kernel@vger.kernel.org, luodaowen.backend@bytedance.com, tianzichen@kuaishou.com, fannaihao@baidu.com, zhangjiachen.jaycee@bytedance.com References: <20220415123614.54024-6-jefflexu@linux.alibaba.com> <20220415123614.54024-1-jefflexu@linux.alibaba.com> <1445520.1650550446@warthog.procyon.org.uk> From: JeffleXu In-Reply-To: <1445520.1650550446@warthog.procyon.org.uk> Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 7bit Precedence: bulk List-ID: X-Mailing-List: linux-fsdevel@vger.kernel.org On 4/21/22 10:14 PM, David Howells wrote: > Jeffle Xu wrote: > >> A new NETFS_SREQ_ONDEMAND flag is introduced to indicate that on-demand >> read should be done when a cache miss encountered. > > That may conflict with changes I'm making - but it's just a matter of flag > renumbering. > >> +#define CACHEFILES_IOC_CREAD _IOW(0x98, 1, int) > > I wonder if CACHEFILES_IOC_READ_COMPLETE would be a better name, Okay, it sounds more readable. Thanks. but apart > from that: > > Acked-by: David Howells -- Thanks, Jeffle