All of lore.kernel.org
 help / color / mirror / Atom feed
From: David Hildenbrand <david@redhat.com>
To: 'Guanjun' <guanjun@linux.alibaba.com>,
	willy@infradead.org, akpm@linux-foundation.org,
	linux-fsdevel@vger.kernel.org, linux-mm@kvack.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH mm 1/1] filemap: Remove redundant folio_test_large check in filemap_free_folio
Date: Thu, 13 Feb 2025 14:00:08 +0100	[thread overview]
Message-ID: <9fb47de6-0d39-43df-b11a-ec188ecd90c8@redhat.com> (raw)
In-Reply-To: <20250213055612.490993-1-guanjun@linux.alibaba.com>

On 13.02.25 06:56, 'Guanjun' wrote:
> From: Guanjun <guanjun@linux.alibaba.com>
> 
> The folio_test_large check in filemap_free_folio is unnecessary because
> folio_nr_pages, which is called internally, already performs this check.
> Removing the redundant condition simplifies the code and avoids double
> validation.
> 
> This change improves code readability and reduces unnecessary operations
> in the folio freeing path.
> 
> Signed-off-by: Guanjun <guanjun@linux.alibaba.com>
> ---
>   mm/filemap.c | 5 +----
>   1 file changed, 1 insertion(+), 4 deletions(-)
> 
> diff --git a/mm/filemap.c b/mm/filemap.c
> index 804d7365680c..2b860b59a521 100644
> --- a/mm/filemap.c
> +++ b/mm/filemap.c
> @@ -227,15 +227,12 @@ void __filemap_remove_folio(struct folio *folio, void *shadow)
>   void filemap_free_folio(struct address_space *mapping, struct folio *folio)
>   {
>   	void (*free_folio)(struct folio *);
> -	int refs = 1;
>   
>   	free_folio = mapping->a_ops->free_folio;
>   	if (free_folio)
>   		free_folio(folio);
>   
> -	if (folio_test_large(folio))
> -		refs = folio_nr_pages(folio);
> -	folio_put_refs(folio, refs);
> +	folio_put_refs(folio, folio_nr_pages(folio));
>   }
>   
>   /**

Acked-by: David Hildenbrand <david@redhat.com>


-- 
Cheers,

David / dhildenb


      reply	other threads:[~2025-02-13 13:00 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-02-13  5:56 [PATCH mm 1/1] filemap: Remove redundant folio_test_large check in filemap_free_folio 'Guanjun'
2025-02-13 13:00 ` David Hildenbrand [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=9fb47de6-0d39-43df-b11a-ec188ecd90c8@redhat.com \
    --to=david@redhat.com \
    --cc=akpm@linux-foundation.org \
    --cc=guanjun@linux.alibaba.com \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=willy@infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.