All of lore.kernel.org
 help / color / mirror / Atom feed
 messages from 2017-12-29 08:08:23 to 2017-12-29 08:18:41 UTC [more...]

consolidate direct dma mapping and swiotlb support
 2017-12-29  8:18 UTC  (187+ messages)
` [PATCH 01/67] x86: remove X86_PPRO_FENCE
  ` [PATCH 02/67] alpha: mark jensen as broken
  ` [PATCH 04/67] arm64: don't override dma_max_pfn
  ` [PATCH 05/67] dma-mapping: replace PCI_DMA_BUS_IS_PHYS with a flag in struct dma_map_ops
  ` [PATCH 07/67] m32r: remove unused flush_write_buffers definition
  ` [PATCH 08/67] powerpc: "
  ` [PATCH 10/67] m32r: remove the unused dma_capable helper
  ` [PATCH 12/67] s390: "
  ` [PATCH 15/67] hexagon: use the generic "
  ` [PATCH 16/67] powerpc: rename dma_direct_ to dma_nommu_
  ` [PATCH 18/67] microblaze: remove dma_nommu_dma_supported
  ` [PATCH 20/67] s390: move s390_pci_dma_ops to asm/pci_dma.h
  ` [PATCH 21/67] dma-mapping: warn when there is no coherent_dma_mask
  ` [PATCH 23/67] dma-mapping: add an arch_dma_supported hook
  ` [PATCH 25/67] dma-direct: rename dma_noop to dma_direct
  ` [PATCH 26/67] dma-direct: use phys_to_dma
  ` [PATCH 27/67] dma-direct: add dma address sanity checks
` [PATCH 03/67] dma-mapping: take dma_pfn_offset into account in dma_max_pfn
` [PATCH 06/67] hexagon: remove unused flush_write_buffers definition
` [PATCH 09/67] arc: remove CONFIG_ARC_PLAT_NEEDS_PHYS_TO_DMA
` [PATCH 11/67] riscv: remove the unused dma_capable helper
` [PATCH 13/67] dma-mapping: move swiotlb arch helpers to a new header
` [PATCH 14/67] dma-mapping: move dma_mark_clean to dma-direct.h
` [PATCH 17/67] microblaze: rename dma_direct to dma_microblaze
` [PATCH 19/67] microblaze: remove the dead !NOT_COHERENT_CACHE dma code
` [PATCH 22/67] dma-mapping: clear harmful GFP_* flags in common code
` [PATCH 24/67] dma-mapping: provide a generic asm/dma-mapping.h
` [PATCH 28/67] dma-direct: add support for CMA allocation
` [PATCH 29/67] dma-direct: use node local allocations for coherent memory
` [PATCH 30/67] dma-direct: retry allocations using GFP_DMA for small masks
` [PATCH 31/67] dma-direct: make dma_direct_{alloc,free} available to other implementations
  ` [PATCH 31/67] dma-direct: make dma_direct_{alloc, free} "
` [PATCH 32/67] dma-direct: add support for allocation from ZONE_DMA and ZONE_DMA32
` [PATCH 33/67] dma-direct: reject too small dma masks
` [PATCH 34/67] cris: use dma-direct
` [PATCH 35/67] h8300: "
` [PATCH 36/67] x86: remove dma_alloc_coherent_mask
` [PATCH 37/67] x86: use dma-direct

consolidate direct dma mapping and swiotlb support
 2017-12-29  8:18 UTC 

[PATCH] build: Update videobuf2 related patches
 2017-12-29  9:12 UTC  (2+ messages)

[PATCH net 0/3] bug fixes for ENA Ethernet driver
 2017-12-29  8:09 UTC  (5+ messages)
` [PATCH net 3/3] eet: ena: invoke netif_carrier_off() only after netdev registered

About the try to remove cross-release feature entirely by Ingo
 2017-12-29  8:09 UTC  (4+ messages)

[PATCH v2 1/4] media: ov5695: add support for OV5695 sensor
 2017-12-29  8:08 UTC  (7+ messages)
  ` [PATCH v2 2/4] [media] dt/bindings: Add bindings for OV5695
  ` [PATCH v2 3/4] media: ov2685: add support for OV2685 sensor
  ` [PATCH v2 4/4] [media] dt/bindings: Add bindings for OV2685


This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.