All of lore.kernel.org
 help / color / mirror / Atom feed
 messages from 2018-02-05 23:57:57 to 2018-02-06 00:29:35 UTC [more...]

[RFC PATCH 000/194] Moving global state into the repository object
 2018-02-06  0:17 UTC  (150+ messages)
` [PATCH 021/194] pack: add repository argument to reprepare_packed_git
  ` [PATCH 023/194] pack: add repository argument to map_sha1_file
  ` [PATCH 024/194] sha1_file: allow alt_odb_usable to handle arbitrary repositories
  ` [PATCH 025/194] object-store: allow prepare_alt_odb "
  ` [PATCH 026/194] object-store: allow foreach_alt_odb "
  ` [PATCH 027/194] pack: allow install_packed_git "
  ` [PATCH 028/194] pack: allow rearrange_packed_git "
  ` [PATCH 029/194] pack: allow prepare_packed_git_mru "
  ` [PATCH 030/194] pack: allow prepare_packed_git_one "
  ` [PATCH 031/194] pack: allow prepare_packed_git "
  ` [PATCH 032/194] pack: allow reprepare_packed_git "
  ` [PATCH 033/194] pack: allow sha1_file_name "
  ` [PATCH 034/194] pack: allow stat_sha1_file "
  ` [PATCH 035/194] pack: allow open_sha1_file "
  ` [PATCH 036/194] pack: allow map_sha1_file_1 "
  ` [PATCH 037/194] pack: allow map_sha1_file "
  ` [PATCH 038/194] pack: allow sha1_loose_object_info "
  ` [PATCH 039/194] replace_object.c: rename to use dash in file name
  ` [PATCH 040/194] replace-object: move replace_object to object store
  ` [PATCH 041/194] sha1_file: add repository argument to sha1_object_info_extended
  ` [PATCH 042/194] object-store: move alternates API to new alternates.h
  ` [PATCH 043/194] object-store: move loose object functions to new loose-object.h
  ` [PATCH 044/194] pack: move struct pack_window and pack_entry to packfile.h
  ` [PATCH 045/194] object-store: move object access functions to object-store.h
  ` [PATCH 046/194] object-store: move replace_objects back to object-store
  ` [PATCH 047/194] object-store: move lookup_replace_object to replace-object.h
  ` [PATCH 048/194] replace-object: add repository argument to do_lookup_replace_object
  ` [PATCH 049/194] replace-object: move replace objects prepared flag to object store
  ` [PATCH 050/194] replace-object: check_replace_refs is safe in multi repo environment
  ` [PATCH 051/194] refs: add repository argument to for_each_replace_ref
  ` [PATCH 052/194] refs: add repository argument to get_main_ref_store
  ` [PATCH 053/194] replace-object: add repository argument to register_replace_object
  ` [PATCH 054/194] replace-object: add repository argument to register_replace_ref
  ` [PATCH 055/194] replace-object: add repository argument to replace_object_pos
  ` [PATCH 056/194] replace-object: allow replace_object_pos to handle arbitrary repositories
  ` [PATCH 057/194] replace-object: allow register_replace_object "
  ` [PATCH 058/194] replace-object: add repository argument to prepare_replace_object
  ` [PATCH 059/194] refs: store the main ref store inside the repository struct
  ` [PATCH 060/194] refs: allow for_each_replace_ref to handle arbitrary repositories
  ` [PATCH 061/194] replace-object: allow prepare_replace_object "
  ` [PATCH 062/194] replace_object: allow do_lookup_replace_object "
  ` [PATCH 063/194] replace-object: add repository argument to lookup_replace_object
  ` [PATCH 064/194] repository: allow lookup_replace_object to handle arbitrary repositories
  ` [PATCH 065/194] object-store: add repository argument to sha1_object_info
  ` [PATCH 066/194] pack: add repository argument to retry_bad_packed_offset
  ` [PATCH 067/194] pack: add repository argument to packed_to_object_type
  ` [PATCH 068/194] pack: add repository argument to packed_object_info
  ` [PATCH 069/194] pack: add repository argument to find_pack_entry
  ` [PATCH 070/194] packfile: add repository argument to read_object
  ` [PATCH 071/194] packfile: add repository argument to unpack_entry
  ` [PATCH 072/194] packfile: add repository argument to cache_or_unpack_entry
  ` [PATCH 073/194] pack: allow find_pack_entry to handle arbitrary repositories
  ` [PATCH 074/194] object-store: allow sha1_object_info "
  ` [PATCH 075/194] fetch, push: do not use submodule as alternate in has_commits check
  ` [PATCH 076/194] push: add test showing bad interaction of replace refs and submodules
  ` [PATCH 077/194] replace_object: allow register_replace_ref to handle arbitrary repositories
  ` [PATCH 078/194] cache.h: migrate the definition of object_id to object.h
  ` [PATCH 079/194] repository: introduce object parser field
  ` [PATCH 080/194] object: add repository argument to parse_object
  ` [PATCH 081/194] object: add repository argument to create_object
  ` [PATCH 082/194] object: add repository argument to lookup_object
  ` [PATCH 083/194] object: add repository argument to grow_object_hash
  ` [PATCH 084/194] blob: add repository argument to lookup_blob
  ` [PATCH 085/194] tree: add repository argument to lookup_tree
  ` [PATCH 086/194] tag: add repository argument to lookup_tag
  ` [PATCH 087/194] tag: add repository argument to parse_tag_buffer
  ` [PATCH 088/194] tag: add repository argument to deref_tag
  ` [PATCH 089/194] object: add repository argument to lookup_commit_reference_gently
  ` [PATCH 090/194] object: add repository argument to lookup_commit_reference
  ` [PATCH 091/194] object: add repository argument to lookup_commit
  ` [PATCH 092/194] object: move grafts to object parser
  ` [PATCH 093/194] object: add repository argument to commit_graft_pos
  ` [PATCH 094/194] commit: add repository argument to parse_commit_buffer
  ` [PATCH 095/194] object: add repository argument to register_commit_graft
  ` [PATCH 096/194] object: add repository argument to read_graft_file
  ` [PATCH 097/194] object: add repository argument to prepare_commit_graft
  ` [PATCH 098/194] object: add repository argument to lookup_commit_graft
` [PATCH 099/194] object: allow grow_object_hash to handle arbitrary repositories
  ` [PATCH 100/194] object: allow create_object "
  ` [PATCH 101/194] object: allow lookup_object "
  ` [PATCH 102/194] object: add repository argument to lookup_unknown_object
  ` [PATCH 103/194] object: allow lookup_unknown_object to handle arbitrary repositories
  ` [PATCH 104/194] object: add repository argument to parse_object_buffer
  ` [PATCH 105/194] repository: keep track of all open repositories
  ` [PATCH 106/194] Rename sha1_object_info.cocci to object_store.cocci
  ` [PATCH 107/194] alternates: add repository argument to add_to_alternates_file
  ` [PATCH 108/194] alternates: add repository argument to add_to_alternates_memory
  ` [PATCH 109/194] object-store: move check_sha1_signature to object-store.h
  ` [PATCH 110/194] object-store: add repository argument to check_sha1_signature
  ` [PATCH 111/194] object-store: add repository argument to read_object
  ` [PATCH 112/194] object-store: add repository argument to read_sha1_file_extended
  ` [PATCH 113/194] object-store: add repository argument to read_sha1_file
  ` [PATCH 114/194] object: move read_object_with_reference to object.h
  ` [PATCH 115/194] packfile: add repository argument to has_packed_and_bad
  ` [PATCH 116/194] packfile: allow has_packed_and_bad to handle arbitrary repositories
  ` [PATCH 117/194] streaming: add repository argument to open_istream_fn
  ` [PATCH 119/194] streaming: add repository argument to istream_source
  ` [PATCH 120/194] streaming: allow istream_source to handle arbitrary repositories
  ` [PATCH 121/194] sha1_file: allow read_object "
  ` [PATCH 122/194] object-store.h: allow read_sha1_file{_extended} "
  ` [PATCH 123/194] streaming: allow open_istream_incore "
  ` [PATCH 124/194] streaming: allow open_istream_pack_non_delta "
  ` [PATCH 125/194] streaming: allow open_istream_loose "
  ` [PATCH 126/194] streaming: allow open_istream "
  ` [PATCH 127/194] alternates: convert add_to_alternates_memory to handle arbitrary repos
  ` [PATCH 128/194] object: add repository argument to object_as_type
  ` [PATCH 129/194] alloc: add repository argument to alloc_blob_node
  ` [PATCH 130/194] alloc: add repository argument to alloc_tree_node
  ` [PATCH 131/194] alloc: add repository argument to alloc_commit_node
  ` [PATCH 132/194] alloc: add repository argument to alloc_tag_node
  ` [PATCH 133/194] alloc: add repository argument to alloc_object_node
  ` [PATCH 134/194] alloc: add repository argument to alloc_report
  ` [PATCH 135/194] alloc: add repository argument to alloc_commit_index
  ` [PATCH 136/194] alloc: allow arbitrary repositories for alloc functions
  ` [PATCH 137/194] object: allow object_as_type to handle arbitrary repositories
  ` [PATCH 138/194] commit: allow lookup_commit "
  ` [PATCH 139/194] sha1_file: allow add_to_alternates_file "
  ` [PATCH 140/194] commit: convert commit_graft_pos() "
  ` [PATCH 141/194] commit: convert register_commit_graft "
  ` [PATCH 142/194] commit: convert read_graft_file "
  ` [PATCH 143/194] object: add repository argument to parse_commit_gently
  ` [PATCH 144/194] commit: add repository argument to parse_commit
  ` [PATCH 145/194] commit: add repository argument to set_commit_buffer
  ` [PATCH 146/194] commit: add repository argument to get_cached_commit_buffer
  ` [PATCH 147/194] commit: add repository argument to unuse_commit_buffer
  ` [PATCH 148/194] commit: add repository argument to free_commit_buffer
  ` [PATCH 149/194] commit: allow commit buffer functions to handle arbitrary repositories
  ` [PATCH 150/194] tree: allow lookup_tree "
  ` [PATCH 151/194] cache: convert get_graft_file "
  ` [PATCH 152/194] shallow: add repository argument to set_alternate_shallow_file
  ` [PATCH 153/194] shallow: add repository argument to register_shallow
  ` [PATCH 154/194] shallow: add repository argument to check_shallow_file_for_update
  ` [PATCH 155/194] shallow: add repository argument to is_repository_shallow
  ` [PATCH 156/194] migrate cached path to use the_repository
  ` [PATCH 157/194] shallow: migrate shallow information into the object parser
  ` [PATCH 158/194] commit: allow prepare_commit_graft to handle arbitrary repositories
  ` [PATCH 159/194] commit: allow lookup_commit_graft "
  ` [PATCH 160/194] commit: allow arbitrary repository argument for parse_commit_buffer
  ` [PATCH 161/194] commit: allow parse_commit_gently to handle arbitrary repository
  ` [PATCH 162/194] commit: add repository argument to get_merge_bases_many_0
  ` [PATCH 163/194] commit: add repository argument to merge_bases_many
  ` [PATCH 164/194] commit: add repository argument to paint_down_to_common
  ` [PATCH 165/194] commit: allow parse_commit to handle arbitrary repositories
  ` [PATCH 166/194] commit: allow paint_down_to_common "
  ` [PATCH 167/194] commit: allow merge_bases_many "
  ` [PATCH 168/194] commit: add repository argument to remove_redundant
  ` [PATCH 169/194] commit: allow remove_redundant to handle arbitrary repositories
  ` [PATCH 170/194] commit: allow get_merge_bases_many_0 "
  ` [PATCH 171/194] commit: add repository argument to get_merge_bases

i915 PSR test results and cursor lag
 2018-02-06  0:26 UTC  (10+ messages)
` [Intel-gfx] "

[PATCH] ceph: avoid memory leak when specifying same option several times
 2018-02-06  0:25 UTC 

[PATCH v8 1/6] drm/i915/guc: Move GuC WOPCM related code into separate files
 2018-02-06  0:25 UTC  (7+ messages)
` [PATCH v8 2/6] drm/i915/guc: Rename guc_ggtt_offset to intel_guc_ggtt_offset
` [PATCH v8 3/6] drm/i915/guc: Implement dynamic GuC WOPCM offset and size
` [PATCH v8 4/6] drm/i915/guc: Add dynamic GuC WOPCM offset and size support for CNL
` [PATCH v8 5/6] drm/i915/guc: Check the locking status of GuC WOPCM registers
` [PATCH v8 6/6] HAX Enable GuC Submission for CI
` ✗ Fi.CI.BAT: failure for series starting with [v8,1/6] drm/i915/guc: Move GuC WOPCM related code into separate files

nonrt behavior with GPIO interrupts
 2018-02-06  0:24 UTC 

bisected bd4c82c22c367e is the first bad commit (was [Bug 198617] New: zswap causing random applications to crash)
 2018-02-06  0:24 UTC  (7+ messages)

+ fontswap-thp-fix.patch added to -mm tree
 2018-02-06  0:24 UTC 

It's back! (Re: [REGRESSION] NFS is creating a hidden port (left over from xs_bind() ))
 2018-02-06  0:24 UTC  (2+ messages)

[PATCH] f2fs: remove redundant check of page type when submit bio
 2018-02-06  0:21 UTC 

[Qemu-devel] [PATCH] target/arm/kvm: gic: Prevent creating userspace GICv3 with KVM
 2018-02-06  0:19 UTC  (3+ messages)

[PATCH] buildtools: output build failure reason to stderr
 2018-02-06  0:19 UTC  (2+ messages)

+ mm-memcontrol-fix-nr_writeback-leak-in-memcg-and-system-stats.patch added to -mm tree
 2018-02-06  0:18 UTC 

[PATCH RFC] Btrfs: expose bad chunks in sysfs
 2018-02-05 23:15 UTC 

[PATCH] pmdinfogen: fix resource leak of FILE object
 2018-02-06  0:16 UTC  (4+ messages)

[linux-next test] 118588: regressions - trouble: blocked/broken/fail/pass
 2018-02-06  0:15 UTC 

[PATCH] core-image-minimal-initramfs: use initramfs-framework for initialization
 2018-02-06  0:15 UTC  (6+ messages)

[Bug 198659] New: Kernel 4.14 crash wirh invalid opcode. list_del_entry_valid
 2018-02-06  0:14 UTC 

[v2] ARM: dts: imx: Add support for Advantech DMS-BA16
 2018-02-06  0:13 UTC  (6+ messages)

+ fix-a-typo-in-documentation-sysctl-usertxt.patch added to -mm tree
 2018-02-06  0:13 UTC 

[PATCH] Documentation/git-send-email.txt: improve batching help
 2018-02-06  0:07 UTC 

[PATCH] mm: thp: fix potential clearing to referenced flag in page_idle_clear_pte_refs_one()
 2018-02-06  0:06 UTC  (2+ messages)

[GIT PULL] libnvdimm for 4.16
 2018-02-06  0:07 UTC  (3+ messages)

[PATCH 0/4] tree-wide: fix comparison to bitshift when dealing with a mask
 2018-02-06  0:06 UTC  (4+ messages)
  ` [PATCH 2/4] drm/exynos: "

[PATCH] [v2] drm/exynos: g2d: use monotonic timestamps
 2018-02-06  0:05 UTC  (3+ messages)

[PATCH 1/2] Revert "eal: fix default mempool ops"
 2018-02-06  0:05 UTC  (4+ messages)
` [PATCH FIX-OPTION-1] mbuf: fix the logic of user mempool ops API

[virtio] [PATCH v6 0/5] packed ring layout spec
 2018-02-06  0:05 UTC  (4+ messages)
` [virtio] [PATCH v7 01/11] content: move 1.0 queue format out to a separate section

[master][PATCH] linux-ti-staging: support multiple kernel packages with KERNEL_PACKAGE_NAME
 2018-02-06  0:04 UTC 

[Buildroot] [RFCv3 00/15] Per-package host/target directory support
 2018-02-06  0:00 UTC  (5+ messages)
` [Buildroot] [RFCv3 13/15] core: change host RPATH handling

[PATCH 4.15 00/60] 4.15.2-stable review
 2018-02-05 23:58 UTC  (2+ messages)

[PATCH v9 0/3] arm: npcm: add basic support for Nuvoton BMCs
 2018-02-05 23:57 UTC  (5+ messages)
` [PATCH v9 1/3] "
` [PATCH v9 2/3] arm: dts: add Nuvoton NPCM750 device tree
` [PATCH v9 3/3] MAINTAINERS: Add entry for the Nuvoton NPCM architecture

[PATCH v3] drm/i915/cnl: WaPipeControlBefore3DStateSamplePattern
 2018-02-05 23:58 UTC  (2+ messages)
` ✓ Fi.CI.BAT: success for drm/i915/cnl: WaPipeControlBefore3DStateSamplePattern (rev3)


This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.