All of lore.kernel.org
 help / color / mirror / Atom feed
 messages from 2018-03-12 02:29:13 to 2018-03-12 03:27:05 UTC [more...]

[PATCH 3.2 000/104] 3.2.101-rc1 review
 2018-03-12  3:03 UTC  (72+ messages)
` [PATCH 3.2 029/104] x86, alternative: Add header guards to <asm/alternative-asm.h>
` [PATCH 3.2 062/104] x86/retpoline/hyperv: Convert assembler indirect jumps
` [PATCH 3.2 090/104] x86/spectre: Fix spelling mistake: "vunerable"-> "vulnerable"
` [PATCH 3.2 092/104] x86/kvm: Update spectre-v1 mitigation
` [PATCH 3.2 040/104] x86/cpufeatures: Make CPU bugs sticky
` [PATCH 3.2 079/104] x86/bugs: Drop one "mitigation" from dmesg
` [PATCH 3.2 075/104] x86/retpoline: Fill RSB on context switch for affected CPUs
` [PATCH 3.2 068/104] x86/retpoline: Add LFENCE to the retpoline/RSB filling RSB macros
` [PATCH 3.2 088/104] vfs, fdtable: Prevent bounds-check bypass via speculative execution
` [PATCH 3.2 007/104] rtlwifi: rtl8192c: Fix W=1 warning
` [PATCH 3.2 036/104] x86/alternatives: Add missing '\n' at end of ALTERNATIVE inline asm
` [PATCH 3.2 024/104] [media] budget-av: only use t_state if initialized
` [PATCH 3.2 073/104] x86/retpoline: Optimize inline assembler for vmexit_fill_RSB
` [PATCH 3.2 074/104] x86/cpu/intel: Introduce macros for Intel family numbers
  ` [3.2,074/104] "
` [PATCH 3.2 087/104] x86/syscall: Sanitize syscall table de-references under speculation
` [PATCH 3.2 021/104] modpost: don't emit section mismatch warnings for compiler optimizations
` [PATCH 3.2 057/104] x86/asm: Use register variable to get stack pointer value
` [PATCH 3.2 011/104] Removed unused typedef to avoid "unused local typedef" warnings
` [PATCH 3.2 089/104] x86/spectre: Report get_user mitigation for spectre_v1
` [PATCH 3.2 097/104] x86/spectre: Fix an error message
` [PATCH 3.2 100/104] nospec: Include <asm/barrier.h> dependency
` [PATCH 3.2 102/104] x86/uaccess: Use __uaccess_begin_nospec() and uaccess_try_nospec
` [PATCH 3.2 078/104] x86/nospec: Fix header guards names
` [PATCH 3.2 101/104] x86: Introduce __uaccess_begin_nospec() and uaccess_try_nospec
` [PATCH 3.2 043/104] x86/pti: Rename BUG_CPU_INSECURE to BUG_CPU_MELTDOWN
` [PATCH 3.2 037/104] kvm: vmx: Scrub hardware GPRs at VM-exit
` [PATCH 3.2 041/104] x86/cpufeatures: Add X86_BUG_CPU_INSECURE
` [PATCH 3.2 034/104] bitops: Introduce BIT_ULL
` [PATCH 3.2 065/104] x86/retpoline/irq32: Convert assembler indirect jumps
` [PATCH 3.2 067/104] x86/retpoline: Remove compile time warning
` [PATCH 3.2 061/104] x86/retpoline/ftrace: Convert ftrace assembler indirect jumps
` [PATCH 3.2 022/104] fs: namespace: suppress 'may be used uninitialized' warnings
` [PATCH 3.2 038/104] x86/Documentation: Add PTI description
` [PATCH 3.2 030/104] KVM: VMX: Make use of asm.h
` [PATCH 3.2 044/104] x86/cpufeatures: Add X86_BUG_SPECTRE_V[12]
` [PATCH 3.2 063/104] x86/retpoline/xen: Convert Xen hypercall indirect jumps
` [PATCH 3.2 084/104] x86: Implement array_index_mask_nospec
` [PATCH 3.2 085/104] x86: Introduce barrier_nospec
` [PATCH 3.2 099/104] nospec: Kill array_index_nospec_mask_check()
` [PATCH 3.2 082/104] Documentation: Document array_index_nospec
` [PATCH 3.2 059/104] x86/spectre: Add boot time option to select Spectre v2 mitigation
` [PATCH 3.2 025/104] atp: remove set_rx_mode_8012()
` [PATCH 3.2 047/104] x86/cpu: Implement CPU vulnerabilites sysfs functions
` [PATCH 3.2 083/104] array_index_nospec: Sanitize speculative array de-references
` [PATCH 3.2 053/104] x86/cpu/AMD: Make LFENCE a serializing instruction
` [PATCH 3.2 010/104] rtlwifi: initialize local array and set value
` [PATCH 3.2 069/104] retpoline: Introduce start/end markers of indirect thunk
` [PATCH 3.2 060/104] x86/retpoline/entry: Convert entry assembler indirect jumps
` [PATCH 3.2 058/104] x86/retpoline: Add initial retpoline support
` [PATCH 3.2 006/104] Turn off -Wmaybe-uninitialized when building with -Os
` [PATCH 3.2 026/104] staging/wlan-ng: Fix 'Branch condition evaluates to a garbage value' in p80211netdev.c
` [PATCH 3.2 076/104] x86/retpoline: Remove the esp/rsp thunk
` [PATCH 3.2 064/104] x86/retpoline/checksum32: Convert assembler indirect jumps
` [PATCH 3.2 054/104] x86/cpu/AMD: Use LFENCE_RDTSC in preference to MFENCE_RDTSC
` [PATCH 3.2 023/104] [media] max2165: trival fix for some -Wuninitialized warning
` [PATCH 3.2 052/104] x86/alternatives: Fix optimize_nops() checking
` [PATCH 3.2 019/104] ath6kl: fix struct hif_scatter_req list handling
` [PATCH 3.2 071/104] kprobes/x86: Disable optimizing on the function jumps to indirect thunk
` [PATCH 3.2 103/104] x86: fix build warnign with 32-bit PAE
` [PATCH 3.2 070/104] kprobes/x86: Blacklist indirect thunk functions for kprobes
` [PATCH 3.2 046/104] sysfs/cpu: Add vulnerability folder
` [PATCH 3.2 096/104] x86/cpufeatures: Clean up Spectre v2 related CPUID flags
` [PATCH 3.2 077/104] module/retpoline: Warn about missing retpoline in module
` [PATCH 3.2 086/104] x86/get_user: Use pointer masking to limit speculation
` [PATCH 3.2 028/104] x86/bitops: Move BIT_64() for a wider use
` [PATCH 3.2 020/104] modpost: reduce visibility of symbols and constify r/o arrays
` [PATCH 3.2 066/104] x86/retpoline: Fill return stack buffer on vmexit
` [PATCH 3.2 091/104] x86/paravirt: Remove 'noreplace-paravirt' cmdline option

[MPTCP] [RFC] MPTCP Path Management Generic Netlink API
 2018-03-12  3:25 UTC 

[lkp-robot] [mm] b8d8bbead3: [No primary change] vm-scalability.free_time -9.8%
 2018-03-12  3:24 UTC 

[PATCH v2 00/20] btrfs-progs: qgroups usability
 2018-03-12  3:24 UTC  (4+ messages)
` [PATCH 13/20] btrfs-progs: use cmd_struct as command entry point

[PATCH] fix misspelling in the example of container_of
 2018-03-12  3:24 UTC 

[PATCH 0/4] allow procinfo and pdump on eth vdev
 2018-03-12  3:22 UTC  (4+ messages)
` [PATCH 2/4] bus/vdev: bus scan by multi-process channel

[Qemu-devel] [Bug 1703506] [NEW] SMT not supported by QEMU on AMD Ryzen CPU
 2018-03-12  3:05 UTC  (2+ messages)
` [Qemu-devel] [Bug 1703506] "

why add the result of check_type in container_of
 2018-03-12  3:19 UTC 

hello
 2018-03-12  3:19 UTC 

[PATCH v2 0/7] kexec_file, x86, powerpc: refactoring for other architecutres
 2018-03-12  3:18 UTC  (11+ messages)

[PATCH 3.16 00/76] 3.16.56-rc1 review
 2018-03-12  3:06 UTC  (75+ messages)
` [PATCH 3.16 75/76] x86/uaccess: Use __uaccess_begin_nospec() and uaccess_try_nospec
` [PATCH 3.16 64/76] x86/spectre: Simplify spectre_v2 command line parsing
` [PATCH 3.16 73/76] x86: Introduce __uaccess_begin_nospec() and uaccess_try_nospec
` [PATCH 3.16 33/76] x86/retpoline: Remove compile time warning
` [PATCH 3.16 14/76] x86/alternatives: Fix ALTERNATIVE_2 padding generation properly
` [PATCH 3.16 60/76] x86/spectre: Fix spelling mistake: "vunerable"-> "vulnerable"
` [PATCH 3.16 35/76] retpoline: Introduce start/end markers of indirect thunk
` [PATCH 3.16 15/76] x86/alternatives: Make optimize_nops() interrupt safe and synced
` [PATCH 3.16 76/76] x86: fix build warnign with 32-bit PAE
` [PATCH 3.16 62/76] x86/kvm: Update spectre-v1 mitigation
` [PATCH 3.16 43/76] x86/retpoline: Remove the esp/rsp thunk
` [PATCH 3.16 40/76] x86/cpu/intel: Introduce macros for Intel family numbers
  ` [3.16,40/76] "
` [PATCH 3.16 36/76] kprobes/x86: Blacklist indirect thunk functions for kprobes
` [PATCH 3.16 16/76] x86/alternatives: Fix optimize_nops() checking
` [PATCH 3.16 22/76] x86/asm: Use register variable to get stack pointer value
` [PATCH 3.16 01/76] kvm: vmx: Scrub hardware GPRs at VM-exit
` [PATCH 3.16 59/76] x86/spectre: Report get_user mitigation for spectre_v1
` [PATCH 3.16 28/76] x86/retpoline/hyperv: Convert assembler indirect jumps
` [PATCH 3.16 55/76] x86/get_user: Use pointer masking to limit speculation
` [PATCH 3.16 12/76] sysfs/cpu: Fix typos in vulnerability documentation
` [PATCH 3.16 71/76] x86: reorganize SMAP handling in user space accesses
` [PATCH 3.16 30/76] x86/retpoline/checksum32: Convert assembler indirect jumps
` [PATCH 3.16 04/76] x86/cpufeatures: Make CPU bugs sticky
` [PATCH 3.16 08/76] x86/cpufeatures: Add X86_BUG_SPECTRE_V[12]
` [PATCH 3.16 26/76] x86/retpoline/entry: Convert entry assembler indirect jumps
` [PATCH 3.16 45/76] KVM: VMX: Make indirect call speculation safe
` [PATCH 3.16 72/76] x86: fix SMAP in 32-bit environments
` [PATCH 3.16 13/76] x86/alternatives: Guard NOPs optimization
` [PATCH 3.16 23/76] x86/retpoline: Add initial retpoline support
` [PATCH 3.16 47/76] x86/nospec: Fix header guards names
` [PATCH 3.16 29/76] x86/retpoline/xen: Convert Xen hypercall indirect jumps
` [PATCH 3.16 39/76] x86/retpoline: Optimize inline assembler for vmexit_fill_RSB
` [PATCH 3.16 48/76] x86/bugs: Drop one "mitigation" from dmesg
` [PATCH 3.16 66/76] x86/cpufeatures: Clean up Spectre v2 related CPUID flags
` [PATCH 3.16 11/76] x86/cpu: Implement CPU vulnerabilites sysfs functions
` [PATCH 3.16 09/76] x86/cpu: Merge bugs.c and bugs_64.c
` [PATCH 3.16 03/76] x86/cpu: Factor out application of forced CPU caps
` [PATCH 3.16 18/76] x86/cpu/AMD: Use LFENCE_RDTSC in preference to MFENCE_RDTSC
` [PATCH 3.16 44/76] KVM: x86: Make indirect calls in emulator speculation safe
` [PATCH 3.16 37/76] kprobes/x86: Disable optimizing on the function jumps to indirect thunk
` [PATCH 3.16 67/76] x86/spectre: Fix an error message
` [PATCH 3.16 10/76] sysfs/cpu: Add vulnerability folder
` [PATCH 3.16 69/76] nospec: Kill array_index_nospec_mask_check()
` [PATCH 3.16 58/76] nl80211: Sanitize array index in parse_txq_params
` [PATCH 3.16 53/76] x86: Implement array_index_mask_nospec
` [PATCH 3.16 24/76] x86/spectre: Add boot time option to select Spectre v2 mitigation
` [PATCH 3.16 31/76] x86/retpoline/irq32: Convert assembler indirect jumps
` [PATCH 3.16 70/76] nospec: Include <asm/barrier.h> dependency
` [PATCH 3.16 46/76] module/retpoline: Warn about missing retpoline in module
` [PATCH 3.16 68/76] nospec: Move array_index_nospec() parameter checking into separate macro
` [PATCH 3.16 52/76] array_index_nospec: Sanitize speculative array de-references
` [PATCH 3.16 06/76] x86/cpu, x86/pti: Do not enable PTI on AMD processors
` [PATCH 3.16 27/76] x86/retpoline/ftrace: Convert ftrace assembler indirect jumps
` [PATCH 3.16 34/76] x86/retpoline: Add LFENCE to the retpoline/RSB filling RSB macros
` [PATCH 3.16 17/76] x86/cpu/AMD: Make LFENCE a serializing instruction
` [PATCH 3.16 05/76] x86/cpufeatures: Add X86_BUG_CPU_INSECURE
` [PATCH 3.16 61/76] x86/paravirt: Remove 'noreplace-paravirt' cmdline option
` [PATCH 3.16 02/76] x86/Documentation: Add PTI description
` [PATCH 3.16 07/76] x86/pti: Rename BUG_CPU_INSECURE to BUG_CPU_MELTDOWN
` [PATCH 3.16 57/76] vfs, fdtable: Prevent bounds-check bypass via speculative execution
` [PATCH 3.16 42/76] x86/cpu: Change type of x86_cache_size variable to unsigned int
` [PATCH 3.16 25/76] x86/retpoline/crypto: Convert crypto assembler indirect jumps
` [PATCH 3.16 54/76] x86: Introduce barrier_nospec
` [PATCH 3.16 51/76] Documentation: Document array_index_nospec
` [PATCH 3.16 74/76] x86/usercopy: Replace open coded stac/clac with __uaccess_{begin, end}
` [PATCH 3.16 49/76] x86/cpu/bugs: Make retpoline module warning conditional
` [PATCH 3.16 41/76] x86/retpoline: Fill RSB on context switch for affected CPUs
` [PATCH 3.16 56/76] x86/syscall: Sanitize syscall table de-references under speculation
` [PATCH 3.16 65/76] x86/speculation: Fix typo IBRS_ATT, which should be IBRS_ALL
` [PATCH 3.16 32/76] x86/retpoline: Fill return stack buffer on vmexit
` [PATCH 3.16 63/76] x86/retpoline: Avoid retpolines for built-in __init functions

[PATCH v2] doc: add driver limitation for vhost dequeue zero copy
 2018-03-12  3:15 UTC  (3+ messages)
` [PATCH v3] "

[PATCH] scsi: eata: drop VLA in reorder()
 2018-03-12  3:08 UTC  (3+ messages)

[PATCH v12 0/6] Address error and recovery for AER and DPC
 2018-03-12  3:03 UTC  (3+ messages)

[PATCH] macintosh/adb: Use C99 initializers for struct adb_driver instances
 2018-03-12  3:01 UTC 

Possible memory leak in acpi_ut_create_internal_object_dbg() in 4.16-rcX
 2018-03-12  2:58 UTC 

[PATCH v4 0/7] unsafe big.LITTLE support
 2018-03-12  2:57 UTC  (13+ messages)

[PATCH 0/4 net-next] ibmvnic: Fix VLAN and other device errata
 2018-03-12  2:56 UTC  (3+ messages)
` [PATCH 3/4 net-next] ibmvnic: Pad small packets to minimum MTU size

[PATCH] drm/amdgpu: Move IH clientid defs to separate file
 2018-03-12  2:55 UTC  (2+ messages)

[PATCH net-next 00/12] fix some bugs for HNS3 driver
 2018-03-12  2:54 UTC  (2+ messages)

[PATCH] vdev: fix name comparison in find_vdev
 2018-03-12  2:51 UTC  (2+ messages)

[PATCH net v2] openvswitch: meter: fix the incorrect calculation of max delta_t
 2018-03-12  2:50 UTC  (2+ messages)

[PATCH net v4 0/2] rhashtable: Fix rhltable duplicates insertion
 2018-03-12  2:48 UTC  (4+ messages)

Where is the __per_cpu_offset array initialized??
 2018-03-12  2:48 UTC  (3+ messages)

[PATCH net] macvlan: filter out unsupported feature flags
 2018-03-12  2:46 UTC  (2+ messages)

[PATCH net-next 0/4] selftests: forwarding: Tweaks and a new test
 2018-03-12  2:44 UTC  (2+ messages)

[PATCH 0/7] ARM: hacks for link-time optimization
 2018-03-12  2:40 UTC  (4+ messages)
` [PATCH 1/7] ARM: disallow combining XIP and LTO

[PATCH 4.13 00/43] 4.13.11-stable review
 2018-03-12  2:37 UTC  (13+ messages)
` [PATCH 4.13 28/43] SMB3: Validate negotiate request must always be signed

[RFC PATCH] KVM: arm/arm64: vgic: change condition for level interrupt resampling
 2018-03-12  2:33 UTC  (11+ messages)

[Buildroot] [PATCH 1/2] linux: bump default to version 4.15.9
 2018-03-12  2:30 UTC  (2+ messages)
` [Buildroot] [PATCH 2/2] linux-headers: bump 4.{4, 9, 14, 15}.x series

[PATCH v3 00/36] object_id part 12
 2018-03-12  2:27 UTC  (18+ messages)
` [PATCH v3 02/36] builtin/write-tree: convert to struct object_id
` [PATCH v3 05/36] resolve-undo: convert struct resolve_undo_info to object_id
` [PATCH v3 09/36] wt-status: convert struct wt_status_state "
` [PATCH v3 10/36] Convert find_unique_abbrev* to struct object_id
` [PATCH v3 11/36] http-walker: convert struct object_request to use "
` [PATCH v3 12/36] send-pack: convert remaining functions to "
` [PATCH v3 14/36] builtin/mktag: convert "
` [PATCH v3 15/36] archive: convert write_archive_entry_fn_t to object_id
` [PATCH v3 17/36] builtin/index-pack: convert struct ref_delta_entry "
` [PATCH v3 18/36] sha1_file: convert read_loose_object to use struct object_id
` [PATCH v3 19/36] sha1_file: convert check_sha1_signature to "
` [PATCH v3 21/36] builtin/mktree: convert "
` [PATCH v3 24/36] packfile: convert unpack_entry "
` [PATCH v3 29/36] tree-walk: convert get_tree_entry_follow_symlinks internals to object_id
` [PATCH v3 31/36] tree-walk: convert tree entry functions "
` [PATCH v3 32/36] sha1_file: convert read_object_with_reference "
` [PATCH v3 35/36] sha1_file: introduce a constant for max header length


This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.