All of lore.kernel.org
 help / color / mirror / Atom feed
 messages from 2021-04-30 05:53:08 to 2021-04-30 06:14:12 UTC [more...]

[PATCH v4 00/12] qtests: Check accelerator available at runtime via QMP 'query-accels'
 2021-04-30  6:13 UTC  (7+ messages)
` [PATCH v4 10/12] qtest/qmp-cmd-test: Make test build-independent from accelerator

[GIT PULL] iomap: new code for 5.13-rc1
 2021-04-30  6:13 UTC  (12+ messages)

[PATCH v1 1/2] caam: imx8m: fix the built-in caam driver cannot match soc_id
 2021-04-30  6:10 UTC  (3+ messages)

[PATCH 000/190] Revertion of all of the umn.edu commits
 2021-04-30  6:10 UTC  (4+ messages)
` [PATCH 134/190] Revert "md: Fix failed allocation of md_register_thread"

[PATCH 0/3] fnic: use scsi_host_busy_iter() to traverse commands
 2021-04-30  6:10 UTC  (3+ messages)
` [PATCH 1/3] fnic: kill 'exclude_id' argument to fnic_cleanup_io()

[PATCH v7] media: imx208: Add imx208 camera sensor driver
 2021-04-30 14:05 UTC 

drivers/net/ethernet/korina.c:408:33: sparse: sparse: incorrect type in argument 2 (different address spaces)
 2021-04-30  6:09 UTC  (2+ messages)

[GIT PULL FOR v5.14] MPEG-2 stateless API cleanup and destaging
 2021-04-30  6:09 UTC 

[PATCH] platform/x86: hp_accel: Avoid invoking _INI to speed up resume
 2021-04-30  6:07 UTC 

[dpdk-dev] [PATCH-V4] config/arm: restore support for Qualcomm servers
 2021-04-30  6:07 UTC  (3+ messages)
` [dpdk-dev] [PATCH-V5] "

[PATCH 0/2] clarify and cleanup CPU and NUMA topology ABIs
 2021-04-30  6:05 UTC  (8+ messages)
` [PATCH 1/2] CPU, NUMA topology ABIs: clarify the overflow issue of sysfs pagebuf

[Buildroot] [PATCH 1/1] package/bullet: fix build
 2021-04-30  6:05 UTC 

[xlnx:pr/142 11850/12170] drivers/regulator/da9121-regulator.c:748:3: error: implicit declaration of function 'regulator_lock'
 2021-04-30  6:01 UTC  (2+ messages)

[PATCH v2] kbuild: replace LANG=C with LC_ALL=C
 2021-04-30  6:02 UTC  (3+ messages)

[PATCH 0/8] refs: cleanup errno sideband ref related functions
 2021-04-30  6:02 UTC  (4+ messages)
` [PATCH 3/8] refs: make errno output explicit for read_raw_ref_fn

incoming
 2021-04-30  6:02 UTC  (179+ messages)
` [patch 001/178] arch/ia64/kernel/head.S: remove duplicate include
` [patch 002/178] arch/ia64/kernel/fsys.S: fix typos
` [patch 003/178] arch/ia64/include/asm/pgtable.h: minor typo fixes
` [patch 004/178] ia64: ensure proper NUMA distance and possible map initialization
` [patch 005/178] ia64: drop unused IA64_FW_EMU ifdef
` [patch 006/178] ia64: simplify code flow around swiotlb init
` [patch 007/178] ia64: trivial spelling fixes
` [patch 008/178] ia64: fix EFI_DEBUG build
` [patch 009/178] ia64: mca: always make IA64_MCA_DEBUG an expression
` [patch 010/178] ia64: drop marked broken DISCONTIGMEM and VIRTUAL_MEM_MAP
` [patch 011/178] ia64: module: fix symbolizer crash on fdescr
` [patch 012/178] include/linux/compiler-gcc.h: sparse can do constant folding of __builtin_bswap*()
` [patch 013/178] scripts/spelling.txt: add entries for recent discoveries
` [patch 014/178] scripts: a new script for checking duplicate struct declaration
` [patch 015/178] arch/sh/include/asm/tlb.h: remove duplicate include
` [patch 016/178] ocfs2: replace DEFINE_SIMPLE_ATTRIBUTE with DEFINE_DEBUGFS_ATTRIBUTE
` [patch 017/178] ocfs2: map flags directly in flags_to_o2dlm()
` [patch 018/178] ocfs2: fix a typo
` [patch 019/178] ocfs2/dlm: remove unused function
` [patch 020/178] kfifo: fix ternary sign extension bugs
` [patch 021/178] vfs: fs_parser: clean up kernel-doc warnings
` [patch 022/178] watchdog: rename __touch_watchdog() to a better descriptive name
` [patch 023/178] watchdog: explicitly update timestamp when reporting softlockup
` [patch 024/178] watchdog/softlockup: report the overall time of softlockups
` [patch 025/178] watchdog/softlockup: remove logic that tried to prevent repeated reports
` [patch 026/178] watchdog: fix barriers when printing backtraces from all CPUs
` [patch 027/178] watchdog: cleanup handling of false positives
` [patch 028/178] mm/slab_common: provide "slab_merge" option for !IS_ENABLED(CONFIG_SLAB_MERGE_DEFAULT) builds
` [patch 029/178] mm, slub: enable slub_debug static key when creating cache with explicit debug flags
` [patch 030/178] kunit: add a KUnit test for SLUB debugging functionality
` [patch 031/178] slub: remove resiliency_test() function
` [patch 032/178] mm/slub.c: trivial typo fixes
` [patch 033/178] mm/kmemleak.c: fix a typo
` [patch 034/178] mm/page_owner: record the timestamp of all pages during free
` [patch 035/178] mm, page_owner: remove unused parameter in __set_page_owner_handle
` [patch 036/178] mm: page_owner: fetch backtrace only for tracked pages
` [patch 037/178] mm: page_owner: use kstrtobool() to parse bool option
` [patch 038/178] mm: page_owner: detect page_owner recursion via task_struct
` [patch 039/178] mm: page_poison: print page info when corruption is caught
` [patch 040/178] mm/memtest: add ARCH_USE_MEMTEST
` [patch 041/178] mm: provide filemap_range_needs_writeback() helper
` [patch 042/178] mm: use filemap_range_needs_writeback() for O_DIRECT reads
` [patch 043/178] iomap: "
` [patch 044/178] mm/filemap: use filemap_read_page in filemap_fault
` [patch 045/178] mm/filemap: drop check for truncated page after I/O
` [patch 046/178] mm: page-writeback: simplify memcg handling in test_clear_page_writeback()
` [patch 047/178] mm: move page_mapping_file to pagemap.h
` [patch 048/178] mm/filemap: update stale comment
` [patch 049/178] mm/msync: exit early when the flags is an MS_ASYNC and start < vm_start
` [patch 050/178] mm/gup: add compound page list iterator
` [patch 051/178] mm/gup: decrement head page once for group of subpages
` [patch 052/178] mm/gup: add a range variant of unpin_user_pages_dirty_lock()
` [patch 053/178] RDMA/umem: batch page unpin in __ib_umem_release()
` [patch 054/178] mm: gup: remove FOLL_SPLIT
` [patch 055/178] mm/memremap.c: fix improper SPDX comment style
` [patch 056/178] mm: memcontrol: fix kernel stack account
` [patch 057/178] memcg: cleanup root memcg checks
` [patch 058/178] memcg: enable memcg oom-kill for __GFP_NOFAIL
` [patch 059/178] mm: memcontrol: fix cpuhotplug statistics flushing
` [patch 060/178] mm: memcontrol: kill mem_cgroup_nodeinfo()
` [patch 061/178] mm: memcontrol: privatize memcg_page_state query functions
` [patch 062/178] cgroup: rstat: support cgroup1
` [patch 063/178] cgroup: rstat: punt root-level optimization to individual controllers
` [patch 064/178] mm: memcontrol: switch to rstat
` [patch 065/178] mm: memcontrol: consolidate lruvec stat flushing
` [patch 066/178] kselftests: cgroup: update kmem test for new vmstat implementation
` [patch 067/178] memcg: charge before adding to swapcache on swapin
` [patch 068/178] mm: memcontrol: slab: fix obtain a reference to a freeing memcg
` [patch 069/178] mm: memcontrol: introduce obj_cgroup_{un}charge_pages
` [patch 070/178] mm: memcontrol: directly access page->memcg_data in mm/page_alloc.c
` [patch 071/178] mm: memcontrol: change ug->dummy_page only if memcg changed
` [patch 072/178] mm: memcontrol: use obj_cgroup APIs to charge kmem pages
` [patch 073/178] mm: memcontrol: inline __memcg_kmem_{un}charge() into obj_cgroup_{un}charge_pages()
` [patch 074/178] mm: memcontrol: move PageMemcgKmem to the scope of CONFIG_MEMCG_KMEM
` [patch 075/178] linux/memcontrol.h: remove duplicate struct declaration
` [patch 076/178] mm: page_counter: mitigate consequences of a page_counter underflow
` [patch 077/178] mm/memory.c: do_numa_page(): delete bool "migrated"
` [patch 078/178] mm/interval_tree: add comments to improve code readability
` [patch 079/178] x86/vmemmap: drop handling of 4K unaligned vmemmap range
` [patch 080/178] x86/vmemmap: drop handling of 1GB vmemmap ranges
` [patch 081/178] x86/vmemmap: handle unpopulated sub-pmd ranges
` [patch 082/178] x86/vmemmap: optimize for consecutive sections in partial populated PMDs
` [patch 083/178] mm, tracing: improve rss_stat tracepoint message
` [patch 084/178] mm: add remap_pfn_range_notrack
` [patch 085/178] mm: add a io_mapping_map_user helper
` [patch 086/178] i915: use io_mapping_map_user
` [patch 087/178] i915: fix remap_io_sg to verify the pgprot
` [patch 088/178] NUMA balancing: reduce TLB flush via delaying mapping on hint page fault
` [patch 089/178] mm: extend MREMAP_DONTUNMAP to non-anonymous mappings
` [patch 090/178] Revert "mremap: don't allow MREMAP_DONTUNMAP on special_mappings and aio"
` [patch 091/178] selftests: add a MREMAP_DONTUNMAP selftest for shmem
` [patch 092/178] mm/dmapool: switch from strlcpy to strscpy
` [patch 093/178] mm/sparse: add the missing sparse_buffer_fini() in error branch
` [patch 094/178] samples/vfio-mdev/mdpy: use remap_vmalloc_range
` [patch 095/178] mm: unexport remap_vmalloc_range_partial
` [patch 096/178] mm/vmalloc: use rb_tree instead of list for vread() lookups
` [patch 097/178] ARM: mm: add missing pud_page define to 2-level page tables
` [patch 098/178] mm/vmalloc: fix HUGE_VMAP regression by enabling huge pages in vmalloc_to_page
` [patch 099/178] mm: apply_to_pte_range warn and fail if a large pte is encountered
` [patch 100/178] mm/vmalloc: rename vmap_*_range vmap_pages_*_range
` [patch 101/178] mm/ioremap: rename ioremap_*_range to vmap_*_range
` [patch 102/178] mm: HUGE_VMAP arch support cleanup
` [patch 103/178] powerpc: inline huge vmap supported functions
` [patch 104/178] arm64: "
` [patch 105/178] x86: "
` [patch 106/178] mm/vmalloc: provide fallback arch huge vmap support functions
` [patch 107/178] mm: move vmap_range from mm/ioremap.c to mm/vmalloc.c
` [patch 108/178] mm/vmalloc: add vmap_range_noflush variant
` [patch 109/178] mm/vmalloc: hugepage vmalloc mappings
` [patch 110/178] mm/vmalloc: remove map_kernel_range
` [patch 111/178] kernel/dma: remove unnecessary unmap_kernel_range
` [patch 112/178] powerpc/xive: "
` [patch 113/178] mm/vmalloc: remove unmap_kernel_range
` [patch 114/178] mm/vmalloc: improve allocation failure error messages
` [patch 115/178] mm: vmalloc: prevent use after free in _vm_unmap_aliases
` [patch 116/178] lib/test_vmalloc.c: remove two kvfree_rcu() tests
` [patch 117/178] lib/test_vmalloc.c: add a new 'nr_threads' parameter
` [patch 118/178] vm/test_vmalloc.sh: adapt for updated driver interface
` [patch 119/178] mm/vmalloc: refactor the preloading loagic
` [patch 120/178] mm/vmalloc: remove an empty line
` [patch 121/178] mm/doc: fix fault_flag_allow_retry_first kerneldoc
` [patch 122/178] mm/doc: fix page_maybe_dma_pinned kerneldoc
` [patch 123/178] mm/doc: turn fault flags into an enum
` [patch 124/178] mm/doc: add mm.h and mm_types.h to the mm-api document
` [patch 125/178] MAINTAINERS: assign pagewalk.h to MEMORY MANAGEMENT
` [patch 126/178] pagewalk: prefix struct kernel-doc descriptions
` [patch 127/178] mm/kasan: switch from strlcpy to strscpy
` [patch 128/178] kasan: fix kasan_byte_accessible() to be consistent with actual checks
` [patch 129/178] kasan: initialize shadow to TAG_INVALID for SW_TAGS
` [patch 130/178] mm, kasan: don't poison boot memory with tag-based modes
` [patch 131/178] arm64: kasan: allow to init memory when setting tags
` [patch 132/178] kasan: init memory in kasan_(un)poison for HW_TAGS
` [patch 133/178] kasan, mm: integrate page_alloc init with HW_TAGS
` [patch 134/178] kasan, mm: integrate slab init_on_alloc "
` [patch 135/178] kasan, mm: integrate slab init_on_free "
` [patch 136/178] kasan: docs: clean up sections
` [patch 137/178] kasan: docs: update overview section
` [patch 138/178] kasan: docs: update usage section
` [patch 139/178] kasan: docs: update error reports section
` [patch 140/178] kasan: docs: update boot parameters section
` [patch 141/178] kasan: docs: update GENERIC implementation details section
` [patch 142/178] kasan: docs: update SW_TAGS "
` [patch 143/178] kasan: docs: update HW_TAGS "
` [patch 144/178] kasan: docs: update shadow memory section
` [patch 145/178] kasan: docs: update ignoring accesses section
` [patch 146/178] kasan: docs: update tests section
` [patch 147/178] kasan: record task_work_add() call stack
` [patch 148/178] kasan: detect false-positives in tests
` [patch 149/178] irq_work: record irq_work_queue() call stack
` [patch 150/178] mm: move mem_init_print_info() into mm_init()
` [patch 151/178] mm/page_alloc: drop pr_info_ratelimited() in alloc_contig_range()
` [patch 152/178] mm: remove lru_add_drain_all in alloc_contig_range
` [patch 153/178] include/linux/page-flags-layout.h: correctly determine LAST_CPUPID_WIDTH
` [patch 154/178] include/linux/page-flags-layout.h: cleanups
` [patch 155/178] mm/page_alloc: rename alloc_mask to alloc_gfp
` [patch 156/178] mm/page_alloc: rename gfp_mask to gfp
` [patch 157/178] mm/page_alloc: combine __alloc_pages and __alloc_pages_nodemask
` [patch 158/178] mm/mempolicy: rename alloc_pages_current to alloc_pages
` [patch 159/178] mm/mempolicy: rewrite alloc_pages documentation
` [patch 160/178] mm/mempolicy: rewrite alloc_pages_vma documentation
` [patch 161/178] mm/mempolicy: fix mpol_misplaced kernel-doc
` [patch 162/178] mm: page_alloc: dump migrate-failed pages
` [patch 163/178] mm/Kconfig: remove default DISCONTIGMEM_MANUAL
` [patch 164/178] mm, page_alloc: avoid page_to_pfn() in move_freepages()
` [patch 165/178] mm/page_alloc: duplicate include linux/vmalloc.h
` [patch 166/178] mm/page_alloc: rename alloced to allocated
` [patch 167/178] mm/page_alloc: add a bulk page allocator
` [patch 168/178] mm/page_alloc: add an array-based interface to the "
` [patch 169/178] mm/page_alloc: optimize code layout for __alloc_pages_bulk
` [patch 170/178] mm/page_alloc: inline __rmqueue_pcplist
` [patch 171/178] SUNRPC: set rq_page_end differently
` [patch 172/178] SUNRPC: refresh rq_pages using a bulk page allocator
` [patch 173/178] net: page_pool: refactor dma_map into own function page_pool_dma_map
` [patch 174/178] net: page_pool: use alloc_pages_bulk in refill code path
` [patch 175/178] mm: page_alloc: ignore init_on_free=1 for debug_pagealloc=1
` [patch 176/178] mm/page_alloc: redundant definition variables of pfn in for loop
` [patch 177/178] mm/mmzone.h: fix existing kernel-doc comments and link them to core-api
` [patch 178/178] mm/memory-failure: unnecessary amount of unmapping

[bug report] net/mlx5: E-Switch, Consider SF ports of host PF
 2021-04-30  6:02 UTC 

[RFC] mm/vmscan.c: avoid possible long latency caused by too_many_isolated()
 2021-04-30  5:57 UTC  (6+ messages)

[igt-dev] [PATCH i-g-t 0/3] lib/igt_fb: A few changes to fix test runs on ADL_P
 2021-04-30  5:53 UTC  (4+ messages)
` [igt-dev] [PATCH i-g-t 2/3] lib/igt_fb: Fix stride for render_copy based FB conversions


This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.