All of lore.kernel.org
 help / color / mirror / Atom feed
 messages from 2025-03-07 22:13:56 to 2025-03-07 23:19:37 UTC [more...]

[PATCH v6 0/6] drm/xe/xe_vm: Implement xe_vm_get_faults_ioctl
 2025-03-07 23:19 UTC  (8+ messages)
` [PATCH v6 1/6] drm/xe/xe_gt_pagefault: Disallow writes to read-only VMAs
` [PATCH v6 2/6] drm/xe/xe_gt_pagefault: Migrate pagefault struct to header
` [PATCH v6 3/6] drm/xe/xe_vm: Add per VM pagefault info
` [PATCH v6 4/6] drm/xe/uapi: Define drm_xe_vm_get_faults
` [PATCH v6 5/6] drm/xe/xe_gt_pagefault: Add address_type field to pagefaults
` [PATCH v6 6/6] drm/xe/xe_vm: Implement xe_vm_get_faults_ioctl

[PATCH i-g-t] tests/intel/xe_multi_tile: Multi-Tile support in IGT
 2025-03-07 23:19 UTC  (2+ messages)

[jfern:nova-core-experiments 192/411] drivers/gpu/drm/nouveau/nouveau_drm.c:824:1: warning: unused label 'fail_drm_dev_init'
 2025-03-07 23:17 UTC 

[PATCH v3 0/3] Add Armada8K reset controller support
 2025-03-07 23:15 UTC  (8+ messages)
` [PATCH v3 1/3] dt-bindings: reset: Add Armada8K reset controller
    ` [EXTERNAL] "

[PATCH v2] PCI: Fix typos
 2025-03-07 23:17 UTC 

[PATCH 0/2] Improve Zram by separating compression context from kswapd
 2025-03-07 23:14 UTC  (6+ messages)
` [PATCH 2/2] kcompressd: Add Kcompressd for accelerated zram compression

[PATCH v4 0/7] usb: dwc3: qcom: Flatten dwc3 structure
 2025-03-07 23:16 UTC  (9+ messages)
` [PATCH v4 5/7] usb: dwc3: qcom: Snapshot driver for backwards compatibilty

[PATCH] drm/xe/xe3: Recognize 3DSTATE_COARSE_PIXEL to LRC dumps
 2025-03-07 23:16 UTC  (7+ messages)
` ✓ CI.Patch_applied: success for "
` ✓ CI.checkpatch: "
` ✓ CI.KUnit: "
` ✓ CI.Build: "
` ✓ CI.Hooks: "
` ✓ CI.checksparse: "

[GIT PULL] s390 updates for 6.14-rc6
 2025-03-07 23:13 UTC 

[Buildroot] [PATCH] package/can-utils: bump to v2025.01
 2025-03-07 23:13 UTC  (3+ messages)

[PATCH 0/3] ubsan/overflow: Enable pattern exclusions
 2025-03-07 23:12 UTC  (3+ messages)
` [PATCH 2/3] "

[PATCH v4 0/3] mm/hwpoison: Fix regressions in memory failure handling
 2025-03-07 23:11 UTC  (6+ messages)
` [PATCH v4 1/3] x86/mce: Use is_copy_from_user() to determine copy-from-user context

[RFC PATCH resend] x86/boot: Drop CRC-32 checksum and the build tool that generates it
 2025-03-07 23:11 UTC  (2+ messages)
` [tip: x86/build] "

[PATCH] hardening: Enable i386 FORTIFY_SOURCE on Clang 16+
 2025-03-07 23:10 UTC  (5+ messages)

request_irq() with local bh disabled
 2025-03-07 23:08 UTC  (6+ messages)

[PATCH] cxl/fwctl: Cleanup unused fwctl_dev from cxl_features_state
 2025-03-07 23:10 UTC  (3+ messages)

[PATCH v2 1/1] x86/mm: Check if PTRS_PER_PMD is defined before use
 2025-03-07 23:09 UTC  (7+ messages)
` [tip: x86/mm] "
      ` [PATCH] x86/mm: Define PTRS_PER_PMD for assembly code too

[PATCH] dt-bindings: trivial-devices: Add Maxim max15301, max15303, and max20751
 2025-03-07 23:09 UTC 

[PATCH] dt-bindings: fsi: ibm,p9-scom: Add "ibm,fsi2pib" compatible
 2025-03-07 23:08 UTC 

[PATCH V1 0/4] skip memory init during CPR
 2025-03-07 23:08 UTC  (3+ messages)
` [PATCH V1 1/4] migration: cpr_is_incoming

[android-common:android16-6.12-desktop 0/3] mm/shmem.c:2361:1: warning: unused label 'alloced'
 2025-03-07 23:06 UTC 

[PATCH 00/57] docs: Add new QAPI transmogrifier
 2025-03-07 23:06 UTC  (22+ messages)
` [PATCH 11/57] docs/qapi-domain: add qapi:command directive
` [PATCH 12/57] docs/qapi-domain: add :since: directive option
` [PATCH 13/57] docs/qapi-domain: add "Arguments:" field lists
` [PATCH 15/57] docs/qapi-domain: add "Errors:" "
` [PATCH 16/57] docs/qapi-domain: add "Returns:" "
` [PATCH 18/57] docs/qapi-domain: add qapi:alternate directive
` [PATCH 19/57] docs/qapi-domain: add qapi:event directive

[PATCH bpf-next 1/2] bpf: add get_netns_cookie helper to tracing programs
 2025-03-07 23:06 UTC  (6+ messages)

[PATCH v2 0/4] Add managed SOFT RESERVE resource handling
 2025-03-07 23:05 UTC  (10+ messages)
` [PATCH v2 1/4] kernel/resource: Introduce managed SOFT RESERVED resources

[tip: x86/asm] x86/asm: Make ASM_CALL_CONSTRAINT conditional on frame pointers
 2025-03-07 23:05 UTC  (3+ messages)

[PATCH v3 0/4] platform/x86: Add Lenovo Gaming Series WMI Drivers
 2025-03-07 23:04 UTC  (5+ messages)
` [PATCH v3 2/4] platform/x86: Add Lenovo Gamezone WMI Driver
` [PATCH v3 3/4] platform/x86: Add Lenovo Capability Data 01 "

[PATCH 6.6] x86/mm: Don't disable PCID when INVLPG has been fixed by microcode
 2025-03-07 23:05 UTC 

[PATCH V2 00/12] KVM: TDX: TD vcpu enter/exit
 2025-03-07 23:04 UTC  (7+ messages)
` [PATCH V2 02/12] KVM: x86: Allow the use of kvm_load_host_xsave_state() with guest_state_protected

[PATCH 00/14] drm/i915: sagv/bw cleanup
 2025-03-07 23:04 UTC  (3+ messages)
` ✗ Fi.CI.CHECKPATCH: warning for drm/i915: sagv/bw cleanup (rev2)
` ✗ Fi.CI.SPARSE: "

[patch V2 00/17] posix-timers: Rework the global hash table and provide a sane mechanism for CRIU
 2025-03-07 23:03 UTC  (5+ messages)
` [patch V2 07/17] posix-timers: Simplify lock/unlock_timer()
` [patch V2 08/17] posix-timers: Rework timer removal

[PATCH 00/23] ARM split hardware and control domains
 2025-03-07 23:03 UTC  (9+ messages)
` [PATCH 04/23] xen/arm: dom0less use domid 0 for hwdom
` [PATCH 08/23] xen/arm: dom0less seed xenstore grant table entry

Thread Safety Analysis and the Linux kernel
 2025-03-07 23:03 UTC  (6+ messages)

[PATCH 0/3] power: supply: set_charged deadcode
 2025-03-07 23:02 UTC  (4+ messages)
` [PATCH 1/3] power: supply: core: Remove unused power_supply_set_battery_charged
` [PATCH 2/3] power: supply: ds2760: Remove unused ds2760_battery_set_charged
` [PATCH 3/3] power: supply: Remove unused set_charged method

[PATCH net-next] eth: fbnic: fix memory corruption in fbnic_tlv_attr_get_string()
 2025-03-07 22:59 UTC  (2+ messages)

[PATCH] fs: support filename refcount without atomics
 2025-03-07 22:58 UTC  (4+ messages)

[LTP] [PATCH] cpuset_memory_testset.sh: Give SIGUSR1 handler time to run before changing target mapping node in tests 12 and 13
 2025-03-07 22:58 UTC 

[PATCH RFC v3 0/7] drm/display: dp: add new DPCD access functions
 2025-03-07 22:57 UTC  (7+ messages)
` [PATCH RFC v3 1/7] drm/display: dp: implement new access helpers
` [PATCH RFC v3 2/7] drm/display: dp: change drm_dp_dpcd_read_link_status() return value
` [PATCH RFC v3 4/7] drm/display: dp-aux-dev: use new DCPD access helpers

[android-common:android16-6.12 3/3] mm/shmem.c:2361:1: warning: label 'alloced' defined but not used
 2025-03-07 22:56 UTC 

Apply 0c5928deada1 for 6.12.y and 6.13.y
 2025-03-07 22:54 UTC 

[PATCH] fs/pipe.c: merge if statements with identical conditions
 2025-03-07 22:54 UTC  (4+ messages)

[PATCH v3 0/8] refs: introduce support for partial reference transactions
 2025-03-07 22:54 UTC  (5+ messages)
` [PATCH v3 6/8] refs: implement partial reference transaction support
      ` [PATCH] config.mak.dev: enable -Wunreachable-code

[RFC PATCH 0/3] sched/numa: Introduce per cgroup numa balance control
 2025-03-07 22:54 UTC  (3+ messages)
` [RFC PATCH 2/3] "

[i-g-t,v3,0/2] tests/i915/pm_rc6_residency: Replace waitboost with
 2025-03-07 22:53 UTC  (3+ messages)
` ✓ Xe.CI.BAT: success for tests/i915/pm_rc6_residency: Replace waitboost with (rev5)
` ✗ i915.CI.BAT: failure "

[PATCH 6.12.y 00/60] `alloc`, `#[expect]` and "Custom FFI"
 2025-03-07 22:50 UTC  (61+ messages)
` [PATCH 6.12.y 01/60] rust: workqueue: remove unneeded ``#[allow(clippy::new_ret_no_self)]`
` [PATCH 6.12.y 02/60] rust: sort global Rust flags
` [PATCH 6.12.y 03/60] rust: types: avoid repetition in `{As,From}Bytes` impls
` [PATCH 6.12.y 04/60] rust: enable `clippy::undocumented_unsafe_blocks` lint
` [PATCH 6.12.y 05/60] rust: enable `clippy::unnecessary_safety_comment` lint
` [PATCH 6.12.y 06/60] rust: enable `clippy::unnecessary_safety_doc` lint
` [PATCH 6.12.y 07/60] rust: enable `clippy::ignored_unit_patterns` lint
` [PATCH 6.12.y 08/60] rust: enable `rustdoc::unescaped_backticks` lint
` [PATCH 6.12.y 09/60] rust: init: remove unneeded `#[allow(clippy::disallowed_names)]`
` [PATCH 6.12.y 10/60] rust: sync: remove unneeded `#[allow(clippy::non_send_fields_in_send_ty)]`
` [PATCH 6.12.y 11/60] rust: introduce `.clippy.toml`
` [PATCH 6.12.y 12/60] rust: replace `clippy::dbg_macro` with `disallowed_macros`
` [PATCH 6.12.y 13/60] rust: provide proper code documentation titles
` [PATCH 6.12.y 14/60] rust: enable Clippy's `check-private-items`
` [PATCH 6.12.y 15/60] Documentation: rust: add coding guidelines on lints
` [PATCH 6.12.y 16/60] rust: start using the `#[expect(...)]` attribute
` [PATCH 6.12.y 17/60] Documentation: rust: discuss `#[expect(...)]` in the guidelines
` [PATCH 6.12.y 18/60] rust: error: make conversion functions public
` [PATCH 6.12.y 19/60] rust: error: optimize error type to use nonzero
` [PATCH 6.12.y 20/60] rust: alloc: add `Allocator` trait
` [PATCH 6.12.y 21/60] rust: alloc: separate `aligned_size` from `krealloc_aligned`
` [PATCH 6.12.y 22/60] rust: alloc: rename `KernelAllocator` to `Kmalloc`
` [PATCH 6.12.y 23/60] rust: alloc: implement `ReallocFunc`
` [PATCH 6.12.y 24/60] rust: alloc: make `allocator` module public
` [PATCH 6.12.y 25/60] rust: alloc: implement `Allocator` for `Kmalloc`
` [PATCH 6.12.y 26/60] rust: alloc: add module `allocator_test`
` [PATCH 6.12.y 27/60] rust: alloc: implement `Vmalloc` allocator
` [PATCH 6.12.y 28/60] rust: alloc: implement `KVmalloc` allocator
` [PATCH 6.12.y 29/60] rust: alloc: add __GFP_NOWARN to `Flags`
` [PATCH 6.12.y 30/60] rust: alloc: implement kernel `Box`
` [PATCH 6.12.y 31/60] rust: treewide: switch to our kernel `Box` type
` [PATCH 6.12.y 32/60] rust: alloc: remove extension of std's `Box`
` [PATCH 6.12.y 33/60] rust: alloc: add `Box` to prelude
` [PATCH 6.12.y 34/60] rust: alloc: introduce `ArrayLayout`
` [PATCH 6.12.y 35/60] rust: alloc: implement kernel `Vec` type
` [PATCH 6.12.y 36/60] rust: alloc: implement `IntoIterator` for `Vec`
` [PATCH 6.12.y 37/60] rust: alloc: implement `collect` for `IntoIter`
` [PATCH 6.12.y 38/60] rust: treewide: switch to the kernel `Vec` type
` [PATCH 6.12.y 39/60] rust: alloc: remove `VecExt` extension
` [PATCH 6.12.y 40/60] rust: alloc: add `Vec` to prelude
` [PATCH 6.12.y 41/60] rust: error: use `core::alloc::LayoutError`
` [PATCH 6.12.y 42/60] rust: error: check for config `test` in `Error::name`
` [PATCH 6.12.y 43/60] rust: alloc: implement `contains` for `Flags`
` [PATCH 6.12.y 44/60] rust: alloc: implement `Cmalloc` in module allocator_test
` [PATCH 6.12.y 45/60] rust: str: test: replace `alloc::format`
` [PATCH 6.12.y 46/60] rust: alloc: update module comment of alloc.rs
` [PATCH 6.12.y 47/60] kbuild: rust: remove the `alloc` crate and `GlobalAlloc`
` [PATCH 6.12.y 48/60] MAINTAINERS: add entry for the Rust `alloc` module
` [PATCH 6.12.y 49/60] drm/panic: avoid reimplementing Iterator::find
` [PATCH 6.12.y 50/60] drm/panic: remove unnecessary borrow in alignment_pattern
` [PATCH 6.12.y 51/60] drm/panic: prefer eliding lifetimes
` [PATCH 6.12.y 52/60] drm/panic: remove redundant field when assigning value
` [PATCH 6.12.y 53/60] drm/panic: correctly indent continuation of line in list item
` [PATCH 6.12.y 54/60] drm/panic: allow verbose boolean for clarity
` [PATCH 6.12.y 55/60] drm/panic: allow verbose version check
` [PATCH 6.12.y 56/60] rust: kbuild: expand rusttest target for macros
` [PATCH 6.12.y 57/60] rust: fix size_t in bindgen prototypes of C builtins
` [PATCH 6.12.y 58/60] rust: map `__kernel_size_t` and friends also to usize/isize
` [PATCH 6.12.y 59/60] rust: use custom FFI integer types
` [PATCH 6.12.y 60/60] rust: alloc: Fix `ArrayLayout` allocations

[PATCH] fs/pipe.c: simplify tmp_page handling
 2025-03-07 22:51 UTC  (3+ messages)

[PATCH v7 0/5] Allow to enable multifd and postcopy migration together
 2025-03-07 22:51 UTC  (12+ messages)
` [PATCH v7 5/5] migration: add MULTIFD_RECV_SYNC migration command

[PATCH v2 00/10] target/i386/kvm/pmu: PMU Enhancement, Bugfix and Cleanup
 2025-03-07 22:49 UTC  (7+ messages)
` [PATCH v2 05/10] target/i386/kvm: extract unrelated code out of kvm_x86_build_cpuid()
` [PATCH v2 06/10] target/i386/kvm: rename architectural PMU variables

[PATCH] drm/dp_mst: Fix locking when skipping CSN before topology probing
 2025-03-07 22:49 UTC  (2+ messages)
` ✓ Xe.CI.BAT: success for "

[Intel-wired-lan] [PATCH iwl-next v5] ixgbe: add support for thermal sensor event reception
 2025-03-07 22:00 UTC  (2+ messages)

[cocci] behavior change in semantic patches since c36b51ffc889 ("don't drop down on single statement")
 2025-03-07 22:47 UTC  (4+ messages)
` [cocci] behavior change in semantic patches since c36b51ffc889 …

[PATCH v6 0/6] target/i386: Update EPYC CPU models for Cache property, RAS, SVM feature and add EPYC-Turin CPU model
 2025-03-07 22:47 UTC  (2+ messages)

[PATCH] driver core: faux: Check device binding state by dedicated API device_is_bound()
 2025-03-07 22:45 UTC  (3+ messages)

[PATCH v5 bpf-next 0/2] security: Propagate caller information in bpf hooks
 2025-03-07 22:45 UTC  (3+ messages)
` [PATCH v5 bpf-next 2/2] selftests/bpf: Add a kernel flag test for LSM bpf hook

[PATCH] docs: fix repository-layout when building with breaking changes
 2025-03-07 22:42 UTC  (6+ messages)
` [PATCH v2] "
  ` [PATCH] docs: fix check-docs with WITH_BREAKING_CHANGES

Using userfaultfd with KVM's async page fault handling causes processes to hung waiting for mmap_lock to be released
 2025-03-07 22:41 UTC  (5+ messages)

[syzbot] [mm?] [bcachefs?] KASAN: slab-use-after-free Read in list_lru_del
 2025-03-07 22:42 UTC  (2+ messages)

[PATCH v2 0/7] hw/virtio: Build virtio-mem.c once
 2025-03-07 22:39 UTC  (8+ messages)
` [PATCH v2 1/7] system: Replace arch_type global by qemu_arch_available() helper
` [PATCH v2 2/7] hw/acpi: Introduce acpi_builtin() helper
` [PATCH v2 3/7] hw/i386/fw_cfg: Check ACPI availability with acpi_builtin()
` [PATCH v2 4/7] hw/virtio/virtio-mem: Remove CONFIG_DEVICES include
` [PATCH v2 5/7] hw/virtio/virtio-mem: Convert VIRTIO_MEM_USABLE_EXTENT to runtime
` [PATCH v2 6/7] hw/virtio/virtio-mem: Convert VIRTIO_MEM_HAS_LEGACY_GUESTS "
` [PATCH v2 7/7] hw/virtio: Compile virtio-mem.c once

[PATCH v4 0/7] hw/hyperv: remove duplication compilation units
 2025-03-07 22:38 UTC  (6+ messages)

[PATCH] hash_readwrite_autotest: fix printf parameters
 2025-03-07 22:34 UTC  (3+ messages)

[PATCH v2 0/3] Support .gnu_debugdata for symbols in perf
 2025-03-07 22:33 UTC  (6+ messages)

[PATCH i-g-t] tests/intel/xe_pmu: Add function engine activity test
 2025-03-07 22:32 UTC  (2+ messages)

[PATCH 0/5] btrfs: block_group refcounting fixes
 2025-03-07 22:32 UTC  (5+ messages)
` [PATCH 4/5] btrfs: explicitly ref count block_group on new_bgs list

PID_MAX_LIMIT
 2025-03-07 22:31 UTC 

[PATCH v2 0/4] pipe: Trivial cleanups
 2025-03-07 22:30 UTC  (5+ messages)
` [PATCH v2 1/4] fs/pipe: Limit the slots in pipe_resize_ring()

[PATCH 00/11] Various dt-bindings fixes
 2025-03-07 22:30 UTC  (4+ messages)
` [PATCH 03/11] dt-bindings: power: qcom,kpss-acc-v2: Add MSM8916 compatible

[GIT PULL] execve fix for v6.14-rc6
 2025-03-07 22:30 UTC  (2+ messages)

[GIT PULL] ACPI fix for v6.14-rc6
 2025-03-07 22:30 UTC  (2+ messages)

[GIT PULL] io_uring fix for 6.14-rc6
 2025-03-07 22:30 UTC  (2+ messages)

[GIT PULL] Block fixes for 6.14-rc6
 2025-03-07 22:30 UTC  (2+ messages)

[GIT PULL] slab fixes for 6.14-rc5
 2025-03-07 22:30 UTC  (2+ messages)

[GIT PULL] Btrfs fixes for 6.15-rc6
 2025-03-07 22:30 UTC  (2+ messages)

[PATCH] man/man7/ip.7 Document capabilities to use IP_TRANSPARENT
 2025-03-07 22:22 UTC 

[ath:pending] BUILD SUCCESS 334be09cab090e43a61a135c73e81d2acc63370b
 2025-03-07 22:27 UTC 

[PATCH v5 00/10] Add R5F and C7xv device nodes
 2025-03-07 22:25 UTC  (2+ messages)

[PATCH 0/2] smack: fix two bugs in setting task label
 2025-03-07 22:26 UTC  (5+ messages)
` [PATCH 1/2] smack: fix bug: unprivileged task can create labels
    ` Re[2]: "

[PATCH 00/16] accel/tcg: Compile more files once
 2025-03-07 22:23 UTC  (4+ messages)
` [PATCH 14/16] include/exec: Split out helper-getpc.h

[PATCH] dt-bindings: mtd: gpmi-nand: Add compatible string for i.MX8 chips
 2025-03-07 22:05 UTC 

[PATCH 0/5] block: Improve writethrough performance
 2025-03-07 22:16 UTC  (6+ messages)
` [PATCH 1/5] file-posix: Support FUA writes
` [PATCH 2/5] block/io: Ignore FUA with cache.no-flush=on
` [PATCH 3/5] aio: Create AioPolledEvent
` [PATCH 4/5] aio-posix: Factor out adjust_polling_time()
` [PATCH 5/5] aio-posix: Separate AioPolledEvent per AioHandler

[PATCH 0/2] migration: multifd documentation
 2025-03-07 22:15 UTC  (5+ messages)
` [PATCH 1/2] migration: Add some documentation for multifd

[PATCHSET v2 sched_ext/for-6.15] sched_ext: Enhance built-in idle selection with allowed CPUs
 2025-03-07 22:17 UTC  (3+ messages)
` [PATCH 3/6] sched_ext: idle: Introduce the concept of "

[PATCH i-g-t v5 0/6] Xe: Add tests for PXP
 2025-03-07 22:15 UTC  (2+ messages)
` ✗ Xe.CI.Full: failure for Xe: Add tests for PXP (rev6)

[PATCH 0/2] Battlemage D3Cold issues
 2025-03-07 22:15 UTC  (3+ messages)
` [PATCH 1/2] drm/xe/pm: Temporarily disable D3Cold on BMG

[tip:x86/asm] BUILD SUCCESS aa3942d4d12ef57f031faa2772fe410c24191e36
 2025-03-07 22:14 UTC 

[f2fs-dev] [PATCH 0/4] f2fs: Remove uses of writepage
 2025-03-07 22:13 UTC  (4+ messages)

[tip:sched/core] BUILD SUCCESS fd881d0a085fc54354414aed990ccf05f282ba53
 2025-03-07 22:13 UTC 


This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.