From: "Alexandre Courbot" <acourbot@nvidia.com>
To: "onur-ozkan" <work@onurozkan.dev>, <linux-clk@vger.kernel.org>,
<rust-for-linux@vger.kernel.org>, <linux-kernel@vger.kernel.org>
Cc: <mturquette@baylibre.com>, <sboyd@kernel.org>, <ojeda@kernel.org>,
<alex.gaynor@gmail.com>, <boqun.feng@gmail.com>,
<gary@garyguo.net>, <bjorn3_gh@protonmail.com>,
<lossin@kernel.org>, <a.hindborg@kernel.org>,
<aliceryhl@google.com>, <tmgross@umich.edu>, <dakr@kernel.org>
Subject: Re: [PATCH] Various improvements on clock abstractions
Date: Tue, 17 Jun 2025 16:52:02 +0900 [thread overview]
Message-ID: <DAON8H30Y6VO.2WKLGX2Q9DORU@nvidia.com> (raw)
In-Reply-To: <20250616200103.24245-1-work@onurozkan.dev>
On Tue Jun 17, 2025 at 5:01 AM JST, onur-ozkan wrote:
> A few changes to improve the clock abstractions and make them a little
> more idiomatic:
>
> 1. `impl Hertz` functions are now constant and compile-time evaluable.
> 2. `Hertz` conversions are now done with constant variables, which should
"constant variable" is an oxymoron. :) I think you just want to say
"constant" here.
> make them more readable.
> 3. `con_id` is handled in a single line using `map_or` instead of using
> nested if-else blocks.
Please split these 3 changes into 3 patches, I agree that they are
trivial but a patch should do a single thing. This makes review simpler
and allows to apply only part of the changes if e.g. one of them needs
further discussion or is rejected.
The changes in themselves look good though!
next prev parent reply other threads:[~2025-06-17 7:52 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-06-16 20:01 [PATCH] Various improvements on clock abstractions onur-ozkan
2025-06-16 20:40 ` Miguel Ojeda
[not found] ` <42151750134012@mail.yandex.com>
2025-06-17 6:55 ` Miguel Ojeda
2025-06-19 6:45 ` Viresh Kumar
2025-06-19 10:05 ` Onur
2025-06-19 13:48 ` Alexandre Courbot
2025-06-17 7:52 ` Alexandre Courbot [this message]
-- strict thread matches above, loose matches on Subject: below --
2025-06-16 15:18 onur-ozkan
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=DAON8H30Y6VO.2WKLGX2Q9DORU@nvidia.com \
--to=acourbot@nvidia.com \
--cc=a.hindborg@kernel.org \
--cc=alex.gaynor@gmail.com \
--cc=aliceryhl@google.com \
--cc=bjorn3_gh@protonmail.com \
--cc=boqun.feng@gmail.com \
--cc=dakr@kernel.org \
--cc=gary@garyguo.net \
--cc=linux-clk@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=lossin@kernel.org \
--cc=mturquette@baylibre.com \
--cc=ojeda@kernel.org \
--cc=rust-for-linux@vger.kernel.org \
--cc=sboyd@kernel.org \
--cc=tmgross@umich.edu \
--cc=work@onurozkan.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.