All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Antonin Godard" <antonin.godard@bootlin.com>
To: "Quentin Schulz" <quentin.schulz@cherry.de>,
	<docs@lists.yoctoproject.org>
Cc: "Thomas Petazzoni" <thomas.petazzoni@bootlin.com>
Subject: Re: [docs] [PATCH 2/3] tools/check-glossaries: fix default doc path
Date: Fri, 03 Jul 2026 13:34:47 +0200	[thread overview]
Message-ID: <DJOWKKVOEWNV.2NBEEBEC1C39P@bootlin.com> (raw)
In-Reply-To: <ade7e005-93df-433c-8b02-e520b0e9478b@cherry.de>

Hi,

On Fri Jul 3, 2026 at 12:22 PM CEST, Quentin Schulz wrote:
> Hi Antonin,
>
> On 7/2/26 3:59 PM, Antonin Godard via lists.yoctoproject.org wrote:
>> This default path pointing to the documentation was wrong, fix it.
>> 
>> Signed-off-by: Antonin Godard <antonin.godard@bootlin.com>
>> ---
>>   documentation/tools/check-glossaries | 2 +-
>>   1 file changed, 1 insertion(+), 1 deletion(-)
>> 
>> diff --git a/documentation/tools/check-glossaries b/documentation/tools/check-glossaries
>> index 9f1a47126..6bfddcfda 100755
>> --- a/documentation/tools/check-glossaries
>> +++ b/documentation/tools/check-glossaries
>> @@ -14,7 +14,7 @@ def parse_arguments() -> argparse.Namespace:
>>   
>>       parser.add_argument("-d", "--docs-dir",
>>                           type=Path,
>> -                        default=Path(os.path.dirname(os.path.realpath(__file__))) / "documentation",
>> +                        default=Path(os.path.dirname(os.path.realpath(__file__))) / "../",
>
> Path(__file__).resolve().parent.parent
>
> is much more readable IMO (and also, we avoid the mental gymnastic of 
> seeing ../ and having to remove the last directory in the path.
>
> Reviewed-by: Quentin Schulz <quentin.schulz@cherry.de>

True, we also don't need the os module with this anymore, thanks! v2 incoming.

Antonin


  reply	other threads:[~2026-07-03 11:35 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-02 13:59 [PATCH 0/3] Add pre-commit support Antonin Godard
2026-07-02 13:59 ` [PATCH 1/3] tools/check-glossaries: return 1 in case of failure Antonin Godard
2026-07-03 10:17   ` [docs] " Quentin Schulz
2026-07-02 13:59 ` [PATCH 2/3] tools/check-glossaries: fix default doc path Antonin Godard
2026-07-03 10:22   ` [docs] " Quentin Schulz
2026-07-03 11:34     ` Antonin Godard [this message]
2026-07-02 13:59 ` [PATCH 3/3] Add a pre-commit hook to check the glossaries Antonin Godard
2026-07-03 10:53   ` [docs] " Quentin Schulz

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=DJOWKKVOEWNV.2NBEEBEC1C39P@bootlin.com \
    --to=antonin.godard@bootlin.com \
    --cc=docs@lists.yoctoproject.org \
    --cc=quentin.schulz@cherry.de \
    --cc=thomas.petazzoni@bootlin.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.