From: Baoquan He <bhe@redhat.com>
To: Christophe Leroy <christophe.leroy@csgroup.eu>
Cc: "linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"linux-mm@kvack.org" <linux-mm@kvack.org>,
"akpm@linux-foundation.org" <akpm@linux-foundation.org>,
"hch@infradead.org" <hch@infradead.org>,
"agordeev@linux.ibm.com" <agordeev@linux.ibm.com>,
"wangkefeng.wang@huawei.com" <wangkefeng.wang@huawei.com>,
"schnelle@linux.ibm.com" <schnelle@linux.ibm.com>,
"David.Laight@ACULAB.COM" <David.Laight@aculab.com>,
"shorne@gmail.com" <shorne@gmail.com>,
Brian Cain <bcain@quicinc.com>, Mark Brown <broonie@kernel.org>,
Linus Walleij <linus.walleij@linaro.org>,
"linux-hexagon@vger.kernel.org" <linux-hexagon@vger.kernel.org>
Subject: Re: [PATCH v3 01/11] hexagon: mm: Convert to GENERIC_IOREMAP
Date: Mon, 10 Oct 2022 08:17:02 +0800 [thread overview]
Message-ID: <Y0NkfggJTI1q/Yvy@MiWiFi-R3L-srv> (raw)
In-Reply-To: <83f292b8-0639-56b2-6dac-0475c34f623c@csgroup.eu>
On 10/09/22 at 04:39pm, Christophe Leroy wrote:
>
>
> Le 09/10/2022 à 12:31, Baoquan He a écrit :
> > By taking GENERIC_IOREMAP method, the generic ioremap_prot() and
> > iounmap() are visible and available to arch. Arch only needs to
> > provide implementation of arch_ioremap() or arch_iounmap() if there's
> > arch specific handling needed in its ioremap() or iounmap(). This
> > change will simplify implementation by removing duplicated codes with
> > generic ioremap() and iounmap(), and has the equivalent functioality.
> >
> > For hexagon, the current ioremap() and iounmap() are the same as
> > generic version. After taking GENERIC_IOREMAP way, the old ioremap()
> > and iounmap() can be completely removed.
> >
> > Signed-off-by: Baoquan He <bhe@redhat.com>
> > Cc: Brian Cain <bcain@quicinc.com>
> > Cc: Mark Brown <broonie@kernel.org>
> > Cc: Linus Walleij <linus.walleij@linaro.org>
> > Cc: linux-hexagon@vger.kernel.org
> > ---
> > v2->v3:
> > Rewrite patch log.
> > Put it at the beginning of patchset since it doesn't introduce new
> > arch_ioremap()/arch_iounmap().
> >
> > arch/hexagon/Kconfig | 1 +
> > arch/hexagon/include/asm/io.h | 9 +++++--
> > arch/hexagon/mm/ioremap.c | 44 -----------------------------------
> > 3 files changed, 8 insertions(+), 46 deletions(-)
> > delete mode 100644 arch/hexagon/mm/ioremap.c
> >
> > diff --git a/arch/hexagon/Kconfig b/arch/hexagon/Kconfig
> > index 54eadf265178..17afffde1a7f 100644
> > --- a/arch/hexagon/Kconfig
> > +++ b/arch/hexagon/Kconfig
> > @@ -25,6 +25,7 @@ config HEXAGON
> > select NEED_SG_DMA_LENGTH
> > select NO_IOPORT_MAP
> > select GENERIC_IOMAP
> > + select GENERIC_IOREMAP
> > select GENERIC_SMP_IDLE_THREAD
> > select STACKTRACE_SUPPORT
> > select GENERIC_CLOCKEVENTS_BROADCAST
> > diff --git a/arch/hexagon/include/asm/io.h b/arch/hexagon/include/asm/io.h
> > index 46a099de85b7..dcd9cbbf5934 100644
> > --- a/arch/hexagon/include/asm/io.h
> > +++ b/arch/hexagon/include/asm/io.h
> > @@ -170,8 +170,13 @@ static inline void writel(u32 data, volatile void __iomem *addr)
> > #define writew_relaxed __raw_writew
> > #define writel_relaxed __raw_writel
> >
> > -void __iomem *ioremap(unsigned long phys_addr, unsigned long size);
> > -#define ioremap_uc(X, Y) ioremap((X), (Y))
> > +/*
> > + * I/O memory mapping functions.
> > + */
> > +#define _PAGE_IOREMAP (_PAGE_PRESENT | _PAGE_READ | _PAGE_WRITE | \
> > + (__HEXAGON_C_DEV << 6))
> > +
> > +#define ioremap_uc(addr, size) ioremap((addr), (size))
>
> Why do you need to change this macro ?
I don't like the X, Y since they look meaningless. I can change back if
you like the old one. Thanks for checking.
next prev parent reply other threads:[~2022-10-10 0:17 UTC|newest]
Thread overview: 45+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-10-09 10:31 [PATCH v3 00/11] mm: ioremap: Convert architectures to take GENERIC_IOREMAP way Baoquan He
2022-10-09 10:31 ` [PATCH v3 01/11] hexagon: mm: Convert to GENERIC_IOREMAP Baoquan He
2022-10-09 16:39 ` Christophe Leroy
2022-10-10 0:17 ` Baoquan He [this message]
2022-10-09 10:31 ` [PATCH v3 02/11] openrisc: mm: remove unneeded early ioremap code Baoquan He
2022-10-09 10:31 ` Baoquan He
2022-10-09 10:31 ` [PATCH v3 03/11] mm/ioremap: change the return value of io[re|un]map_allowed and rename Baoquan He
2022-10-09 10:31 ` Baoquan He
2022-10-09 11:13 ` Kefeng Wang
2022-10-09 11:13 ` Kefeng Wang
2022-10-10 0:25 ` Baoquan He
2022-10-10 0:25 ` Baoquan He
2022-10-10 0:55 ` Kefeng Wang
2022-10-10 0:55 ` Kefeng Wang
2022-10-09 10:31 ` [PATCH v3 04/11] mm: ioremap: allow ARCH to have its own ioremap definition Baoquan He
2022-10-09 10:31 ` [PATCH v3 05/11] arc: mm: Convert to GENERIC_IOREMAP Baoquan He
2022-10-09 10:31 ` Baoquan He
2022-10-12 10:17 ` Christophe Leroy
2022-10-12 10:17 ` Christophe Leroy
2022-10-13 9:51 ` Baoquan He
2022-10-13 9:51 ` Baoquan He
2022-10-09 10:31 ` [PATCH v3 06/11] ia64: " Baoquan He
2022-10-09 10:31 ` Baoquan He
2022-10-09 10:31 ` [PATCH v3 07/11] openrisc: " Baoquan He
2022-10-09 10:31 ` Baoquan He
2022-10-09 10:31 ` [PATCH v3 08/11] parisc: " Baoquan He
2022-10-09 10:31 ` [PATCH v3 09/11] s390: " Baoquan He
2022-10-09 13:54 ` kernel test robot
2022-10-10 10:38 ` Baoquan He
2022-10-10 10:38 ` Baoquan He
2022-10-10 11:53 ` Niklas Schnelle
2022-10-10 11:53 ` Niklas Schnelle
2022-10-11 3:00 ` Baoquan He
2022-10-11 3:00 ` Baoquan He
2022-10-11 15:16 ` Niklas Schnelle
2022-10-12 5:52 ` Baoquan He
2022-10-12 7:37 ` Niklas Schnelle
2022-10-12 9:20 ` Baoquan He
2022-10-09 10:31 ` [PATCH v3 10/11] sh: " Baoquan He
2022-10-09 14:16 ` kernel test robot
2022-10-09 10:31 ` [PATCH v3 11/11] xtensa: " Baoquan He
2022-10-09 16:12 ` kernel test robot
2022-10-10 2:47 ` Baoquan He
2022-10-10 2:47 ` Baoquan He
2022-10-12 10:08 ` [PATCH v3 00/11] mm: ioremap: Convert architectures to take GENERIC_IOREMAP way Christophe Leroy
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Y0NkfggJTI1q/Yvy@MiWiFi-R3L-srv \
--to=bhe@redhat.com \
--cc=David.Laight@aculab.com \
--cc=agordeev@linux.ibm.com \
--cc=akpm@linux-foundation.org \
--cc=bcain@quicinc.com \
--cc=broonie@kernel.org \
--cc=christophe.leroy@csgroup.eu \
--cc=hch@infradead.org \
--cc=linus.walleij@linaro.org \
--cc=linux-hexagon@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=schnelle@linux.ibm.com \
--cc=shorne@gmail.com \
--cc=wangkefeng.wang@huawei.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.